summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/anthy/anthy-4300b.ebuild19
-rw-r--r--app-i18n/anthy/anthy-4700.ebuild19
-rw-r--r--app-i18n/canna/canna-3.6_p4.ebuild17
-rw-r--r--app-i18n/canna/canna-3.7.ebuild17
-rw-r--r--app-i18n/canna/canna-3.7_p1.ebuild17
-rw-r--r--app-i18n/canna/canna-3.7_p2.ebuild17
-rw-r--r--app-i18n/canuum/canuum-3.7_p2.ebuild14
-rw-r--r--app-i18n/dbskkd-cdb/dbskkd-cdb-1.01-r1.ebuild15
-rw-r--r--app-i18n/freewnn/freewnn-1.1.1_alpha17.ebuild10
-rw-r--r--app-i18n/freewnn/freewnn-1.1.1_alpha20.ebuild10
10 files changed, 63 insertions, 92 deletions
diff --git a/app-i18n/anthy/anthy-4300b.ebuild b/app-i18n/anthy/anthy-4300b.ebuild
index 80ea25e1175e..fb9c835b34cc 100644
--- a/app-i18n/anthy/anthy-4300b.ebuild
+++ b/app-i18n/anthy/anthy-4300b.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4300b.ebuild,v 1.8 2004/06/24 21:43:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4300b.ebuild,v 1.9 2004/06/28 01:40:27 vapier Exp $
inherit elisp-common
-IUSE="emacs"
-
-DESCRIPTION="Anthy -- free and secure Japanese input system"
+DESCRIPTION="free and secure Japanese input system"
HOMEPAGE="http://anthy.sourceforge.jp/"
SRC_URI="mirror://sourceforge.jp/anthy/5332/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 alpha sparc"
SLOT="0"
+KEYWORDS="x86 sparc alpha"
+IUSE="emacs"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
!app-i18n/anthy-ss
emacs? ( virtual/emacs )"
SITEFILE="50anthy-gentoo.el"
src_compile() {
-
- econf `use emacs >/dev/null 2>&1 || echo EMACS=no` || die
+ local myconf=""
+ use emacs || myconf="EMACS=no"
+ econf ${myconf} || die
emake || die
}
src_install() {
-
einstall || die
use emacs && elisp-site-file-install ${FILESDIR}/${SITEFILE}
@@ -37,11 +36,9 @@ src_install() {
}
pkg_postinst() {
-
use emacs && elisp-site-regen
}
pkg_postrm() {
-
use emacs && elisp-site-regen
}
diff --git a/app-i18n/anthy/anthy-4700.ebuild b/app-i18n/anthy/anthy-4700.ebuild
index a7638424da65..b5c67990aea7 100644
--- a/app-i18n/anthy/anthy-4700.ebuild
+++ b/app-i18n/anthy/anthy-4700.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4700.ebuild,v 1.4 2004/06/24 21:43:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-4700.ebuild,v 1.5 2004/06/28 01:40:27 vapier Exp $
inherit elisp-common
-IUSE="emacs"
-
-DESCRIPTION="Anthy -- free and secure Japanese input system"
+DESCRIPTION="free and secure Japanese input system"
HOMEPAGE="http://anthy.sourceforge.jp/"
SRC_URI="mirror://sourceforge.jp/anthy/6621/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 alpha sparc"
SLOT="0"
+KEYWORDS="x86 sparc alpha"
+IUSE="emacs"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
!app-i18n/anthy-ss
emacs? ( virtual/emacs )"
SITEFILE="50anthy-gentoo.el"
src_compile() {
-
- econf `use emacs >/dev/null 2>&1 || echo EMACS=no` || die
+ local myconf=""
+ use emacs || myconf="EMACS=no"
+ econf ${myconf} || die
emake || die
}
src_install() {
-
einstall || die
use emacs && elisp-site-file-install ${FILESDIR}/${SITEFILE}
@@ -37,11 +36,9 @@ src_install() {
}
pkg_postinst() {
-
use emacs && elisp-site-regen
}
pkg_postrm() {
-
use emacs && elisp-site-regen
}
diff --git a/app-i18n/canna/canna-3.6_p4.ebuild b/app-i18n/canna/canna-3.6_p4.ebuild
index 809dc148e34e..720f8bd42b84 100644
--- a/app-i18n/canna/canna-3.6_p4.ebuild
+++ b/app-i18n/canna/canna-3.6_p4.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p4.ebuild,v 1.16 2004/06/24 21:43:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p4.ebuild,v 1.17 2004/06/28 01:41:41 vapier Exp $
inherit cannadic eutils
-IUSE="doc"
-
MY_P="Canna${PV//[._]/}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
@@ -14,13 +12,14 @@ SRC_URI="mirror://sourceforge.jp/canna/6059/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86 alpha ppc sparc"
+KEYWORDS="x86 ppc sparc alpha"
+IUSE="doc"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
doc? ( app-text/ptex )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_P}"
@@ -99,8 +98,7 @@ src_install() {
fperms 775 /var/lib/canna/dic/{user,group}
}
-pkg_prerm () {
-
+pkg_prerm() {
if [ -S /tmp/.iroha_unix/IROHA ] ; then
einfo
einfo "Stopping Canna for safe unmerge"
@@ -109,8 +107,7 @@ pkg_prerm () {
fi
}
-pkg_postrm () {
-
+pkg_postrm() {
if [ -f /usr/sbin/cannaserver ] ; then
update-cannadic-dir
einfo
diff --git a/app-i18n/canna/canna-3.7.ebuild b/app-i18n/canna/canna-3.7.ebuild
index dfd154694458..4aab418e040d 100644
--- a/app-i18n/canna/canna-3.7.ebuild
+++ b/app-i18n/canna/canna-3.7.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7.ebuild,v 1.11 2004/06/24 21:43:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7.ebuild,v 1.12 2004/06/28 01:41:41 vapier Exp $
inherit cannadic eutils
-IUSE="doc"
-
MY_P="Canna${PV//./}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
@@ -15,12 +13,13 @@ SRC_URI="mirror://sourceforge.jp/canna/7240/${MY_P}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha amd64"
+IUSE="doc"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
doc? ( app-text/ptex )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_P}"
@@ -36,7 +35,6 @@ src_unpack() {
}
src_compile() {
-
xmkmf || die
# Remove VENDORNAME, see bug #48229
@@ -105,7 +103,6 @@ src_install() {
}
pkg_postinst() {
-
update-cannadic-dir
einfo
einfo "Canna dictionary format has been changed."
@@ -113,8 +110,7 @@ pkg_postinst() {
einfo
}
-pkg_prerm () {
-
+pkg_prerm() {
if [ -S /tmp/.iroha_unix/IROHA ] ; then
# make sure cannaserver get stopped because otherwise
# we cannot stop it with /etc/init.d after emerge -C canna
@@ -126,8 +122,7 @@ pkg_prerm () {
fi
}
-pkg_postrm () {
-
+pkg_postrm() {
if [ -f /usr/sbin/cannaserver -a -e ${T}/canna.cookie ] ; then
#update-cannadic-dir
einfo
diff --git a/app-i18n/canna/canna-3.7_p1.ebuild b/app-i18n/canna/canna-3.7_p1.ebuild
index d66dd326f52f..9f3aa7fdbb27 100644
--- a/app-i18n/canna/canna-3.7_p1.ebuild
+++ b/app-i18n/canna/canna-3.7_p1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7_p1.ebuild,v 1.5 2004/06/24 21:43:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7_p1.ebuild,v 1.6 2004/06/28 01:41:41 vapier Exp $
inherit cannadic eutils
-IUSE="doc"
-
MY_P="Canna${PV//./}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
@@ -15,12 +13,13 @@ SRC_URI="mirror://sourceforge.jp/canna/7449/${MY_P/_/}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha ~amd64"
+IUSE="doc"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
doc? ( app-text/ptex )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_P/_/}"
@@ -36,7 +35,6 @@ src_unpack() {
}
src_compile() {
-
xmkmf || die
# Remove VENDORNAME, see bug #48229
@@ -105,7 +103,6 @@ src_install() {
}
pkg_postinst() {
-
update-cannadic-dir
einfo
einfo "Canna dictionary format has been changed."
@@ -113,8 +110,7 @@ pkg_postinst() {
einfo
}
-pkg_prerm () {
-
+pkg_prerm() {
if [ -S /tmp/.iroha_unix/IROHA ] ; then
# make sure cannaserver get stopped because otherwise
# we cannot stop it with /etc/init.d after emerge -C canna
@@ -126,8 +122,7 @@ pkg_prerm () {
fi
}
-pkg_postrm () {
-
+pkg_postrm() {
if [ -f /usr/sbin/cannaserver -a -e ${T}/canna.cookie ] ; then
#update-cannadic-dir
einfo
diff --git a/app-i18n/canna/canna-3.7_p2.ebuild b/app-i18n/canna/canna-3.7_p2.ebuild
index adb43032ae32..133c6cc18d5f 100644
--- a/app-i18n/canna/canna-3.7_p2.ebuild
+++ b/app-i18n/canna/canna-3.7_p2.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7_p2.ebuild,v 1.4 2004/06/24 21:43:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7_p2.ebuild,v 1.5 2004/06/28 01:41:41 vapier Exp $
inherit cannadic eutils
-IUSE="doc"
-
MY_P="Canna${PV//./}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
@@ -15,12 +13,13 @@ SRC_URI="mirror://sourceforge.jp/canna/9558/${MY_P/_/}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ppc ~sparc ~alpha ~amd64"
+IUSE="doc"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
doc? ( app-text/ptex )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_P/_/}"
@@ -36,7 +35,6 @@ src_unpack() {
}
src_compile() {
-
xmkmf || die
#make libCannaDir=../lib/canna canna || die
@@ -102,7 +100,6 @@ src_install() {
}
pkg_postinst() {
-
update-cannadic-dir
einfo
einfo "Canna dictionary format has been changed."
@@ -110,8 +107,7 @@ pkg_postinst() {
einfo
}
-pkg_prerm () {
-
+pkg_prerm() {
if [ -S /tmp/.iroha_unix/IROHA ] ; then
# make sure cannaserver get stopped because otherwise
# we cannot stop it with /etc/init.d after emerge -C canna
@@ -123,8 +119,7 @@ pkg_prerm () {
fi
}
-pkg_postrm () {
-
+pkg_postrm() {
if [ -f /usr/sbin/cannaserver -a -e ${T}/canna.cookie ] ; then
#update-cannadic-dir
einfo
diff --git a/app-i18n/canuum/canuum-3.7_p2.ebuild b/app-i18n/canuum/canuum-3.7_p2.ebuild
index aafaf78f4654..ff1cf0bd39f0 100644
--- a/app-i18n/canuum/canuum-3.7_p2.ebuild
+++ b/app-i18n/canuum/canuum-3.7_p2.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canuum/canuum-3.7_p2.ebuild,v 1.2 2004/06/24 21:44:03 agriffis Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canuum/canuum-3.7_p2.ebuild,v 1.3 2004/06/28 01:42:05 vapier Exp $
MY_P="Canna${PV//[._]/}"
S="${WORKDIR}/${MY_P}/${PN}"
@@ -11,11 +9,12 @@ DESCRIPTION="Canna input method engine client for console"
HOMEPAGE="http://canna.sourceforge.jp/"
SRC_URI="mirror://sourceforge.jp/canna/9558/${MY_P}.tar.bz2"
-KEYWORDS="~x86"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
app-i18n/canna
dev-libs/libspt"
@@ -28,9 +27,8 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "install failed"
make DESTDIR=${D} install.man || die "install man failed"
-
- dodoc COPYRIGHT README*
+ dodoc README*
}
diff --git a/app-i18n/dbskkd-cdb/dbskkd-cdb-1.01-r1.ebuild b/app-i18n/dbskkd-cdb/dbskkd-cdb-1.01-r1.ebuild
index 10caf1ec7621..d632bd5c3e09 100644
--- a/app-i18n/dbskkd-cdb/dbskkd-cdb-1.01-r1.ebuild
+++ b/app-i18n/dbskkd-cdb/dbskkd-cdb-1.01-r1.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/dbskkd-cdb/dbskkd-cdb-1.01-r1.ebuild,v 1.6 2004/06/24 21:44:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/dbskkd-cdb/dbskkd-cdb-1.01-r1.ebuild,v 1.7 2004/06/28 01:42:35 vapier Exp $
DESCRIPTION="Yet another Dictionary server for the SKK Japanese-input software"
-
HOMEPAGE="http://www.ne.jp/asahi/bdx/info/software/jp-dbskkd.html"
SRC_URI="http://www.ne.jp/asahi/bdx/info/software/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-
KEYWORDS="x86 ~ppc sparc alpha amd64"
-
IUSE=""
-PROVIDE="virtual/skkserv"
-
DEPEND="dev-db/freecdb"
RDEPEND="app-i18n/skk-jisyo-cdb
virtual/inetd"
+PROVIDE="virtual/skkserv"
src_compile() {
- emake SERVERDIR=/usr/sbin \
+ emake \
+ SERVERDIR=/usr/sbin \
COMPAT="-DJISHO_FILE=\\\"/usr/share/skk/SKK-JISYO.L.cdb\\\"" \
LDFLAGS="-lutil -lfreecdb" \
CC="cc ${CFLAGS}" || die
@@ -43,9 +40,9 @@ src_install() {
dodoc LICENSE Release-Notes.{English,Japanese}
}
-pkg_postinst () {
+pkg_postinst() {
ewarn "The skk server is disabled by default."
- if test -f /usr/sbin/xinetd; then
+ if test -f ${ROOT}/usr/sbin/xinetd; then
ewarn "Please check /etc/xinetd.d/dbskkd-cdb"
else
ewarn "Please see /etc/inetd.skkserv for an example inetd configuration line"
diff --git a/app-i18n/freewnn/freewnn-1.1.1_alpha17.ebuild b/app-i18n/freewnn/freewnn-1.1.1_alpha17.ebuild
index ce4973b68a8b..5063bf686e1b 100644
--- a/app-i18n/freewnn/freewnn-1.1.1_alpha17.ebuild
+++ b/app-i18n/freewnn/freewnn-1.1.1_alpha17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/freewnn/freewnn-1.1.1_alpha17.ebuild,v 1.6 2004/06/24 21:45:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/freewnn/freewnn-1.1.1_alpha17.ebuild,v 1.7 2004/06/28 01:44:05 vapier Exp $
inherit eutils
@@ -10,12 +10,12 @@ DESCRIPTION="Network-Extensible Kana-to-Kanji Conversion System"
HOMEPAGE="http://www.freewnn.org/"
SRC_URI="ftp://ftp.freewnn.org/pub/FreeWnn/alpha/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~alpha ~ia64 ~amd64 ~ppc"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ia64"
IUSE="X ipv6"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
X? ( virtual/x11 )"
S="${WORKDIR}/${MY_P}/Xsi"
@@ -46,7 +46,7 @@ src_compile() {
#make || die
}
-src_install () {
+src_install() {
# install executables, libs ,dictionaries
make DESTDIR=${D} install || die "installation failed"
# install man pages
diff --git a/app-i18n/freewnn/freewnn-1.1.1_alpha20.ebuild b/app-i18n/freewnn/freewnn-1.1.1_alpha20.ebuild
index 4d0c0fbb3327..b73a956c3ba4 100644
--- a/app-i18n/freewnn/freewnn-1.1.1_alpha20.ebuild
+++ b/app-i18n/freewnn/freewnn-1.1.1_alpha20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/freewnn/freewnn-1.1.1_alpha20.ebuild,v 1.9 2004/06/24 21:45:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/freewnn/freewnn-1.1.1_alpha20.ebuild,v 1.10 2004/06/28 01:44:05 vapier Exp $
MY_P="FreeWnn-${PV/_alpha/-a0}"
@@ -8,12 +8,12 @@ DESCRIPTION="Network-Extensible Kana-to-Kanji Conversion System"
HOMEPAGE="http://www.freewnn.org/"
SRC_URI="ftp://ftp.freewnn.org/pub/FreeWnn/alpha/${MY_P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc alpha ia64 -amd64 ppc"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha -amd64 ia64"
IUSE="X ipv6"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
X? ( virtual/x11 )"
S="${WORKDIR}/FreeWnn-1.10-pl020"
@@ -39,7 +39,7 @@ src_compile() {
#make || die
}
-src_install () {
+src_install() {
# install executables, libs ,dictionaries
make DESTDIR=${D} install || die "installation failed"
# install man pages