summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/turbokid/ChangeLog9
-rw-r--r--dev-python/turbokid/files/digest-turbokid-1.0.43
-rw-r--r--dev-python/turbokid/turbokid-1.0.4.ebuild27
3 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/turbokid/ChangeLog b/dev-python/turbokid/ChangeLog
index a54f7fcc1d4e..419c1f8caf30 100644
--- a/dev-python/turbokid/ChangeLog
+++ b/dev-python/turbokid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/turbokid
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/turbokid/ChangeLog,v 1.4 2007/07/19 05:58:51 pythonhead Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/turbokid/ChangeLog,v 1.5 2008/01/04 18:06:51 hawking Exp $
+
+*turbokid-1.0.4 (04 Jan 2008)
+
+ 04 Jan 2008; Ali Polatel <hawking@gentoo.org> +turbokid-1.0.4.ebuild:
+ Version bump.
*turbokid-1.0.2 (19 Jul 2007)
diff --git a/dev-python/turbokid/files/digest-turbokid-1.0.4 b/dev-python/turbokid/files/digest-turbokid-1.0.4
new file mode 100644
index 000000000000..79076834f048
--- /dev/null
+++ b/dev-python/turbokid/files/digest-turbokid-1.0.4
@@ -0,0 +1,3 @@
+MD5 0dc9eba1783244a9800b8c4316d38341 TurboKid-1.0.4.tar.gz 4080
+RMD160 407792b9e77ec53314955daf83bd32e5b0b9be07 TurboKid-1.0.4.tar.gz 4080
+SHA256 4a570aa1aae4595c4cc99693d25894e6448cbf841d16e317c23be0a213bd7ac0 TurboKid-1.0.4.tar.gz 4080
diff --git a/dev-python/turbokid/turbokid-1.0.4.ebuild b/dev-python/turbokid/turbokid-1.0.4.ebuild
new file mode 100644
index 000000000000..640bc168fe0f
--- /dev/null
+++ b/dev-python/turbokid/turbokid-1.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/turbokid/turbokid-1.0.4.ebuild,v 1.1 2008/01/04 18:06:51 hawking Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+MY_PN="TurboKid"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python template plugin that supports Kid templates"
+HOMEPAGE="http://www.turbogears.org/docs/plugins/template.html"
+SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+S="${WORKDIR}/${MY_P}"
+RDEPEND=">=dev-python/kid-0.9.6"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+src_test() {
+ PYTHONPATH=. "${python}" setup.py test || die "tests failed"
+}