summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/kgraphviewer/ChangeLog9
-rw-r--r--media-gfx/kgraphviewer/files/kgraphviewer-2.1.1-boost-1.50.patch32
-rw-r--r--media-gfx/kgraphviewer/kgraphviewer-2.1.1.ebuild6
3 files changed, 42 insertions, 5 deletions
diff --git a/media-gfx/kgraphviewer/ChangeLog b/media-gfx/kgraphviewer/ChangeLog
index 918e9f4f636d..de4a67e24897 100644
--- a/media-gfx/kgraphviewer/ChangeLog
+++ b/media-gfx/kgraphviewer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/kgraphviewer
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/kgraphviewer/ChangeLog,v 1.7 2011/10/28 23:59:28 abcd Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/kgraphviewer/ChangeLog,v 1.8 2012/07/10 16:32:16 kensington Exp $
+
+ 10 Jul 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/kgraphviewer-2.1.1-boost-1.50.patch, kgraphviewer-2.1.1.ebuild:
+ Fix build with boost-1.50, wrt bug #425478.
28 Oct 2011; Jonathan Callen <abcd@gentoo.org> kgraphviewer-2.1.1.ebuild:
Bump to EAPI=4; set KDE_HANDBOOK
@@ -37,4 +41,3 @@
28 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
+kgraphviewer-2.0.2.ebuild:
Initial commit wrt #135245.
-
diff --git a/media-gfx/kgraphviewer/files/kgraphviewer-2.1.1-boost-1.50.patch b/media-gfx/kgraphviewer/files/kgraphviewer-2.1.1-boost-1.50.patch
new file mode 100644
index 000000000000..46c9490629cf
--- /dev/null
+++ b/media-gfx/kgraphviewer/files/kgraphviewer-2.1.1-boost-1.50.patch
@@ -0,0 +1,32 @@
+From 470bf0a4774a600dbd958b781342589a337d8898 Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Wed, 11 Jul 2012 01:58:00 +1000
+Subject: [PATCH] Fix build with boost-1.50
+
+REVIEW: 105494
+---
+ src/part/DotGraphParsingHelper.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/part/DotGraphParsingHelper.cpp b/src/part/DotGraphParsingHelper.cpp
+index 69cac49..7d46837 100644
+--- a/src/part/DotGraphParsingHelper.cpp
++++ b/src/part/DotGraphParsingHelper.cpp
+@@ -26,10 +26,10 @@
+ #include "graphedge.h"
+
+ #include <boost/throw_exception.hpp>
+-#include <boost/spirit/core.hpp>
+-#include <boost/spirit/utility/distinct.hpp>
+-#include <boost/spirit/utility/loops.hpp>
+-#include <boost/spirit/utility/confix.hpp>
++#include <boost/spirit/include/classic_core.hpp>
++#include <boost/spirit/include/classic_distinct.hpp>
++#include <boost/spirit/include/classic_loops.hpp>
++#include <boost/spirit/include/classic_confix.hpp>
+
+
+ #include <iostream>
+--
+1.7.11.1
+
diff --git a/media-gfx/kgraphviewer/kgraphviewer-2.1.1.ebuild b/media-gfx/kgraphviewer/kgraphviewer-2.1.1.ebuild
index 1966cc22659e..4e13a25555ff 100644
--- a/media-gfx/kgraphviewer/kgraphviewer-2.1.1.ebuild
+++ b/media-gfx/kgraphviewer/kgraphviewer-2.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/kgraphviewer/kgraphviewer-2.1.1.ebuild,v 1.2 2011/10/28 23:59:28 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/kgraphviewer/kgraphviewer-2.1.1.ebuild,v 1.3 2012/07/10 16:32:16 kensington Exp $
EAPI=4
@@ -26,3 +26,5 @@ RDEPEND="
DEPEND="${RDEPEND}
>=dev-libs/boost-1.38
"
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.50.patch" )