summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/endeavour/endeavour-2.3.6.ebuild16
-rw-r--r--app-misc/endeavour/endeavour-2.4.6.ebuild13
-rw-r--r--app-misc/endeavour/files/endeavour-2.4.6-gcc33.patch31
-rw-r--r--games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch31
-rw-r--r--games-action/xshipwars/xshipwars-1.34.0.ebuild4
5 files changed, 82 insertions, 13 deletions
diff --git a/app-misc/endeavour/endeavour-2.3.6.ebuild b/app-misc/endeavour/endeavour-2.3.6.ebuild
index 7809d04631c5..9f9c3082d51e 100644
--- a/app-misc/endeavour/endeavour-2.3.6.ebuild
+++ b/app-misc/endeavour/endeavour-2.3.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/endeavour/endeavour-2.3.6.ebuild,v 1.6 2005/01/01 15:00:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/endeavour/endeavour-2.3.6.ebuild,v 1.7 2005/04/08 04:08:37 vapier Exp $
-IUSE=""
+inherit eutils
M=endeavour2-mimetypes
DESCRIPTION="Powerful file and image browser"
@@ -10,9 +10,10 @@ HOMEPAGE="http://wolfpack.twu.net/Endeavour2/"
SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2
ftp://wolfpack.twu.net/users/wolfpack/${M}.tgz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc amd64"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
DEPEND="app-arch/bzip2
=x11-libs/gtk+-1.2*
@@ -21,6 +22,8 @@ DEPEND="app-arch/bzip2
src_unpack() {
unpack ${P}.tar.bz2
unpack ${M}.tgz
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.4.6-gcc33.patch
}
src_compile() {
@@ -32,13 +35,12 @@ src_install() {
dodoc AUTHORS HACKING INSTALL README TODO
cd endeavour2
-
- dobin endeavour2
+ dobin endeavour2 || die
bunzip2 endeavour2.1.bz2
doman endeavour2.1
dodir /usr/share/endeavour2
- cp -R data/* ${D}/usr/share/endeavour2
+ cp -R data/* ${D}/usr/share/endeavour2 || die
cd images
insinto /usr/share/icons
diff --git a/app-misc/endeavour/endeavour-2.4.6.ebuild b/app-misc/endeavour/endeavour-2.4.6.ebuild
index d2266958ada3..4d0beb780c70 100644
--- a/app-misc/endeavour/endeavour-2.4.6.ebuild
+++ b/app-misc/endeavour/endeavour-2.4.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/endeavour/endeavour-2.4.6.ebuild,v 1.3 2005/01/01 15:00:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/endeavour/endeavour-2.4.6.ebuild,v 1.4 2005/04/08 04:08:37 vapier Exp $
+
+inherit eutils
M=endeavour2-mimetypes
DESCRIPTION="Powerful file and image browser"
@@ -10,7 +12,7 @@ SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND="app-arch/bzip2
@@ -20,6 +22,8 @@ DEPEND="app-arch/bzip2
src_unpack() {
unpack ${P}.tar.bz2
unpack ${M}.tgz
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc33.patch
}
src_compile() {
@@ -31,13 +35,12 @@ src_install() {
dodoc AUTHORS HACKING INSTALL README TODO
cd endeavour2
-
- dobin endeavour2
+ dobin endeavour2 || die
bunzip2 endeavour2.1.bz2
doman endeavour2.1
dodir /usr/share/endeavour2
- cp -R data/* ${D}/usr/share/endeavour2
+ cp -R data/* ${D}/usr/share/endeavour2 || die
dodir /usr/share/endeavour2/icons/
cp -R images/* ${D}/usr/share/endeavour2/icons/
diff --git a/app-misc/endeavour/files/endeavour-2.4.6-gcc33.patch b/app-misc/endeavour/files/endeavour-2.4.6-gcc33.patch
new file mode 100644
index 000000000000..33a3e4594f4a
--- /dev/null
+++ b/app-misc/endeavour/files/endeavour-2.4.6-gcc33.patch
@@ -0,0 +1,31 @@
+Work around a gcc-3.3.x bug where redefining prototypes with different
+__THROW / attribute(nonnull) markings throws an error:
+
+string.cpp:31: error: declaration of `char* strcasestr(const char*, const char*)' throws different exceptions
+../include/string.h:46: error: than previous declaration `char* strcasestr(const char*, const char*) throw ()'
+
+basically we just use the glibc strcasestr() instead of the internal one.
+
+http://bugs.gentoo.org/show_bug.cgi?id=85780
+
+--- endeavour2/string.cpp
++++ endeavour2/string.cpp
+@@ -28,3 +28,5 @@
+ #endif
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle);
++#endif
+ int strpfx(const char *s, const char *pfx);
+@@ -217,3 +219,4 @@
+ */
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle)
+ {
+@@ -274,6 +277,7 @@
+
+ return(NULL);
+ }
++#endif
+
+ /*
+ * Checks if string pfx is a prefix of string s.
diff --git a/games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch b/games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch
new file mode 100644
index 000000000000..f64de08f4d2a
--- /dev/null
+++ b/games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch
@@ -0,0 +1,31 @@
+Work around a gcc-3.3.x bug where redefining prototypes with different
+__THROW / attribute(nonnull) markings throws an error:
+
+string.cpp:31: error: declaration of `char* strcasestr(const char*, const char*)' throws different exceptions
+../include/string.h:46: error: than previous declaration `char* strcasestr(const char*, const char*) throw ()'
+
+basically we just use the glibc strcasestr() instead of the internal one.
+
+http://bugs.gentoo.org/show_bug.cgi?id=85780
+
+--- global/string.cpp
++++ global/string.cpp
+@@ -37,3 +37,5 @@
+ #endif
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle);
++#endif
+ int strpfx(const char *s, const char *pfx);
+@@ -221,3 +224,4 @@
+ */
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle)
+ {
+@@ -274,6 +277,7 @@
+
+ return(NULL);
+ }
++#endif
+
+ /*
+ * Checks if string pfx is a prefix of string s.
diff --git a/games-action/xshipwars/xshipwars-1.34.0.ebuild b/games-action/xshipwars/xshipwars-1.34.0.ebuild
index b8e5c3b91ed3..897c9318ed83 100644
--- a/games-action/xshipwars/xshipwars-1.34.0.ebuild
+++ b/games-action/xshipwars/xshipwars-1.34.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-1.34.0.ebuild,v 1.11 2005/03/19 18:20:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-1.34.0.ebuild,v 1.12 2005/04/08 04:09:24 vapier Exp $
inherit toolchain-funcs eutils games
@@ -25,6 +25,8 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc33.patch
}
src_compile() {