summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/seahorse/seahorse-0.5.0.ebuild23
-rw-r--r--media-gfx/gnome-iconedit/gnome-iconedit-1.2.0.ebuild31
2 files changed, 25 insertions, 29 deletions
diff --git a/app-crypt/seahorse/seahorse-0.5.0.ebuild b/app-crypt/seahorse/seahorse-0.5.0.ebuild
index e78089ecfab7..3ba895c114ee 100644
--- a/app-crypt/seahorse/seahorse-0.5.0.ebuild
+++ b/app-crypt/seahorse/seahorse-0.5.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Ben Lutgens <blutgens@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.5.0.ebuild,v 1.6 2001/06/24 20:11:29 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.5.0.ebuild,v 1.7 2001/10/06 23:17:53 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,21 +11,20 @@ HOMEPGAE="http://seahorse.sourceforge.net/"
DEPEND="virtual/glibc virtual/x11
>=app-crypt/gnupg-1.0.4
- >=gnome-base/gnome-libs-1.2"
+ >=gnome-base/gnome-libs-1.4.1.2-r1"
src_compile() {
- try ./configure --host=${CHOST} --prefix=/opt/gnome
- try pmake
+ ./configure --host=${CHOST} \
+ --prefix=/usr
+ assert
+
+ emake || die
}
src_install() {
- try make DESTDIR=${D} localedir=${D}/opt/gnome/share/locale \
- gnulocaledir=${D}/opt/gnome/share/locale install
- #try make prefix=${D}/opt/gnome install
- dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ make DESTDIR=${D} \
+ localedir=${D}/usr/share/locale \
+ gnulocaledir=${D}/usr/share/locale install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
}
-
-
-
-
diff --git a/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0.ebuild b/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0.ebuild
index 556bda7367d4..abfc6c6d48b7 100644
--- a/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0.ebuild
+++ b/media-gfx/gnome-iconedit/gnome-iconedit-1.2.0.ebuild
@@ -7,11 +7,11 @@ DESCRIPTION="Edits icons, what more can you say?"
SRC_URI="http://210.77.60.218/ftp/ftp.debian.org/pool/main/g/gnome-iconedit/gnome-iconedit_${PV}.orig.tar.gz"
HOMEPAGE="www.advogato.org/proj/GNOME-Iconedit/"
-DEPEND="gnome-base/gnome-libs
- x11-libs/gtk+
- media-libs/gdk-pixbuf
+DEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/gdk-pixbuf-0.11.0-r1
media-libs/libpng
- gnome-base/gnome-print"
+ >=gnome-base/gnome-print-0.30"
# Bonobo support is broken
# bonobo? ( gnome-base/bonobo )"
@@ -24,30 +24,27 @@ src_unpack() {
# Fix some compile / #include errors
cd ${S}
patch -p1 <${FILESDIR}/gnome-iconedit.diff || die
-
+ automake
+ autoconf
}
src_compile() {
-
local myconf
- use nls || myconf="--disable-nls"
- # Needed by .diff
- automake
- autoconf
+ use nls || myconf="--disable-nls"
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print`"
- ./configure --host=${CHOST} --prefix=/opt/gnome --mandir=/usr/share/man \
- --infodir=/usr/share/info --with-sysconfdir=/etc/opt/gnome \
- $myconf || die
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --with-sysconfdir=/etc \
+ $myconf || die
emake || die
}
src_install () {
-
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} prefix=${D}/usr install || die
dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
-
}
-