summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/nokogiri/ChangeLog6
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.4.0.ebuild18
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.4.2.ebuild77
3 files changed, 5 insertions, 96 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index db9e7f213785..b10f9413f88b 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.34 2010/07/30 15:48:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.35 2010/09/12 07:56:46 graaff Exp $
+
+ 12 Sep 2010; Hans de Graaff <graaff@gentoo.org> -nokogiri-1.4.0.ebuild,
+ -nokogiri-1.4.2.ebuild:
+ Remove old versions.
*nokogiri-1.4.3.1 (30 Jul 2010)
diff --git a/dev-ruby/nokogiri/nokogiri-1.4.0.ebuild b/dev-ruby/nokogiri/nokogiri-1.4.0.ebuild
deleted file mode 100644
index 8b075fb71138..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.4.0.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.0.ebuild,v 1.2 2010/05/22 15:31:43 flameeyes Exp $
-
-inherit gems
-USE_RUBY="ruby18"
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${RDEPEND}"
diff --git a/dev-ruby/nokogiri/nokogiri-1.4.2.ebuild b/dev-ruby/nokogiri/nokogiri-1.4.2.ebuild
deleted file mode 100644
index f9c1efb4fdf3..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.4.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.2.ebuild,v 1.4 2010/07/30 15:20:50 darkside Exp $
-
-EAPI=2
-
-# jruby → needs weakling for testing , will add back in a bit
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-SLOT="0"
-IUSE="ffi"
-
-RDEPEND="${RDEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${DEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-
-# The tests require _minitest_, not the virtual; what is shipped with
-# Ruby 1.9 is *not* enough, unfortunately
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/rexical
- dev-ruby/hoe
- test? ( dev-ruby/minitest )"
-
-ruby_add_rdepend "ffi? ( virtual/ruby-ffi )"
-
-# USE_RUBY=jruby \
-# ruby_add_bdepend "test? ( dev-ruby/weakling )"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}+ruby-1.9.2.patch
-
- sed -i \
- -e '/tasks\/cross_compile/s:^:#:' \
- -e '/:test.*prerequisites/s:^:#:' \
- Rakefile || die
-}
-
-nokogiri_ffi() {
- [[ $(basename ${RUBY}) == "jruby" ]] || use ffi
-}
-
-each_ruby_configure() {
- nokogiri_ffi && return
- ${RUBY} -Cext/${PN} extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- if ! [[ -f lib/nokogiri/css/generated_tokenizer.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/generated_tokenizer.rb || die "rexical failed"
- fi
-
- nokogiri_ffi && return
- emake -Cext/${PN} \
- CFLAGS="${CFLAGS} -fPIC" \
- archflag="${LDFLAGS}" || die "make extension failed"
- cp -l ext/${PN}/${PN}.so lib/${PN}/ || die
-}
-
-each_ruby_test() {
- nokogiri_ffi && export NOKOGIRI_FFI=yes
- each_fakegem_test
-}