summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-pda/libimobiledevice/ChangeLog10
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.1.4-HOME-segfault.patch15
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.1.4-r2.ebuild63
3 files changed, 87 insertions, 1 deletions
diff --git a/app-pda/libimobiledevice/ChangeLog b/app-pda/libimobiledevice/ChangeLog
index e838f9210855..6f2151cc72d7 100644
--- a/app-pda/libimobiledevice/ChangeLog
+++ b/app-pda/libimobiledevice/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-pda/libimobiledevice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.31 2012/05/19 08:19:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.32 2012/08/05 13:03:59 ssuominen Exp $
+
+*libimobiledevice-1.1.4-r2 (05 Aug 2012)
+
+ 05 Aug 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +libimobiledevice-1.1.4-r2.ebuild,
+ +files/libimobiledevice-1.1.4-HOME-segfault.patch:
+ Fix segmentation fault when both $XDG_CONFIG_HOME and $HOME are unset wrt
+ #423155c3 by Davide Pesavento
19 May 2012; Samuli Suominen <ssuominen@gentoo.org>
-libimobiledevice-1.1.4.ebuild:
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-HOME-segfault.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-HOME-segfault.patch
new file mode 100644
index 000000000000..1dc82b763aab
--- /dev/null
+++ b/app-pda/libimobiledevice/files/libimobiledevice-1.1.4-HOME-segfault.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/show_bug.cgi?id=423155#c3
+http://libiphone.lighthouseapp.com/projects/27916-libiphone/tickets/265
+
+--- src/userpref.c
++++ src/userpref.c
+@@ -125,6 +125,9 @@
+ const char *cdir = getenv("XDG_CONFIG_HOME");
+ if (!cdir) {
+ cdir = getenv("HOME");
++ if (!cdir) {
++ cdir="/root";
++ }
+ strcpy(__config_dir, cdir);
+ strcat(__config_dir, DIR_SEP_S);
+ strcat(__config_dir, ".config");
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.1.4-r2.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.1.4-r2.ebuild
new file mode 100644
index 000000000000..4616f6c99764
--- /dev/null
+++ b/app-pda/libimobiledevice/libimobiledevice-1.1.4-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.1.4-r2.ebuild,v 1.1 2012/08/05 13:03:59 ssuominen Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.7"
+inherit autotools eutils python
+
+DESCRIPTION="Support library to communicate with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="gnutls python"
+
+RDEPEND=">=app-pda/libplist-1.8-r1[python?]
+ >=app-pda/usbmuxd-1.0.8
+ gnutls? (
+ dev-libs/libgcrypt
+ >=dev-libs/libtasn1-1.1
+ >=net-libs/gnutls-2.2.0
+ )
+ !gnutls? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ python? ( >=dev-python/cython-0.14.1-r1 )"
+
+DOCS="AUTHORS NEWS README"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-cython.patch \
+ "${FILESDIR}"/${P}-openssl.patch \
+ "${FILESDIR}"/${P}-HOME-segfault.patch
+
+ eautoreconf
+
+ >py-compile
+}
+
+src_configure() {
+ local myconf='--disable-static'
+ use python || myconf+=' --without-cython'
+ use gnutls && myconf+=' --disable-openssl'
+
+ econf ${myconf}
+}
+
+src_install() {
+ default
+ dohtml docs/html/*
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}