summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/ktux/ChangeLog7
-rw-r--r--kde-base/ktux/ktux-4.4.0.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/kde-base/ktux/ChangeLog b/kde-base/ktux/ChangeLog
index d94a2bf6063d..b067be2a2b0b 100644
--- a/kde-base/ktux/ChangeLog
+++ b/kde-base/ktux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ktux
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ktux/ChangeLog,v 1.136 2010/01/25 17:03:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ktux/ChangeLog,v 1.137 2010/02/09 00:18:23 alexxy Exp $
+
+*ktux-4.4.0 (09 Feb 2010)
+
+ 09 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +ktux-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*ktux-4.3.5 (25 Jan 2010)
diff --git a/kde-base/ktux/ktux-4.4.0.ebuild b/kde-base/ktux/ktux-4.4.0.ebuild
new file mode 100644
index 000000000000..2326f89c802e
--- /dev/null
+++ b/kde-base/ktux/ktux-4.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ktux/ktux-4.4.0.ebuild,v 1.1 2010/02/09 00:18:23 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdetoys"
+inherit kde4-meta
+
+DESCRIPTION="KDE: screensaver featuring the Space-Faring Tux"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+# libkworkspace - only as a stub to provide KDE4Workspace config
+DEPEND="
+ $(add_kdebase_dep kscreensaver)
+ $(add_kdebase_dep libkworkspace)
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e's/${KDE4WORKSPACE_KSCREENSAVER_LIBRARY}/kscreensaver/' \
+ "${PN}"/CMakeLists.txt || die "Failed to patch CMakeLists.txt"
+
+ kde4-meta_src_prepare
+}