summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-firewall/iptables/ChangeLog12
-rw-r--r--net-firewall/iptables/files/digest-iptables-1.3.1-r4 (renamed from net-firewall/iptables/files/digest-iptables-1.3.1-r3)0
-rw-r--r--net-firewall/iptables/files/iptables-1.2.9-r1.init7
-rw-r--r--net-firewall/iptables/files/iptables.init7
-rw-r--r--net-firewall/iptables/iptables-1.3.1-r4.ebuild (renamed from net-firewall/iptables/iptables-1.3.1-r3.ebuild)2
-rw-r--r--net-firewall/iptables/metadata.xml2
6 files changed, 22 insertions, 8 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 1592111bebc4..5087a5b3f1e7 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-firewall/iptables
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.69 2005/05/03 22:55:13 wormo Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.70 2005/05/05 01:27:29 vapier Exp $
+
+*iptables-1.3.1-r4 (05 May 2005)
+
+ 05 May 2005; Mike Frysinger <vapier@gentoo.org>
+ files/iptables-1.2.9-r1.init, files/iptables.init, metadata.xml,
+ -iptables-1.3.1-r3.ebuild, +iptables-1.3.1-r4.ebuild:
+ Make sure /var/lib/iptables/rules-saves is only read/writable by root #91468
+ by eromang.
03 May 2005; Stephanie Lockwood-Childs <wormo@gentoo.org>
iptables-1.3.1-r3.ebuild:
diff --git a/net-firewall/iptables/files/digest-iptables-1.3.1-r3 b/net-firewall/iptables/files/digest-iptables-1.3.1-r4
index 2cd860dcf77a..2cd860dcf77a 100644
--- a/net-firewall/iptables/files/digest-iptables-1.3.1-r3
+++ b/net-firewall/iptables/files/digest-iptables-1.3.1-r4
diff --git a/net-firewall/iptables/files/iptables-1.2.9-r1.init b/net-firewall/iptables/files/iptables-1.2.9-r1.init
index 9c96a242f0c9..436401d525c9 100644
--- a/net-firewall/iptables/files/iptables-1.2.9-r1.init
+++ b/net-firewall/iptables/files/iptables-1.2.9-r1.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/files/iptables-1.2.9-r1.init,v 1.4 2005/04/25 00:27:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/files/iptables-1.2.9-r1.init,v 1.5 2005/05/05 01:27:29 vapier Exp $
opts="save reload"
@@ -67,7 +67,10 @@ reload() {
}
save() {
+ local ret
ebegin "Saving iptables state"
/sbin/iptables-save ${SAVE_RESTORE_OPTIONS} > ${IPTABLES_SAVE}
- eend $?
+ ret=$?
+ chmod 0600 ${IPTABLES_SAVE}
+ eend ${ret}
}
diff --git a/net-firewall/iptables/files/iptables.init b/net-firewall/iptables/files/iptables.init
index cc9e49950f74..41dec2e69c78 100644
--- a/net-firewall/iptables/files/iptables.init
+++ b/net-firewall/iptables/files/iptables.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/files/iptables.init,v 1.5 2005/04/25 00:27:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/files/iptables.init,v 1.6 2005/05/05 01:27:29 vapier Exp $
opts="save reload"
@@ -74,7 +74,10 @@ reload() {
}
save() {
+ local ret
ebegin "Saving iptables state"
/sbin/iptables-save ${SAVE_RESTORE_OPTIONS} > ${IPTABLES_SAVE}
- eend $?
+ ret=$?
+ chmod 0600 ${IPTABLES_SAVE}
+ eend ${ret}
}
diff --git a/net-firewall/iptables/iptables-1.3.1-r3.ebuild b/net-firewall/iptables/iptables-1.3.1-r4.ebuild
index 4e1aeec90aad..ee2aca25f255 100644
--- a/net-firewall/iptables/iptables-1.3.1-r3.ebuild
+++ b/net-firewall/iptables/iptables-1.3.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.1-r3.ebuild,v 1.7 2005/05/03 22:55:13 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.3.1-r4.ebuild,v 1.1 2005/05/05 01:27:29 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info
diff --git a/net-firewall/iptables/metadata.xml b/net-firewall/iptables/metadata.xml
index 8060c04f89e1..42a48a7483e0 100644
--- a/net-firewall/iptables/metadata.xml
+++ b/net-firewall/iptables/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
+<herd>base-system</herd>
<maintainer>
<email>aliz@gentoo.org</email>
</maintainer>