summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/gcc/gcc-3.2.3-r4.ebuild10
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r7.ebuild9
-rw-r--r--sys-devel/gcc/gcc-3.3.5-r1.ebuild5
-rw-r--r--sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild3
-rw-r--r--sys-devel/gcc/gcc-3.3.6.ebuild5
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r3.ebuild3
-rw-r--r--sys-devel/gcc/gcc-3.4.4-r1.ebuild5
-rw-r--r--sys-devel/gcc/gcc-3.4.5-r1.ebuild3
-rw-r--r--sys-devel/gcc/gcc-3.4.5.ebuild3
-rw-r--r--sys-devel/gcc/gcc-3.4.6.ebuild3
-rw-r--r--sys-devel/gcc/gcc-4.0.2-r3.ebuild5
-rw-r--r--sys-devel/gcc/gcc-4.0.3.ebuild5
-rw-r--r--sys-devel/gcc/gcc-4.1.0.ebuild5
13 files changed, 20 insertions, 44 deletions
diff --git a/sys-devel/gcc/gcc-3.2.3-r4.ebuild b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
index 066257a39330..bef54b19003b 100644
--- a/sys-devel/gcc/gcc-3.2.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.18 2005/10/07 02:01:56 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.19 2006/03/28 05:17:36 vapier Exp $
inherit eutils flag-o-matic libtool versionator
@@ -635,10 +635,4 @@ pkg_postinst() {
# Fix ncurses b0rking (if r5 isn't unmerged)
find ${ROOT}/usr/lib/gcc-lib -name '*curses.h' -exec rm -f {} \;
-
- # http://dev.gentoo.org/~pappy/hardened-gcc/docs/etdyn-ssp.html
- if has_version '>=sys-devel/hardened-gcc-1.2'
- then
- [ "${ROOT}" = "/" ] && hardened-gcc -A
- fi
}
diff --git a/sys-devel/gcc/gcc-3.3.2-r7.ebuild b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
index 353d5c7ffcf1..8df6bb269abe 100644
--- a/sys-devel/gcc/gcc-3.3.2-r7.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.25 2006/03/03 14:34:49 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.26 2006/03/28 05:17:36 vapier Exp $
IUSE="static nls bootstrap java build X multilib gcj emul-linux-x86"
@@ -680,11 +680,4 @@ pkg_postinst() {
/sbin/fix_libtool_files.sh ${OLD_GCC_VERSION} ${OLD_GCC_CHOST}
fi
-
- # http://dev.gentoo.org/~pappy/hardened-gcc/docs/etdyn-ssp.html
- if has_version '>=sys-devel/hardened-gcc-1.2'
- then
- [ "${ROOT}" = "/" ] && hardened-gcc -A
- fi
}
-
diff --git a/sys-devel/gcc/gcc-3.3.5-r1.ebuild b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
index a7faf19455a0..deb3232c552a 100644
--- a/sys-devel/gcc/gcc-3.3.5-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.28 2006/03/03 14:10:19 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.29 2006/03/28 05:17:36 vapier Exp $
MAN_VER="3.3.5"
#BRANCH_UPDATE="20041025"
@@ -50,7 +50,6 @@ KEYWORDS="~alpha ~amd64 arm hppa -ia64 ~mips s390 sh sparc x86"
RDEPEND="virtual/libc
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.6 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
elibc_glibc? ( >=sys-libs/glibc-2.3.2-r9 )
>=sys-devel/binutils-2.14.90.0.6-r1
>=sys-devel/bison-1.875
diff --git a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
index ffc25bd77ce0..07c41e6ae55d 100644
--- a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.14 2006/03/03 14:10:19 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.15 2006/03/28 05:17:36 vapier Exp $
MAN_VER="3.3.5"
PATCH_VER="1.4"
@@ -46,7 +46,6 @@ KEYWORDS="~alpha ~amd64 arm ~hppa -ia64 ~mips sh sparc x86"
RDEPEND="virtual/libc
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.10 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
elibc_glibc? ( >=sys-libs/glibc-2.3.2-r9 )
>=sys-devel/binutils-2.14.90.0.6-r1
>=sys-devel/bison-1.875
diff --git a/sys-devel/gcc/gcc-3.3.6.ebuild b/sys-devel/gcc/gcc-3.3.6.ebuild
index 9ca7f6e921ed..7f9255b80a83 100644
--- a/sys-devel/gcc/gcc-3.3.6.ebuild
+++ b/sys-devel/gcc/gcc-3.3.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.21 2006/03/03 14:10:19 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.22 2006/03/28 05:17:36 vapier Exp $
MAN_VER=""
PATCH_VER="1.3"
@@ -42,7 +42,6 @@ KEYWORDS="-* ~alpha ~amd64 arm hppa -ia64 m68k sh ~sparc x86"
# well tested in gentoo on any arch other than amd64!!
RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
elibc_glibc? ( >=sys-libs/glibc-2.3.2-r9 )
>=sys-devel/binutils-2.14.90.0.6-r1
>=sys-devel/bison-1.875
diff --git a/sys-devel/gcc/gcc-3.4.1-r3.ebuild b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
index 50d3e015554f..dfe56dd12201 100644
--- a/sys-devel/gcc/gcc-3.4.1-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.21 2006/03/03 14:34:49 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.22 2006/03/28 05:17:36 vapier Exp $
IUSE="static nls bootstrap build multilib gcj gtk fortran objc hardened n32 n64 emul-linux-x86"
@@ -22,7 +22,6 @@ KEYWORDS="-* ~amd64 mips ppc64 ~x86 -hppa ppc s390"
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
# well tested in gentoo on any arch other than amd64!!
DEPEND="virtual/libc
- !sys-devel/hardened-gcc
>=sys-devel/binutils-2.14.90.0.8-r1
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )
>=sys-devel/bison-1.875
diff --git a/sys-devel/gcc/gcc-3.4.4-r1.ebuild b/sys-devel/gcc/gcc-3.4.4-r1.ebuild
index 91b797b53d4c..b3912c46cba9 100644
--- a/sys-devel/gcc/gcc-3.4.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4-r1.ebuild,v 1.12 2006/03/03 14:10:19 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4-r1.ebuild,v 1.13 2006/03/28 05:17:36 vapier Exp $
MAN_VER=""
PATCH_VER="1.7"
@@ -48,7 +48,6 @@ KEYWORDS="-* alpha amd64 arm ~hppa ~ia64 mips ppc ppc64 ~s390 sh ~sparc x86"
# well tested in gentoo on any arch other than amd64!!
RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
elibc_glibc? (
>=sys-libs/glibc-2.3.3_pre20040420-r1
hardened? ( >=sys-libs/glibc-2.3.3_pre20040529 )
diff --git a/sys-devel/gcc/gcc-3.4.5-r1.ebuild b/sys-devel/gcc/gcc-3.4.5-r1.ebuild
index 1c8592a52f6f..041b40ecb7e4 100644
--- a/sys-devel/gcc/gcc-3.4.5-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.5-r1.ebuild,v 1.9 2006/03/28 01:22:48 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.5-r1.ebuild,v 1.10 2006/03/28 05:17:36 vapier Exp $
MAN_VER=""
PATCH_VER="1.4"
@@ -45,7 +45,6 @@ KEYWORDS="-* arm ~mips ppc ~ppc64 sh x86"
# well tested in gentoo on any arch other than amd64!!
RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
elibc_glibc? (
>=sys-libs/glibc-2.3.3_pre20040420-r1
hardened? ( >=sys-libs/glibc-2.3.3_pre20040529 )
diff --git a/sys-devel/gcc/gcc-3.4.5.ebuild b/sys-devel/gcc/gcc-3.4.5.ebuild
index 3b21f0f227e4..aee482bf99bc 100644
--- a/sys-devel/gcc/gcc-3.4.5.ebuild
+++ b/sys-devel/gcc/gcc-3.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.5.ebuild,v 1.13 2006/03/23 19:48:33 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.5.ebuild,v 1.14 2006/03/28 05:17:36 vapier Exp $
MAN_VER=""
PATCH_VER="1.2"
@@ -45,7 +45,6 @@ KEYWORDS="-* amd64 ~arm ~hppa ~ia64 mips ~ppc ~ppc64 ~s390 sh sparc x86"
# well tested in gentoo on any arch other than amd64!!
RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
elibc_glibc? (
>=sys-libs/glibc-2.3.3_pre20040420-r1
hardened? ( >=sys-libs/glibc-2.3.3_pre20040529 )
diff --git a/sys-devel/gcc/gcc-3.4.6.ebuild b/sys-devel/gcc/gcc-3.4.6.ebuild
index aee3816323e2..d9a68ef66bd4 100644
--- a/sys-devel/gcc/gcc-3.4.6.ebuild
+++ b/sys-devel/gcc/gcc-3.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6.ebuild,v 1.4 2006/03/28 01:17:36 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6.ebuild,v 1.5 2006/03/28 05:17:36 vapier Exp $
MAN_VER=""
PATCH_VER="1.0"
@@ -48,7 +48,6 @@ KEYWORDS="-* ~amd64 ~arm ~ppc64 ~sh ~sparc ~x86"
# well tested in gentoo on any arch other than amd64!!
RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
elibc_glibc? (
>=sys-libs/glibc-2.3.3_pre20040420-r1
hardened? ( >=sys-libs/glibc-2.3.3_pre20040529 )
diff --git a/sys-devel/gcc/gcc-4.0.2-r3.ebuild b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
index bb550425c3c2..498b8eae93ea 100644
--- a/sys-devel/gcc/gcc-4.0.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r3.ebuild,v 1.10 2006/03/03 14:10:19 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r3.ebuild,v 1.11 2006/03/28 05:17:36 vapier Exp $
PATCH_VER="1.5"
PATCH_GCC_VER="4.0.2"
@@ -30,9 +30,8 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-* ~ia64"
-RDEPEND="!sys-devel/hardened-gcc
+RDEPEND=">=sys-libs/zlib-1.1.4
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
- >=sys-libs/zlib-1.1.4
fortran? (
dev-libs/gmp
dev-libs/mpfr
diff --git a/sys-devel/gcc/gcc-4.0.3.ebuild b/sys-devel/gcc/gcc-4.0.3.ebuild
index e0d2993338eb..9067c58f73b7 100644
--- a/sys-devel/gcc/gcc-4.0.3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.3.ebuild,v 1.2 2006/03/18 01:43:28 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.3.ebuild,v 1.3 2006/03/28 05:17:36 vapier Exp $
PATCH_VER="1.1"
PATCH_GCC_VER="4.0.3"
@@ -28,9 +28,8 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-* ~ia64"
-RDEPEND="!sys-devel/hardened-gcc
+RDEPEND=">=sys-libs/zlib-1.1.4
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
- >=sys-libs/zlib-1.1.4
fortran? (
dev-libs/gmp
dev-libs/mpfr
diff --git a/sys-devel/gcc/gcc-4.1.0.ebuild b/sys-devel/gcc/gcc-4.1.0.ebuild
index 7197b5c6c856..fcbc595984c0 100644
--- a/sys-devel/gcc/gcc-4.1.0.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0.ebuild,v 1.9 2006/03/18 01:43:28 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0.ebuild,v 1.10 2006/03/28 05:17:36 vapier Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.1"
@@ -22,9 +22,8 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-* ~amd64 ~ppc ~x86"
-RDEPEND="!sys-devel/hardened-gcc
+RDEPEND=">=sys-libs/zlib-1.1.4
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
- >=sys-libs/zlib-1.1.4
fortran? (
dev-libs/gmp
dev-libs/mpfr