summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/cdrtools/cdrtools-2.01_alpha03.ebuild15
-rw-r--r--app-i18n/kde-i18n-fr/kde-i18n-fr-3.1-r1.ebuild4
-rw-r--r--dev-libs/root/files/digest-root-3.03.04-r11
-rw-r--r--dev-libs/root/root-3.03.04-r1.ebuild82
-rw-r--r--dev-libs/root/root-3.03.04-r2.ebuild27
-rw-r--r--net-mail/pine/pine-4.53-r4.ebuild7
6 files changed, 21 insertions, 115 deletions
diff --git a/app-cdr/cdrtools/cdrtools-2.01_alpha03.ebuild b/app-cdr/cdrtools/cdrtools-2.01_alpha03.ebuild
index 4fad67a5711e..5e7b848f7453 100644
--- a/app-cdr/cdrtools/cdrtools-2.01_alpha03.ebuild
+++ b/app-cdr/cdrtools/cdrtools-2.01_alpha03.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01_alpha03.ebuild,v 1.1 2003/02/18 04:02:45 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01_alpha03.ebuild,v 1.2 2003/02/28 21:56:14 vapier Exp $
+
+inherit eutils
DESCRIPTION="A set of tools for CDR drives, including cdrecord."
HOMEPAGE="http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/cdrecord.html"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc"
+SRC_URI="ftp://ftp.berlios.de/pub/cdrecord/alpha/${P/_alpha/a}.tar.gz"
-IUSE=""
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-SRC_URI="ftp://ftp.berlios.de/pub/cdrecord/alpha/${P/_alpha/a}.tar.gz"
-S="${WORKDIR}/${PN}-2.01"
+DEPEND="virtual/glibc"
-inherit eutils
+S="${WORKDIR}/${PN}-2.01"
src_unpack() {
unpack ${A}
diff --git a/app-i18n/kde-i18n-fr/kde-i18n-fr-3.1-r1.ebuild b/app-i18n/kde-i18n-fr/kde-i18n-fr-3.1-r1.ebuild
index fd3d5606787b..2494cb168e75 100644
--- a/app-i18n/kde-i18n-fr/kde-i18n-fr-3.1-r1.ebuild
+++ b/app-i18n/kde-i18n-fr/kde-i18n-fr-3.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kde-i18n-fr/kde-i18n-fr-3.1-r1.ebuild,v 1.2 2003/02/13 08:15:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kde-i18n-fr/kde-i18n-fr-3.1-r1.ebuild,v 1.3 2003/02/28 21:56:53 vapier Exp $
-inherit kde-i18n eutils
+inherit eutils kde-i18n
src_unpack() {
unpack ${A}
diff --git a/dev-libs/root/files/digest-root-3.03.04-r1 b/dev-libs/root/files/digest-root-3.03.04-r1
deleted file mode 100644
index ef93a97a2fdb..000000000000
--- a/dev-libs/root/files/digest-root-3.03.04-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 70edd37d08af7efb281abafd014bd9d4 root_v3.03.04.source.tar.gz 5367020
diff --git a/dev-libs/root/root-3.03.04-r1.ebuild b/dev-libs/root/root-3.03.04-r1.ebuild
deleted file mode 100644
index 0d4072a27080..000000000000
--- a/dev-libs/root/root-3.03.04-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/root/root-3.03.04-r1.ebuild,v 1.10 2003/02/22 10:39:32 kain Exp $
-
-IUSE="mysql postgres opengl"
-
-S=${WORKDIR}/${PN}
-DESCRIPTION="An Object-Oriented Data Analysis Framework"
-SRC_URI="ftp://root.cern.ch/root/root_v3.03.04.source.tar.gz"
-HOMEPAGE="http://root.cern.ch/"
-
-inherit flag-o-matic
-inherit eutils
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="x86 sparc ~ppc"
-
-DEPEND="virtual/x11
- >=media-libs/xpm-3.4k
- >=media-libs/freetype-2.0.9
- opengl? ( virtual/opengl virtual/glu )
- mysql? ( >=dev-db/mysql-3.23.49 )
- postgres? ( >=dev-db/postgresql-7.1.3-r4 )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/root-makefile.patch
- epatch ${FILESDIR}/pgsql-no-libpq-int.patch
-}
-
-src_compile() {
-
- use opengl \
- && myconf="${myconf} --enable-opengl" \
- || myconf="${myconf} --disable-opengl"
-
- use mysql \
- && myconf="${myconf} --enable-mysql" \
- || myconf="${myconf} --disable-mysql"
-
- use postgres \
- && myconf="${myconf} --enable-pgsql" \
- || myconf="${myconf} --disable-pgsql"
-
- case $SYSTEM_ARCH in
- ppc)
- append-flags "-fsigned-char";;
- esac
- export GENTOO_CFLAGS="${CFLAGS}" GENTOO_CXXFLAGS="${CXXFLAGS}"
- ./configure \
- linux \
- --prefix=/usr \
- --docdir=/usr/share/doc/${P} \
- --enable-shared \
- --disable-rpath \
- --enable-thread \
- --enable-star \
- --enable-ttf \
- --disable-cern \
- --disable-sapdb \
- --disable-rfio \
- --disable-dcache \
- --disable-srp \
- --disable-afs \
- --disable-krb5 \
- --enable-shadowpw \
- --disable-pythia \
- --disable-pythia6 \
- --disable-venus \
- --enable-soversion \
- ${myconf} || die "./configure failed"
- make || die
-}
-
-src_install () {
- make DESTDIR=${D} install || die
-
- dodir /etc/env.d
- echo "LDPATH=/usr/lib/root" > ${D}/etc/env.d/60root
-}
diff --git a/dev-libs/root/root-3.03.04-r2.ebuild b/dev-libs/root/root-3.03.04-r2.ebuild
index 005590a7b1e7..259101d72085 100644
--- a/dev-libs/root/root-3.03.04-r2.ebuild
+++ b/dev-libs/root/root-3.03.04-r2.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/root/root-3.03.04-r2.ebuild,v 1.1 2003/02/22 10:39:32 kain Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/root/root-3.03.04-r2.ebuild,v 1.2 2003/02/28 21:59:21 vapier Exp $
-IUSE="mysql postgres opengl"
+inherit flag-o-matic eutils
S=${WORKDIR}/${PN}
DESCRIPTION="An Object-Oriented Data Analysis Framework"
-SRC_URI="ftp://root.cern.ch/root/root_v3.03.04.source.tar.gz"
+SRC_URI="ftp://root.cern.ch/root/root_v${PV}.source.tar.gz"
HOMEPAGE="http://root.cern.ch/"
-inherit flag-o-matic
-inherit eutils
-
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc ~ppc"
+IUSE="mysql postgres opengl"
DEPEND="virtual/x11
>=media-libs/xpm-3.4k
@@ -31,18 +29,6 @@ src_unpack() {
}
src_compile() {
-
- use opengl \
- && myconf="${myconf} --enable-opengl" \
- || myconf="${myconf} --disable-opengl"
-
- use mysql \
- && myconf="${myconf} --enable-mysql" \
- || myconf="${myconf} --disable-mysql"
-
- use postgres \
- && myconf="${myconf} --enable-pgsql" \
- || myconf="${myconf} --disable-pgsql"
case $SYSTEM_ARCH in
ppc)
@@ -70,11 +56,14 @@ src_compile() {
--disable-pythia6 \
--disable-venus \
--enable-soversion \
+ `use_enable opengl` \
+ `use_enable mysql` \
+ `use_enable postgres pgsql` \
${myconf} || die "./configure failed"
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodir /etc/env.d
diff --git a/net-mail/pine/pine-4.53-r4.ebuild b/net-mail/pine/pine-4.53-r4.ebuild
index 97c522c59097..8d19f9bf3dab 100644
--- a/net-mail/pine/pine-4.53-r4.ebuild
+++ b/net-mail/pine/pine-4.53-r4.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.53-r4.ebuild,v 1.2 2003/02/16 00:18:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.53-r4.ebuild,v 1.3 2003/02/28 22:00:10 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${PN}${PV}
DESCRIPTION="A tool for reading, sending and managing electronic messages."
SRC_URI="ftp://ftp.cac.washington.edu/pine/${PN}${PV}.tar.bz2
mirror://gentoo//${P}-chappa-20030214.patch.bz2"
@@ -22,7 +23,7 @@ DEPEND="virtual/glibc
net-www/lynx
!net-mail/pine-maildir"
-inherit eutils
+S=${WORKDIR}/${PN}${PV}
src_unpack() {
unpack ${PN}${PV}.tar.bz2