summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-laptop/macosd/ChangeLog5
-rw-r--r--app-laptop/macosd/Manifest4
-rw-r--r--app-laptop/macosd/files/digest-macosd-0.1.71
-rw-r--r--app-laptop/macosd/files/macosd-0.1.7-include-fix.diff24
-rw-r--r--app-laptop/macosd/macosd-0.1.7.ebuild47
5 files changed, 81 insertions, 0 deletions
diff --git a/app-laptop/macosd/ChangeLog b/app-laptop/macosd/ChangeLog
new file mode 100644
index 000000000000..6133a726bdcc
--- /dev/null
+++ b/app-laptop/macosd/ChangeLog
@@ -0,0 +1,5 @@
+# ChangeLog for app-laptop/macosd
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/ChangeLog,v 1.1 2004/09/25 00:07:58 pvdabeel Exp $
+
+ 25 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> : New ebuild #55485
diff --git a/app-laptop/macosd/Manifest b/app-laptop/macosd/Manifest
new file mode 100644
index 000000000000..998a90fdeb27
--- /dev/null
+++ b/app-laptop/macosd/Manifest
@@ -0,0 +1,4 @@
+MD5 b3c4a415e042d8051c265310be61724c ChangeLog 289
+MD5 f5d47648c0248b3226666212801078a2 macosd-0.1.7.ebuild 1154
+MD5 43cd825ea802fb0841d757bb667229cf files/macosd-0.1.7-include-fix.diff 1068
+MD5 b06e205ccef0f87bc5dca70acf5e99a7 files/digest-macosd-0.1.7 65
diff --git a/app-laptop/macosd/files/digest-macosd-0.1.7 b/app-laptop/macosd/files/digest-macosd-0.1.7
new file mode 100644
index 000000000000..537355c79eb7
--- /dev/null
+++ b/app-laptop/macosd/files/digest-macosd-0.1.7
@@ -0,0 +1 @@
+MD5 4aeb934870cf2d61b0bf17708063d494 macosd-0.1.7.tar.bz2 164349
diff --git a/app-laptop/macosd/files/macosd-0.1.7-include-fix.diff b/app-laptop/macosd/files/macosd-0.1.7-include-fix.diff
new file mode 100644
index 000000000000..22b85c115748
--- /dev/null
+++ b/app-laptop/macosd/files/macosd-0.1.7-include-fix.diff
@@ -0,0 +1,24 @@
+diff -Naur macosd-0.1.7/utility/include/template/ArgumentList.tcc macosd-0.1.7.patched/utility/include/template/ArgumentList.tcc
+--- macosd-0.1.7/utility/include/template/ArgumentList.tcc 2004-06-17 17:33:03.000000000 +0200
++++ macosd-0.1.7.patched/utility/include/template/ArgumentList.tcc 2004-06-29 02:10:12.855629496 +0200
+@@ -1,7 +1,7 @@
+
+ #include "Compiler.hh"
+
+-#if GCC_VERSION < 30400 || __INCLUDE_LEVEL__ == 1
++#if GCC_VERSION < 30400 && __INCLUDE_LEVEL__ == 1
+
+ #ifndef UTILITY__ARGUMENTLIST_TCC__
+ #define UTILITY__ARGUMENTLIST_TCC__
+diff -Naur macosd-0.1.7/utility/include/template/Storage.tcc macosd-0.1.7.patched/utility/include/template/Storage.tcc
+--- macosd-0.1.7/utility/include/template/Storage.tcc 2004-06-17 17:33:03.000000000 +0200
++++ macosd-0.1.7.patched/utility/include/template/Storage.tcc 2004-06-29 02:10:24.070924512 +0200
+@@ -1,7 +1,7 @@
+
+ #include "Compiler.hh"
+
+-#if GCC_VERSION < 30400 || __INCLUDE_LEVEL__ == 1
++#if GCC_VERSION < 30400 && __INCLUDE_LEVEL__ == 1
+
+ #ifndef UTILITY__STORAGE_TCC__
+ #define UTILITY__STORAGE_TCC__
diff --git a/app-laptop/macosd/macosd-0.1.7.ebuild b/app-laptop/macosd/macosd-0.1.7.ebuild
new file mode 100644
index 000000000000..477b81505a71
--- /dev/null
+++ b/app-laptop/macosd/macosd-0.1.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/macosd/macosd-0.1.7.ebuild,v 1.1 2004/09/25 00:07:58 pvdabeel Exp $
+
+inherit eutils
+
+DESCRIPTION="On-Screen-Display frontend for pbbuttonsd (only for PPC Laptops)."
+HOMEPAGE="http://www.rocklinux-consulting.de/oss/macosd/"
+SRC_URI="http://dl.rocklinux-consulting.de/oss/macosd/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+DEPEND="virtual/x11
+ >=app-laptop/pbbuttonsd-0.5.2-r1
+ >=x11-libs/evas-1.0.0.20040529_pre13
+ >=x11-libs/xosd-2.2.5"
+RDEPEND="$DEPEND"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-include-fix.diff
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/macosd
+ dodir /usr/bin
+ einstall || die
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "Make sure that pbbuttons is running (add it to your default runlevel)"
+ einfo "and then add the following to your $HOME/.xinitrc to have macosd"
+ einfo "start whenever you launch X:"
+ einfo "macosd -n -t CleanOSX &"
+}