summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-wireless/broadcom-sta/ChangeLog8
-rw-r--r--net-wireless/broadcom-sta/broadcom-sta-5.100.82.38.ebuild57
-rw-r--r--net-wireless/broadcom-sta/files/broadcom-sta-5.100.82.38-gcc.patch11
3 files changed, 75 insertions, 1 deletions
diff --git a/net-wireless/broadcom-sta/ChangeLog b/net-wireless/broadcom-sta/ChangeLog
index b145acedab76..409423c31a2b 100644
--- a/net-wireless/broadcom-sta/ChangeLog
+++ b/net-wireless/broadcom-sta/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/broadcom-sta
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/broadcom-sta/ChangeLog,v 1.28 2010/11/17 15:31:38 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/broadcom-sta/ChangeLog,v 1.29 2010/12/30 15:29:55 matsuu Exp $
+
+*broadcom-sta-5.100.82.38 (30 Dec 2010)
+
+ 30 Dec 2010; MATSUU Takuto <matsuu@gentoo.org>
+ +broadcom-sta-5.100.82.38.ebuild, +files/broadcom-sta-5.100.82.38-gcc.patch:
+ Version bumped, bug #349646. the ebuild is submitted by Yoan Blanc.
*broadcom-sta-5.60.246.6 (17 Nov 2010)
diff --git a/net-wireless/broadcom-sta/broadcom-sta-5.100.82.38.ebuild b/net-wireless/broadcom-sta/broadcom-sta-5.100.82.38.ebuild
new file mode 100644
index 000000000000..73a8514d751e
--- /dev/null
+++ b/net-wireless/broadcom-sta/broadcom-sta-5.100.82.38.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/broadcom-sta/broadcom-sta-5.100.82.38.ebuild,v 1.1 2010/12/30 15:29:55 matsuu Exp $
+
+EAPI="2"
+inherit eutils linux-mod
+
+DESCRIPTION="Broadcom's IEEE 802.11a/b/g/n hybrid Linux device driver."
+HOMEPAGE="http://www.broadcom.com/support/802.11/linux_sta.php"
+SRC_BASE="http://www.broadcom.com/docs/linux_sta/hybrid-portsrc_x86_"
+SRC_URI="x86? ( ${SRC_BASE}32-v${PV//\./_}.tar.gz )
+ amd64? ( ${SRC_BASE}64-v${PV//\./_}.tar.gz )"
+
+LICENSE="Broadcom"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="mirror"
+
+DEPEND=">=virtual/linux-sources-2.6.22"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+MODULE_NAMES="wl(net/wireless)"
+MODULESD_WL_ALIASES=("wlan0 wl")
+
+PROPERTIES="interactive"
+
+pkg_setup() {
+ check_license
+
+ # bug #300570
+ # NOTE<lxnay>: module builds correctly anyway with b43 and SSB enabled
+ # make checks non-fatal. The correct fix is blackisting ssb and, perhaps
+ # b43 via udev rules. Moreover, previous fix broke binpkgs support.
+ CONFIG_CHECK="~!B43 ~!SSB"
+ if kernel_is ge 2 6 33; then
+ CONFIG_CHECK="${CONFIG_CHECK} LIB80211 WIRELESS_EXT CFG80211_WEXT WEXT_PRIV ~!MAC80211"
+ ERROR_WEXT_PRIV="Starting with 2.6.33, it is not possible to set WEXT_PRIV directly. We recommend to set another symbol selecting WEXT_PRIV, for example, PRISM54, IPW2200 and so on. See Bug #248450 comment#98."
+ elif kernel_is ge 2 6 31; then
+ CONFIG_CHECK="${CONFIG_CHECK} LIB80211 WIRELESS_EXT ~!MAC80211"
+ elif kernel_is ge 2 6 29; then
+ CONFIG_CHECK="${CONFIG_CHECK} LIB80211 WIRELESS_EXT ~!MAC80211 COMPAT_NET_DEV_OPS"
+ else
+ CONFIG_CHECK="${CONFIG_CHECK} IEEE80211 IEEE80211_CRYPT_TKIP"
+ fi
+ linux-mod_pkg_setup
+
+ BUILD_PARAMS="-C ${KV_DIR} M=${S}"
+ BUILD_TARGETS="wl.ko"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-5.10.91.9-license.patch" \
+ "${FILESDIR}/${PN}-5.100.82.38-gcc.patch"
+}
diff --git a/net-wireless/broadcom-sta/files/broadcom-sta-5.100.82.38-gcc.patch b/net-wireless/broadcom-sta/files/broadcom-sta-5.100.82.38-gcc.patch
new file mode 100644
index 000000000000..048565376d75
--- /dev/null
+++ b/net-wireless/broadcom-sta/files/broadcom-sta-5.100.82.38-gcc.patch
@@ -0,0 +1,11 @@
+diff -Naur broadcom-sta-5.60.246.2.orig//src/wl/sys/wl_iw.h broadcom-sta-5.60.246.2/src/wl/sys/wl_iw.h
+--- broadcom-sta-5.60.246.2.orig//src/wl/sys/wl_iw.h 2010-10-08 07:32:59.000000000 +0900
++++ broadcom-sta-5.60.246.2/src/wl/sys/wl_iw.h 2010-10-28 00:50:57.925351964 +0900
+@@ -15,6 +15,7 @@
+ #ifndef _wl_iw_h_
+ #define _wl_iw_h_
+
++#include <linux/semaphore.h>
+ #include <linux/wireless.h>
+
+ #include <typedefs.h>