summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-gnustep/pantomime/ChangeLog7
-rw-r--r--app-gnustep/pantomime/Manifest5
-rw-r--r--app-gnustep/pantomime/files/pantomime-1.1.0_pre2-compilation-fix.diff10
-rw-r--r--app-gnustep/pantomime/pantomime-1.1.0_pre2.ebuild5
4 files changed, 21 insertions, 6 deletions
diff --git a/app-gnustep/pantomime/ChangeLog b/app-gnustep/pantomime/ChangeLog
index 45f3cbff19cd..01ef47c84e6c 100644
--- a/app-gnustep/pantomime/ChangeLog
+++ b/app-gnustep/pantomime/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-gnustep/pantomime
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-gnustep/pantomime/ChangeLog,v 1.2 2003/07/16 16:35:06 brain Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-gnustep/pantomime/ChangeLog,v 1.3 2003/07/17 12:05:51 brain Exp $
*pantomime-1.1.0_pre2 (15 Jul 2003)
-
+
+ 17 Jul 2003; Michele Balistreri <brain@gentoo.org> pantomime-1.1.0_pre2.ebuild:
+ Fixing compilation problems
+
16 Jul 2003; Michele Balistreri <brain@gentoo.org> pantomime-1.1.0_pre2.ebuild:
Changing license information as they were invalid
diff --git a/app-gnustep/pantomime/Manifest b/app-gnustep/pantomime/Manifest
index bbdbc0be20f3..e53214210a1c 100644
--- a/app-gnustep/pantomime/Manifest
+++ b/app-gnustep/pantomime/Manifest
@@ -1,4 +1,5 @@
-MD5 93442e13aedb931612e3ebaa749fa84e ChangeLog 489
-MD5 b176ceda779cf69a6d97e25d1f5ecbb6 pantomime-1.1.0_pre2.ebuild 550
+MD5 b1f4554f1a42ca02a420dc0ad0c65402 ChangeLog 600
+MD5 79c5bd8e2e4849733e11813180d10954 pantomime-1.1.0_pre2.ebuild 603
MD5 80699754a7e9adb6c02df33c8fa16fd6 metadata.xml 161
MD5 29c520038205a746e1f9e00360489b19 files/digest-pantomime-1.1.0_pre2 71
+MD5 c28a7f65a7973b51d359e26af1adc764 files/pantomime-1.1.0_pre2-compilation-fix.diff 312
diff --git a/app-gnustep/pantomime/files/pantomime-1.1.0_pre2-compilation-fix.diff b/app-gnustep/pantomime/files/pantomime-1.1.0_pre2-compilation-fix.diff
new file mode 100644
index 000000000000..39d87cac4843
--- /dev/null
+++ b/app-gnustep/pantomime/files/pantomime-1.1.0_pre2-compilation-fix.diff
@@ -0,0 +1,10 @@
+--- Source/NSString+Extensions.m.orig 2003-07-17 13:02:25.000000000 +0200
++++ Source/NSString+Extensions.m 2003-07-17 13:22:41.000000000 +0200
+@@ -28,6 +28,7 @@
+ #ifdef MACOSX
+ #import <CoreFoundation/CoreFoundation.h>
+ #else
++#include <Foundation/Foundation.h>
+ #include <gnustep/base/GSCategories.h>
+ #endif
+
diff --git a/app-gnustep/pantomime/pantomime-1.1.0_pre2.ebuild b/app-gnustep/pantomime/pantomime-1.1.0_pre2.ebuild
index d37f7bc4f56b..cefff0026ed2 100644
--- a/app-gnustep/pantomime/pantomime-1.1.0_pre2.ebuild
+++ b/app-gnustep/pantomime/pantomime-1.1.0_pre2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-gnustep/pantomime/pantomime-1.1.0_pre2.ebuild,v 1.2 2003/07/16 16:35:06 brain Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-gnustep/pantomime/pantomime-1.1.0_pre2.ebuild,v 1.3 2003/07/17 12:05:51 brain Exp $
-inherit gnustep
+inherit base gnustep
DESCRIPTION="A set of Objective-C classes that model a mail system"
HOMEPAGE="http://www.collaboration-world.com/pantomime/"
@@ -11,3 +11,4 @@ SRC_URI="http://www.collaboration-world.com/pantomime.data/releases/Stable/${PN/
KEYWORDS="x86"
SLOT="0"
S=${WORKDIR}/${PN/p/P}
+PATCHES="${FILESDIR}/${P}-compilation-fix.diff"