summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/pyephem/ChangeLog6
-rw-r--r--sci-astronomy/pyephem/metadata.xml15
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild50
3 files changed, 14 insertions, 57 deletions
diff --git a/sci-astronomy/pyephem/ChangeLog b/sci-astronomy/pyephem/ChangeLog
index da439c54b70b..529bc3b10b90 100644
--- a/sci-astronomy/pyephem/ChangeLog
+++ b/sci-astronomy/pyephem/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/pyephem
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.17 2012/08/05 19:18:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.18 2012/08/05 19:20:35 bicatali Exp $
+
+ 05 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> -pyephem-3.7.4.1.ebuild,
+ metadata.xml:
+ removed old
05 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> pyephem-3.7.5.1.ebuild:
keyword amd64-linux, x86-linux, switch to EAPI4
diff --git a/sci-astronomy/pyephem/metadata.xml b/sci-astronomy/pyephem/metadata.xml
index 4973eaeb4c9e..e09bb9cc9755 100644
--- a/sci-astronomy/pyephem/metadata.xml
+++ b/sci-astronomy/pyephem/metadata.xml
@@ -1,16 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-astronomy</herd>
- <longdescription lang="en">PyEphem provides astronomical computations for the Python programming
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ PyEphem provides astronomical computations for the Python programming
language. Given a date and location on the Earth's surface, it can
compute the positions of the Sun and Moon, of the planets and their
moons, and of any asteroids, comets, or earth satellites whose orbital
elements the user can provide. Additional functions are provided to
compute the angular separation between two objects in the sky, to
determine the constellation in which an object lies, and to find the
- times at which an object rises, transits, and sets on a particular day.</longdescription>
- <upstream>
- <remote-id type="pypi">pyephem</remote-id>
- </upstream>
+ times at which an object rises, transits, and sets on a particular
+ day.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">pyephem</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild b/sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild
deleted file mode 100644
index 6b8311bd22bc..000000000000
--- a/sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.4.1.ebuild,v 1.5 2012/02/25 02:47:03 patrick Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils eutils
-
-DESCRIPTION="Astronomical routines for the python programming language"
-LICENSE="LGPL-3"
-HOMEPAGE="http://rhodesmill.org/pyephem/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc test"
-RDEPEND=""
-DEPEND="doc? ( dev-python/sphinx )
- test? ( dev-python/setuptools )"
-
-src_prepare() {
- # don't install rst files
- sed -i -e "s:'doc/\*\.rst',::" "${S}"/setup.py || die
- distutils_src_prepare
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- cd src/ephem/doc
- PYTHONPATH=../../.. emake html || die "Building of documentation failed"
- fi
-}
-
-src_test() {
- # remove a buggy test (it's a doc test), check next version.
- mv src/ephem/tests/test_rst.py{,orig}
- distutils_src_test
-}
-
-src_install() {
- distutils_src_install
- if use doc; then
- dohtml -r src/ephem/doc/.build/html/* || die "Installation of documentation failed"
- fi
-}