summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/file/ChangeLog4
-rw-r--r--sys-apps/file/Manifest8
-rw-r--r--sys-apps/file/file-4.06.ebuild12
3 files changed, 13 insertions, 11 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index bcc81213c40d..4f1c86c76800 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,7 +1,9 @@
# ChangeLog for sys-apps/file
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.22 2003/10/18 00:50:21 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.23 2003/10/18 03:17:15 mr_bones_ Exp $
+ 17 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> file-4.06.ebuild:
+ fix failure of parallel make. bug 31356
*file-4.06 (17 Oct 2003)
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index 3c513cfc421d..976117b91255 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -1,20 +1,20 @@
-MD5 fd3066a20e607eac88ef38e99b74398b ChangeLog 3471
+MD5 6ae157e28b8879fb106826a39fd52f16 ChangeLog 3591
MD5 9199c0027f82ae3e018e2415de888492 file-3.37.ebuild 870
MD5 11c4331cb3a68b4bd5250959127e31c0 file-3.39.ebuild 1008
MD5 864d9d78ae48573d790cc598fcc4bc40 file-3.41.ebuild 1025
MD5 20dd962c51a7b039d867a7a99645fbb5 file-4.01.ebuild 936
MD5 e593a4a7dea3146bb413dea1737d48b6 file-4.02.ebuild 1093
MD5 eaf31df54d9fcbb759afd4c5e6dcfc7e file-4.03.ebuild 1102
+MD5 720c61561aace335be5c4f7843b154a4 file-4.06.ebuild 1462
MD5 e193046ccfd778ae4353b86efeb8d205 file-4.05.ebuild 1841
-MD5 16272f7470d2f68ee98815ed4630b540 file-4.06.ebuild 1379
MD5 3a18c97dfcc727e6c1b701cc8c03af47 files/digest-file-3.37 267
MD5 950dd57055e8275bd852869557035f42 files/digest-file-3.39 268
MD5 eabc698678353b52ea7d9bfb724d4e1e files/digest-file-3.41 268
MD5 419df5c3f794f6f0b42d8d78d5f9a0da files/digest-file-4.01 267
MD5 fd38ae2f761ce496f7caedf3226166ae files/digest-file-4.02 61
MD5 8a94349d0574b8fdb31ba08f31c8f5a7 files/digest-file-4.03 61
-MD5 d2817e86e2c224967c80ca7b38e418e3 files/digest-file-4.05 61
-MD5 50700bf6bff49778fd8c6083466a0813 files/digest-file-4.06 61
MD5 aff834708f034a4995abba4192e79583 files/file-3.39-gentoo.diff 4673
MD5 aff834708f034a4995abba4192e79583 files/file-3.41-mips-gentoo.diff 4673
+MD5 d2817e86e2c224967c80ca7b38e418e3 files/digest-file-4.05 61
MD5 8f6cec8c0754678a2817139182637eac files/file-4.05-mips-gentoo.diff 13035
+MD5 50700bf6bff49778fd8c6083466a0813 files/digest-file-4.06 61
diff --git a/sys-apps/file/file-4.06.ebuild b/sys-apps/file/file-4.06.ebuild
index 09b638af3489..330ca017f2f8 100644
--- a/sys-apps/file/file-4.06.ebuild
+++ b/sys-apps/file/file-4.06.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.06.ebuild,v 1.2 2003/10/18 00:50:21 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.06.ebuild,v 1.3 2003/10/18 03:17:15 mr_bones_ Exp $
inherit flag-o-matic
-S=${WORKDIR}/${P}
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
ftp://ftp.astron.com/pub/file/${P}.tar.gz"
@@ -22,7 +21,7 @@ src_unpack() {
# (12 Oct 2003) <kumba@gentoo.org>
# This patch is for MIPS only. It slightly changes the 'file' output
- # on MIPS machines to a specific format so that other programs can
+ # on MIPS machines to a specific format so that other programs can
# recognize things.
if [ "${ARCH}" = "mips" ]; then
epatch ${FILESDIR}/${P}-mips-gentoo.diff
@@ -39,14 +38,15 @@ src_compile() {
--datadir=/usr/share/misc \
--host=${CHOST} || die
- emake || die
+ # Buggy Makefiles. This fixes bug 31356
+ emake -j1 || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die "make install failed"
if [ -z "`use build`" ] ; then
- dodoc ChangeLog LEGAL.NOTICE MAINT README || die
+ dodoc ChangeLog LEGAL.NOTICE MAINT README || die "dodoc failed"
else
rm -rf ${D}/usr/share/man
fi