summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.3.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 9b3725409bb9..4b8c2e274a05 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.21 2009/06/14 11:57:20 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.22 2009/08/04 01:36:30 wired Exp $
+
+*step-4.3.0 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org> +step-4.3.0.ebuild:
+ Version bump
14 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -step-4.2.3.ebuild:
Drop KDE 4.2.3
diff --git a/kde-base/step/step-4.3.0.ebuild b/kde-base/step/step-4.3.0.ebuild
new file mode 100644
index 000000000000..3c5e9c8c5330
--- /dev/null
+++ b/kde-base/step/step-4.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.3.0.ebuild,v 1.1 2009/08/04 01:36:30 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)"
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this file collides with oxygen-icons
+ rm -f "${D}/usr/share/icons/oxygen/22x22/actions/pointer.png"
+}