summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/lame/ChangeLog8
-rw-r--r--media-sound/lame/files/digest-lame-3.97-r13
-rw-r--r--media-sound/lame/lame-3.97-r1.ebuild76
3 files changed, 86 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 3a1c45f4aa13..f8a37bfed6e6 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/lame
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.84 2007/06/23 03:05:11 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.85 2007/07/15 20:49:11 drac Exp $
+
+*lame-3.97-r1 (15 Jul 2007)
+
+ 15 Jul 2007; Samuli Suominen <drac@gentoo.org> +lame-3.97-r1.ebuild:
+ Stop installing mp3x analyzer based on GTK+-1.2. LAME is a library, and it
+ shouldn't be pulling obsolete toolkit. Try glame. Bug 168123.
23 Jun 2007; Joshua Kinard <kumba@gentoo.org> lame-3.97.ebuild:
Stable on mips, per #167391.
diff --git a/media-sound/lame/files/digest-lame-3.97-r1 b/media-sound/lame/files/digest-lame-3.97-r1
new file mode 100644
index 000000000000..1ea1b201f3f7
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.97-r1
@@ -0,0 +1,3 @@
+MD5 90a4acbb730d150dfe80de145126eef7 lame-3.97.tar.gz 1328058
+RMD160 5c4cf02c0f4e10c4cd2ab610d62478b554cd0873 lame-3.97.tar.gz 1328058
+SHA256 0a2334a6d11085298a9a3c46d5d310cca012f2e61d6efae90840a76a364dbe17 lame-3.97.tar.gz 1328058
diff --git a/media-sound/lame/lame-3.97-r1.ebuild b/media-sound/lame/lame-3.97-r1.ebuild
new file mode 100644
index 000000000000..628cb474708d
--- /dev/null
+++ b/media-sound/lame/lame-3.97-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.97-r1.ebuild,v 1.1 2007/07/15 20:49:11 drac Exp $
+
+inherit flag-o-matic toolchain-funcs eutils autotools
+
+DESCRIPTION="LAME Ain't an MP3 Encoder"
+HOMEPAGE="http://lame.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug mp3rtp"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # The frontened tries to link staticly, but we prefer shared libs
+ epatch "${FILESDIR}"/${PN}-3.96.1-shared-frontend.patch
+
+ # If ccc (alpha compiler) is installed on the system, the default
+ # configure is broken, fix it to respect CC. This is only
+ # directly broken for ARCH=alpha but would affect anybody with a
+ # ccc binary in their PATH. Bug #41908 (26 Jul 2004 agriffis)
+ epatch "${FILESDIR}"/${PN}-3.96-ccc.patch
+
+ # Make sure -lm is linked in the library to fix other programs linking to
+ # this while using --as-needed
+ epatch "${FILESDIR}"/${PN}-3.96.1-asneeded.patch
+
+ AT_M4DIR="${S}" eautoreconf || die
+ epunt_cxx # embedded bug #74498
+}
+
+src_compile() {
+ # take out -fomit-frame-pointer from CFLAGS if k6-2
+ is-flag "-march=k6-3" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && filter-flags "-fomit-frame-pointer"
+
+ # The user sets compiler optimizations... But if you'd like
+ # lame to choose it's own... uncomment one of these (experiMENTAL)
+ # myconf="${myconf} --enable-expopt=full \
+ # myconf="${myconf} --enable-expopt=norm \
+
+ econf \
+ --enable-shared \
+ $(use_enable debug debug norm) \
+ --disable-mp3x \
+ $(use_enable mp3rtp mp3rtp) \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkghtmldir="/usr/share/doc/${PF}/html" install || die
+
+ dodoc API ChangeLog HACKING README* STYLEGUIDE TODO USAGE
+ dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
+
+ dobin "${S}"/misc/mlame || die
+}
+
+pkg_postinst(){
+ if use mp3rtp ; then
+ ewarn "Warning, support for the encode-to-RTP program, 'mp3rtp'"
+ ewarn "is broken as of August 2001."
+ ewarn " "
+ fi
+}