summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/pcsc-lite/ChangeLog7
-rw-r--r--sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.03
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index fb970893f290..cb05ef3f09c3 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.34 2007/01/19 21:37:29 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.35 2007/02/14 21:00:41 alonbl Exp $
+
+*pcsc-lite-1.4.0 (14 Feb 2007)
+
+ 14 Feb 2007; Alon Bar-Lev <alonbl@gentoo.org> +pcsc-lite-1.4.0.ebuild:
+ Version bump
*pcsc-lite-1.3.3 (19 Jan 2007)
diff --git a/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.0 b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.0
new file mode 100644
index 000000000000..dac8c218d751
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.4.0
@@ -0,0 +1,3 @@
+MD5 9ac845b62a683ce9f7c1331741f422ee pcsc-lite-1.4.0.tar.gz 862058
+RMD160 69d6ed2cf87772e5b2781675f38e9740ec432faf pcsc-lite-1.4.0.tar.gz 862058
+SHA256 671317c4543452f4618a4e6d97f9d09c89fb518a2010a0a04e3e8c67791477ab pcsc-lite-1.4.0.tar.gz 862058
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild
new file mode 100644
index 000000000000..addba98ccc43
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild,v 1.1 2007/02/14 21:00:41 alonbl Exp $
+
+inherit multilib
+
+STUPID_NUM="1884"
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static debug"
+
+RDEPEND="!static? ( dev-libs/libusb )"
+DEPEND="dev-libs/libusb
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ --enable-muscledropdir="/usr/share/pcsc/services" \
+ --enable-runpid="/var/run/pcscd.pid" \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog DRIVERS HELP INSTALL NEWS README SECURITY
+ dodoc doc/*.pdf doc/README.DAEMON
+
+ newinitd "${FILESDIR}"/pcscd-init pcscd
+ newconfd "${FILESDIR}"/pcscd-confd pcscd
+}
+
+pkg_postinst() {
+ ewarn "You should run 'revdep-rebuild --library libpcsclite.so.0'"
+}