summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmlife/ChangeLog9
-rw-r--r--x11-plugins/wmlife/wmlife-1.0.0.ebuild21
-rw-r--r--x11-plugins/wmlife/wmlife-1.0.1.ebuild14
3 files changed, 18 insertions, 26 deletions
diff --git a/x11-plugins/wmlife/ChangeLog b/x11-plugins/wmlife/ChangeLog
index 8d5e032be7a7..2390dd8461f4 100644
--- a/x11-plugins/wmlife/ChangeLog
+++ b/x11-plugins/wmlife/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmlife
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlife/ChangeLog,v 1.5 2012/08/27 09:15:47 voyageur Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlife/ChangeLog,v 1.6 2014/04/07 19:40:20 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> wmlife-1.0.0.ebuild,
+ wmlife-1.0.1.ebuild:
+ Use EAPI5 instead of EAPI1.
*wmlife-1.0.1 (27 Aug 2012)
@@ -22,4 +26,3 @@
12 Jan 2008; Samuli Suominen <drac@gentoo.org>
+files/wmlife-1.0.0-stringh.patch, +wmlife-1.0.0.ebuild:
Initial commit.
-
diff --git a/x11-plugins/wmlife/wmlife-1.0.0.ebuild b/x11-plugins/wmlife/wmlife-1.0.0.ebuild
index 026670200b01..0da1fb8ca689 100644
--- a/x11-plugins/wmlife/wmlife-1.0.0.ebuild
+++ b/x11-plugins/wmlife/wmlife-1.0.0.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlife/wmlife-1.0.0.ebuild,v 1.4 2012/05/05 05:12:01 jdhore Exp $
-
-EAPI="1"
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlife/wmlife-1.0.0.ebuild,v 1.5 2014/04/07 19:40:20 ssuominen Exp $
+EAPI=5
inherit eutils
DESCRIPTION="dockapp running Conway's Game of Life (and program launcher)."
@@ -26,18 +25,12 @@ RDEPEND="x11-libs/gtk+:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
epatch "${FILESDIR}"/${P}-stringh.patch
}
-src_compile() {
+src_configure() {
econf --enable-session
- emake || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog NEWS README
}
diff --git a/x11-plugins/wmlife/wmlife-1.0.1.ebuild b/x11-plugins/wmlife/wmlife-1.0.1.ebuild
index 62804b123bc0..90feedf76489 100644
--- a/x11-plugins/wmlife/wmlife-1.0.1.ebuild
+++ b/x11-plugins/wmlife/wmlife-1.0.1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlife/wmlife-1.0.1.ebuild,v 1.1 2012/08/27 09:15:47 voyageur Exp $
-
-EAPI=4
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlife/wmlife-1.0.1.ebuild,v 1.2 2014/04/07 19:40:20 ssuominen Exp $
+EAPI=5
inherit eutils
DESCRIPTION="dockapp running Conway's Game of Life (and program launcher)."
@@ -26,6 +25,8 @@ RDEPEND="x11-libs/gtk+:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
+DOCS="AUTHORS ChangeLog NEWS README"
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.0-stringh.patch
}
@@ -33,8 +34,3 @@ src_prepare() {
src_configure() {
econf --enable-session
}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog NEWS README
-}