summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild8
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.2.3.ebuild17
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.2.5.ebuild16
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild5
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild5
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.2.ebuild29
-rw-r--r--dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild13
-rw-r--r--dev-util/cvsd/cvsd-0.9.19.ebuild39
-rw-r--r--dev-util/gpsim/gpsim-0.20.14.ebuild14
-rw-r--r--dev-util/kprof/kprof-1.4.2.ebuild13
-rw-r--r--dev-util/shc/shc-3.4.ebuild22
-rw-r--r--dev-util/shc/shc-3.6.ebuild17
12 files changed, 88 insertions, 110 deletions
diff --git a/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild b/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild
index 01d5880fd168..00c2640966cc 100644
--- a/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild,v 1.3 2003/08/01 20:49:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-1.2.9-r2.ebuild,v 1.4 2003/08/07 03:35:15 vapier Exp $
+
+inherit eutils
DESCRIPTION="C++ interface for GTK+"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
SRC_URI="http://download.sourceforge.net/gtkmm/${P}.tar.gz"
# ftp://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${P}.tar.gz
# http://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${P}.tar.gz"
-HOMEPAGE="http://gtkmm.sourceforge.net/"
LICENSE="GPL-2"
SLOT="1.2"
@@ -22,7 +24,7 @@ src_unpack() {
# this patch applies only to gtkmm-1.2.9. gtkmm has been fixed
# in CVS. It fixes a build problem with gcc3.1.
# (http://marc.theaimsgroup.com/?l=gtkmm&m=101879848701486&w=2)
- patch -p0 <${FILESDIR}/gtkmm-1.2.9-gcc3.1-gentoo.patch
+ epatch ${FILESDIR}/gtkmm-1.2.9-gcc3.1-gentoo.patch
}
src_compile() {
diff --git a/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild b/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild
index 81af917fdd9e..d9a4738789ca 100644
--- a/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild
@@ -1,29 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild,v 1.2 2003/07/23 21:09:39 gmsoft Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.2.3.ebuild,v 1.3 2003/08/07 03:35:15 vapier Exp $
inherit gnome2
-S=${WORKDIR}/${P}
-IUSE=""
DESCRIPTION="C++ interface for GTK+2"
HOMEPAGE="http://gtkmm.sourceforge.net/"
-LICENSE="LGPL-2.1"
-KEYWORDS="x86 ~ppc ~sparc hppa"
+LICENSE="LGPL-2.1"
SLOT="2"
+KEYWORDS="x86 ~ppc ~sparc hppa"
RDEPEND=">=dev-libs/glib-2.2
>=x11-libs/gtk+-2.2
>=dev-libs/libsigc++-1.2
!=sys-devel/gcc-3.3.0*"
-
DEPEND="${RDEPEND}
>=dev-lang/perl-5.6.0
dev-util/pkgconfig"
-DOCS="AUTHORS CHANGES COPYING ChangeLog HACKING PORTING NEWS README TODO"
-
-
-
-
+DOCS="AUTHORS CHANGES ChangeLog HACKING PORTING NEWS README TODO"
diff --git a/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild b/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild
index 6e06d1e070ef..e1fe947b8d45 100644
--- a/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild
@@ -1,26 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild,v 1.1 2003/07/25 15:52:16 foser Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.2.5.ebuild,v 1.2 2003/08/07 03:35:15 vapier Exp $
inherit gnome2
-IUSE=""
DESCRIPTION="C++ interface for GTK+2"
HOMEPAGE="http://gtkmm.sourceforge.net/"
-LICENSE="LGPL-2.1"
-KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="LGPL-2.1"
SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc"
RDEPEND=">=dev-libs/glib-2.2
>=x11-libs/gtk+-2.2
>=dev-libs/libsigc++-1.2"
-
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-DOCS="AUTHORS CHANGES COPYING ChangeLog HACKING PORTING NEWS README TODO"
-
-
-
-
+DOCS="AUTHORS CHANGES ChangeLog HACKING PORTING NEWS README TODO"
diff --git a/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild
index 4c59ae7b0295..b000f394c6fb 100644
--- a/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild
+++ b/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild,v 1.2 2003/07/11 20:49:57 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.21.0.ebuild,v 1.3 2003/08/07 03:34:05 vapier Exp $
MY_P=${P/pp/++}
DESCRIPTION="C++ wrapper for the libxml XML parser library"
@@ -10,7 +10,6 @@ SRC_URI="mirror://sourceforge/libxmlplusplus/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
-IUSE=""
DEPEND=">=dev-libs/libxml2-2.5.1"
diff --git a/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild
index 2b39a24e13aa..72ec879c9d38 100644
--- a/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild
+++ b/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild,v 1.1 2003/06/19 00:41:50 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-0.24.0.ebuild,v 1.2 2003/08/07 03:34:05 vapier Exp $
MY_P=${P/pp/++}
DESCRIPTION="C++ wrapper for the libxml XML parser library"
@@ -10,7 +10,6 @@ SRC_URI="mirror://sourceforge/libxmlplusplus/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc"
-IUSE=""
DEPEND=">=dev-libs/libxml2-2.5.1"
diff --git a/dev-tex/cpp2latex/cpp2latex-2.2.ebuild b/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
index c1c0dc450a5f..a91be496cc41 100644
--- a/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
+++ b/dev-tex/cpp2latex/cpp2latex-2.2.ebuild
@@ -1,30 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.2.ebuild,v 1.1 2003/06/09 07:32:39 satai Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.2.ebuild,v 1.2 2003/08/07 03:32:58 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="A program to convert C++ code to LaTeX source"
-SRC_URI="http://www.arnoldarts.de/${P}.tar.gz"
HOMEPAGE="http://www.arnoldarts.de/cpp2latex.html"
+SRC_URI="http://www.arnoldarts.de/${P}.tar.gz"
-DEPEND="virtual/glibc
- app-text/tetex"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc"
+DEPEND="virtual/glibc
+ app-text/tetex"
+
src_unpack () {
unpack ${A}
cd ${S}
- patch -p 0 < ${FILESDIR}/main.cpp.patch
+ epatch ${FILESDIR}/main.cpp.patch
}
-src_compile () {
- econf
- emake
+src_compile() {
+ econf || die
+ emake || die
}
-src_install () {
- make install DESTDIR=${D} || die make install failed
+src_install() {
+ make install DESTDIR=${D} || die make install failed
}
diff --git a/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild b/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild
index 887ad91cce3a..06838ad975a7 100644
--- a/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild
+++ b/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild
@@ -1,17 +1,22 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cweb_latex/cweb_latex-1.1.1.ebuild,v 1.2 2003/08/07 03:33:41 vapier Exp $
+
+PATCHES="${FILESDIR}/cweb.cls.patch"
inherit latex-package
-S="${WORKDIR}/cweb-sty-${PV}"
DESCRIPTION="LaTeX package for using LaTeX with CWEB"
SRC_URI="ftp://ftp.th-darmstadt.de//programming/literate-programming/c.c++/cweb-sty-${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 mips"
-PATCHES="${FILESDIR}/cweb.cls.patch"
-# this package has a .tex file which needs to go with the cweb.sty
+S="${WORKDIR}/cweb-sty-${PV}"
+
src_install() {
- cd ${S}
latex-package_src_install
+ # this package has a .tex file which needs to go with the cweb.sty
insinto ${TEXMF}/tex/latex/${PN}
doins cwebbase.tex
}
diff --git a/dev-util/cvsd/cvsd-0.9.19.ebuild b/dev-util/cvsd/cvsd-0.9.19.ebuild
index b8d7ac0a1cad..c4f92da60b42 100644
--- a/dev-util/cvsd/cvsd-0.9.19.ebuild
+++ b/dev-util/cvsd/cvsd-0.9.19.ebuild
@@ -1,30 +1,28 @@
-S=${WORKDIR}/${P}
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsd/cvsd-0.9.19.ebuild,v 1.2 2003/08/07 03:30:25 vapier Exp $
+
DESCRIPTION="CVS pserver daemon"
-SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
HOMEPAGE="http://tiefighter.et.tudelft.nl/~arthur/cvsd/"
-DEPEND="virtual/glibc"
+SRC_URI="http://tiefighter.et.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
-src_compile() {
- cd ${S}
- local myconf
-
- use tcpd && myconf="${myconf} --with-libwrap"
-
- econf --prefix=/usr ${myconf} || die
+DEPEND="virtual/glibc"
+src_compile() {
+ local myconf=""
+ use tcpd && myconf="--with-libwrap"
+ econf ${myconf} || die
make || die
}
src_install() {
- exeinto /usr/sbin
- doexe cvsd cvsd-buildroot cvsd-passwd
+ dosbin cvsd cvsd-buildroot cvsd-passwd
insinto /etc/cvsd
- mv cvsd.conf-dist cvsd.conf
- doins cvsd.conf
+ newins cvsd.conf-dist cvsd.conf
dodoc COPYING* ChangeLog* FAQ
dodoc NEWS README* TODO
@@ -32,12 +30,11 @@ src_install() {
doman cvsd-buildroot.8 cvsd-passwd.8 cvsd.8 cvsd.conf.5
exeinto /etc/init.d ; newexe ${FILESDIR}/cvsd.init cvsd
- insinto /etc/conf.d ; newins ${FILESDIR}/cvsd.confd cvsd
-
+ insinto /etc/conf.d ; newins ${FILESDIR}/cvsd.confd cvsd
}
+
pkg_postinst() {
- einfo
- einfo "To configure cvsd please read /usr/share/cvsd-0.9.17/README.gz"
- einfo
+ einfo
+ einfo "To configure cvsd please read /usr/share/cvsd-0.9.17/README.gz"
+ einfo
}
-
diff --git a/dev-util/gpsim/gpsim-0.20.14.ebuild b/dev-util/gpsim/gpsim-0.20.14.ebuild
index 06e663652c15..2c6d35bcf196 100644
--- a/dev-util/gpsim/gpsim-0.20.14.ebuild
+++ b/dev-util/gpsim/gpsim-0.20.14.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Copyright 2003 Alex Holden <alex@alexholden.net>
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gpsim/gpsim-0.20.14.ebuild,v 1.2 2003/07/12 14:28:13 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gpsim/gpsim-0.20.14.ebuild,v 1.3 2003/08/07 03:32:14 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="A simulator for the Microchip PIC microcontrollers"
-SRC_URI="http://www.dattalo.com/gnupic/${P}.tar.gz"
HOMEPAGE="http://www.dattalo.com/gnupic/gpsim.html"
+SRC_URI="http://www.dattalo.com/gnupic/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
DEPEND="x11-libs/gtk+extra"
@@ -17,7 +17,7 @@ DEPEND="x11-libs/gtk+extra"
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
- patch -p1 < ${FILESDIR}/${P}-gcc3.2.patch
+ epatch ${FILESDIR}/${P}-gcc3.2.patch
}
src_compile(){
diff --git a/dev-util/kprof/kprof-1.4.2.ebuild b/dev-util/kprof/kprof-1.4.2.ebuild
index 99b02e6ba506..d32bc21e1263 100644
--- a/dev-util/kprof/kprof-1.4.2.ebuild
+++ b/dev-util/kprof/kprof-1.4.2.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kprof/kprof-1.4.2.ebuild,v 1.2 2003/07/12 14:28:13 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kprof/kprof-1.4.2.ebuild,v 1.3 2003/08/07 03:31:38 vapier Exp $
inherit kde-base
need-kde 3
-IUSE=""
DESCRIPTION="A KDE3 visual tool helping developers to analyze the profiling results generated by code profilers."
+HOMEPAGE="http://kprof.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://kprof.sourceforge.net"
-LICENSE="GPL-2"
+
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
src_unpack() {
base_src_unpack
-
# Rename the source directory to include the version to make the eclass happy
mv ${WORKDIR}/${PN} ${WORKDIR}/${P}
}
-
diff --git a/dev-util/shc/shc-3.4.ebuild b/dev-util/shc/shc-3.4.ebuild
index b483ad07f3e4..2d25d9f81351 100644
--- a/dev-util/shc/shc-3.4.ebuild
+++ b/dev-util/shc/shc-3.4.ebuild
@@ -1,33 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.4.ebuild,v 1.3 2003/02/13 12:00:30 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.4.ebuild,v 1.4 2003/08/07 03:31:15 vapier Exp $
-IUSE=""
-
-DESCRIPTION="A (shell-) script compiler/scrambler."
-SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
+DESCRIPTION="A (shell-) script compiler/scrambler"
HOMEPAGE="http://www.datsi.fi.upm.es/~frosal"
+SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
DEPEND="virtual/glibc"
-src_unpack() {
- unpack ${P}.tgz
- cd ${S}
-}
-
src_compile() {
## the "test"-target leads to an access-violation -> so we skip it
## as it's only for demonstration purposes anyway.
make shc || die
}
-src_install () {
- exeinto /usr/bin
- doexe shc
+src_install() {
+ dobin shc
doman shc.1
dodoc shc.README CHANGES
}
diff --git a/dev-util/shc/shc-3.6.ebuild b/dev-util/shc/shc-3.6.ebuild
index 1884e1040a3a..4041e4175345 100644
--- a/dev-util/shc/shc-3.6.ebuild
+++ b/dev-util/shc/shc-3.6.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.6.ebuild,v 1.2 2003/07/12 14:28:13 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.6.ebuild,v 1.3 2003/08/07 03:31:15 vapier Exp $
-IUSE=""
-
-DESCRIPTION="A (shell-) script compiler/scrambler."
-SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
+DESCRIPTION="A (shell-) script compiler/scrambler"
HOMEPAGE="http://www.datsi.fi.upm.es/~frosal"
+SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
DEPEND="virtual/glibc"
@@ -20,9 +18,8 @@ src_compile() {
make shc || die
}
-src_install () {
- exeinto /usr/bin
- doexe shc
+src_install() {
+ dobin shc
doman shc.1
dodoc shc.README CHANGES
}