summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/molecule/ChangeLog7
-rw-r--r--dev-util/molecule/molecule-0.9.24.3.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-util/molecule/ChangeLog b/dev-util/molecule/ChangeLog
index 65002bea519e..1fe79ad5cdbc 100644
--- a/dev-util/molecule/ChangeLog
+++ b/dev-util/molecule/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/molecule
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.32 2012/08/01 14:15:08 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.33 2012/09/05 11:56:52 lxnay Exp $
+
+*molecule-0.9.24.3 (05 Sep 2012)
+
+ 05 Sep 2012; Fabio Erculiani <lxnay@gentoo.org> +molecule-0.9.24.3.ebuild:
+ version bump
*molecule-0.9.24.2 (01 Aug 2012)
diff --git a/dev-util/molecule/molecule-0.9.24.3.ebuild b/dev-util/molecule/molecule-0.9.24.3.ebuild
new file mode 100644
index 000000000000..6f676b3325c6
--- /dev/null
+++ b/dev-util/molecule/molecule-0.9.24.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.24.3.ebuild,v 1.1 2012/09/05 11:56:53 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+
+inherit python
+
+DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="net-misc/rsync
+ sys-fs/squashfs-tools
+ sys-process/lsof
+ virtual/cdrtools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/molecule"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/molecule"
+}