summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/glib/ChangeLog10
-rw-r--r--dev-libs/glib/files/glib-2.24-punt-python-check.patch20
-rw-r--r--dev-libs/glib/files/glib-2.26.1-gsettings-read.patch25
-rw-r--r--dev-libs/glib/files/glib-2.26.1-locked-message.patch68
-rw-r--r--dev-libs/glib/glib-1.2.10-r5.ebuild5
-rw-r--r--dev-libs/glib/glib-2.28.5.ebuild171
-rw-r--r--dev-libs/glib/glib-2.28.7.ebuild5
7 files changed, 15 insertions, 289 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 99258134aa3c..2e4422bff7f0 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.466 2011/05/28 17:25:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.467 2011/06/05 13:12:30 pacho Exp $
+
+ 05 Jun 2011; Pacho Ramos <pacho@gentoo.org> glib-1.2.10-r5.ebuild,
+ -files/glib-2.24-punt-python-check.patch,
+ -files/glib-2.26.1-gsettings-read.patch,
+ -files/glib-2.26.1-locked-message.patch, -glib-2.28.5.ebuild,
+ glib-2.28.7.ebuild:
+ Block broken gtk-doc versions that causes problems like bug #363213. Remove
+ old. Make repoman happier with glib-1.
28 May 2011; Raúl Porcel <armin76@gentoo.org> glib-2.28.6.ebuild:
Add patch to fix bug 368275 again
diff --git a/dev-libs/glib/files/glib-2.24-punt-python-check.patch b/dev-libs/glib/files/glib-2.24-punt-python-check.patch
deleted file mode 100644
index 3cbd6dc15155..000000000000
--- a/dev-libs/glib/files/glib-2.24-punt-python-check.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Remove python detection from configure.in, we won't be installing the gdb python
-scripts anymore. They use a redhat-specific gdb module that has not been
-upstreamed yet.
-
-https://bugs.gentoo.org/291328
-https://bugzilla.gnome.org/623552
----
---- configure.in
-+++ configure.in
-@@ -379,10 +379,6 @@ if test "x$PERL_PATH" = x ; then
- fi
- AC_SUBST(PERL_PATH)
-
--# Need suitable python path for greport
--AM_PATH_PYTHON(2.4,,PYTHON="/usr/bin/env python2.4")
--
--
- dnl ***********************
- dnl *** Tests for iconv ***
- dnl ***********************
diff --git a/dev-libs/glib/files/glib-2.26.1-gsettings-read.patch b/dev-libs/glib/files/glib-2.26.1-gsettings-read.patch
deleted file mode 100644
index fa5b081bcc36..000000000000
--- a/dev-libs/glib/files/glib-2.26.1-gsettings-read.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 900a4c853f8dbf0887c66155ba489ff4570e5948 Mon Sep 17 00:00:00 2001
-From: Matthew Barnes <mbarnes@redhat.com>
-Date: Wed, 01 Dec 2010 00:19:12 +0000
-Subject: Bug 636100 - Can't read GSettings:backend property
-
-The PROP_BACKEND case was missing from the switch statement in
-g_settings_get_property().
----
-diff --git a/gio/gsettings.c b/gio/gsettings.c
-index 94d1f3a..7f775a0 100644
---- a/gio/gsettings.c
-+++ b/gio/gsettings.c
-@@ -417,6 +417,10 @@ g_settings_get_property (GObject *object,
- g_value_set_string (value, settings->priv->schema_name);
- break;
-
-+ case PROP_BACKEND:
-+ g_value_set_object (value, settings->priv->backend);
-+ break;
-+
- case PROP_PATH:
- g_value_set_string (value, settings->priv->path);
- break;
---
-cgit v0.8.3.1
diff --git a/dev-libs/glib/files/glib-2.26.1-locked-message.patch b/dev-libs/glib/files/glib-2.26.1-locked-message.patch
deleted file mode 100644
index acec46e5daf8..000000000000
--- a/dev-libs/glib/files/glib-2.26.1-locked-message.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 62476cd0f7ca7d3becf81243fb7ac1b97cf7db51 Mon Sep 17 00:00:00 2001
-From: Peng Huang <shawn.p.huang@gmail.com>
-Date: Mon, 13 Dec 2010 18:09:38 +0000
-Subject: Bug 632544 – Cannot send a locked message with PRESERVE_SERIAL flag
-
-https://bugzilla.gnome.org/show_bug.cgi?id=632544
-
-Signed-off-by: David Zeuthen <davidz@redhat.com>
----
-diff --git a/gio/gdbusconnection.c b/gio/gdbusconnection.c
-index da2b9f9..cf12f41 100644
---- a/gio/gdbusconnection.c
-+++ b/gio/gdbusconnection.c
-@@ -1449,7 +1449,8 @@ g_dbus_connection_send_message_unlocked (GDBusConnection *connection,
- if (out_serial != NULL)
- *out_serial = serial_to_use;
-
-- g_dbus_message_set_serial (message, serial_to_use);
-+ if (!(flags & G_DBUS_SEND_MESSAGE_FLAGS_PRESERVE_SERIAL))
-+ g_dbus_message_set_serial (message, serial_to_use);
-
- g_dbus_message_lock (message);
- _g_dbus_worker_send_message (connection->worker,
-diff --git a/gio/tests/gdbus-connection.c b/gio/tests/gdbus-connection.c
-index 866e27c..5c2939e 100644
---- a/gio/tests/gdbus-connection.c
-+++ b/gio/tests/gdbus-connection.c
-@@ -880,6 +880,18 @@ test_connection_filter (void)
-
- m2 = g_dbus_message_copy (m, &error);
- g_assert_no_error (error);
-+ g_dbus_message_set_serial (m2, data.serial);
-+ /* lock the message to test PRESERVE_SERIAL flag. */
-+ g_dbus_message_lock (m2);
-+ g_dbus_connection_send_message (c, m2, G_DBUS_SEND_MESSAGE_FLAGS_PRESERVE_SERIAL, &data.serial, &error);
-+ g_object_unref (m2);
-+ g_assert_no_error (error);
-+
-+ while (data.num_handled == 2)
-+ g_thread_yield ();
-+
-+ m2 = g_dbus_message_copy (m, &error);
-+ g_assert_no_error (error);
- r = g_dbus_connection_send_message_with_reply_sync (c,
- m2,
- G_DBUS_SEND_MESSAGE_FLAGS_NONE,
-@@ -891,7 +903,7 @@ test_connection_filter (void)
- g_assert_no_error (error);
- g_assert (r != NULL);
- g_object_unref (r);
-- g_assert_cmpint (data.num_handled, ==, 3);
-+ g_assert_cmpint (data.num_handled, ==, 4);
-
- g_dbus_connection_remove_filter (c, filter_id);
-
-@@ -908,8 +920,8 @@ test_connection_filter (void)
- g_assert_no_error (error);
- g_assert (r != NULL);
- g_object_unref (r);
-- g_assert_cmpint (data.num_handled, ==, 3);
-- g_assert_cmpint (data.num_outgoing, ==, 3);
-+ g_assert_cmpint (data.num_handled, ==, 4);
-+ g_assert_cmpint (data.num_outgoing, ==, 4);
-
- /* this is safe; testserver will exit once the bus goes away */
- g_assert (g_spawn_command_line_async (SRCDIR "/gdbus-testserver.py", NULL));
---
-cgit v0.8.3.1
diff --git a/dev-libs/glib/glib-1.2.10-r5.ebuild b/dev-libs/glib/glib-1.2.10-r5.ebuild
index 6852e8d2b17f..f2335ade2aa2 100644
--- a/dev-libs/glib/glib-1.2.10-r5.ebuild
+++ b/dev-libs/glib/glib-1.2.10-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.53 2008/08/03 22:36:31 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.54 2011/06/05 13:12:30 pacho Exp $
inherit autotools libtool flag-o-matic eutils portability
@@ -16,6 +16,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-
IUSE="hardened"
DEPEND=""
+RDEPEND=""
src_unpack() {
unpack ${A}
diff --git a/dev-libs/glib/glib-2.28.5.ebuild b/dev-libs/glib/glib-2.28.5.ebuild
deleted file mode 100644
index 443b70bf3410..000000000000
--- a/dev-libs/glib/glib-2.28.5.ebuild
+++ /dev/null
@@ -1,171 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.28.5.ebuild,v 1.2 2011/04/26 21:12:33 eva Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-
-inherit autotools gnome.org libtool eutils flag-o-matic pax-utils python virtualx
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc fam +introspection selinux +static-libs test xattr"
-
-RDEPEND="virtual/libiconv
- sys-libs/zlib
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- >=dev-util/gtk-doc-am-1.13
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.13
- ~app-text/docbook-xml-dtd-4.1.2 )
- test? ( >=sys-apps/dbus-1.2.14 )"
-PDEPEND="introspection? ( dev-libs/gobject-introspection )
- !<gnome-base/gvfs-1.6.4-r990" # Earlier versions do not work with glib
-
-# XXX: Consider adding test? ( sys-devel/gdb ); assert-msg-test tries to use it
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # Don't fail gio tests when ran without userpriv, upstream bug 552912
- # This is only a temporary workaround, remove as soon as possible
- epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- # Don't check for python, hence removing the build-time python dep.
- # We remove the gdb python scripts in src_install due to bug 291328
- epatch "${FILESDIR}/${PN}-2.25-punt-python-check.patch"
-
- # Fix test failure when upgrading from 2.22 to 2.24, upstream bug 621368
- epatch "${FILESDIR}/${PN}-2.24-assert-test-failure.patch"
-
- # Do not try to remove files on live filesystem, upstream bug #619274
- sed 's:^\(.*"/desktop-app-info/delete".*\):/*\1*/:' \
- -i "${S}"/gio/tests/desktop-app-info.c || die "sed failed"
-
- # Disable failing tests, upstream bug #???
- epatch "${FILESDIR}/${PN}-2.26.0-disable-locale-sensitive-test.patch"
- epatch "${FILESDIR}/${PN}-2.26.0-disable-volumemonitor-broken-test.patch"
-
- if ! use test; then
- # don't waste time building tests
- sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
- || die "sed failed"
- fi
-
- # Needed for the punt-python-check patch, disabling timeout test
- # Also needed to prevent croscompile failures, see bug #267603
- eautoreconf
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-
- epunt_cxx
-}
-
-src_configure() {
- local myconf
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
-
- # Always use internal libpcre, bug #254659
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- $(use_enable static-libs static) \
- --enable-regex \
- --with-pcre=internal \
- --with-threads=posix \
- --disable-dtrace \
- --disable-systemtap
-}
-
-src_install() {
- local f
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${ED}/usr/lib/charset.alias"
-
- # Don't install gdb python macros, bug 291328
- rm -rf "${ED}/usr/share/gdb/" "${ED}/usr/share/glib-2.0/gdb/"
-
- dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
-
- insinto /usr/share/bash-completion
- for f in gdbus gsettings; do
- newins "${ED}/etc/bash_completion.d/${f}-bash-completion.sh" ${f} || die
- done
- rm -rf "${ED}/etc"
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- export XDG_CONFIG_DIRS=/etc/xdg
- export XDG_DATA_DIRS=/usr/local/share:/usr/share
- export G_DBUS_COOKIE_SHA1_KEYRING_DIR="${T}/temp"
- export XDG_DATA_HOME="${T}"
- unset GSETTINGS_BACKEND # bug 352451
-
- # Related test is a bit nitpicking
- mkdir "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
- chmod 0700 "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
-
- # Hardened: gdb needs this, bug #338891
- if host-is-pax ; then
- pax-mark -mr "${S}"/tests/.libs/assert-msg-test \
- || die "Hardened adjustment failed"
- fi
-
- # Need X for dbus-launch session X11 initialization
- Xemake check || die "tests failed"
-}
-
-pkg_preinst() {
- # Only give the introspection message if:
- # * The user has it enabled
- # * Has glib already installed
- # * Previous version was different from new version
- if use introspection && has_version "${CATEGORY}/${PN}"; then
- if ! has_version "=${CATEGORY}/${PF}"; then
- ewarn "You must rebuild gobject-introspection so that the installed"
- ewarn "typelibs and girs are regenerated for the new APIs in glib"
- fi
- fi
-}
-
-pkg_postinst() {
- # Inform users about possible breakage when updating glib and not dbus-glib, bug #297483
- if has_version dev-libs/dbus-glib; then
- ewarn "If you experience a breakage after updating dev-libs/glib try"
- ewarn "rebuilding dev-libs/dbus-glib"
- fi
-}
diff --git a/dev-libs/glib/glib-2.28.7.ebuild b/dev-libs/glib/glib-2.28.7.ebuild
index d3e78b685f4f..c3aa4607a3a1 100644
--- a/dev-libs/glib/glib-2.28.7.ebuild
+++ b/dev-libs/glib/glib-2.28.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.28.7.ebuild,v 1.1 2011/05/21 19:19:16 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.28.7.ebuild,v 1.2 2011/06/05 13:12:30 pacho Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -29,7 +29,8 @@ DEPEND="${RDEPEND}
>=dev-util/gtk-doc-1.13
~app-text/docbook-xml-dtd-4.1.2 )
test? ( dev-util/pkgconfig
- >=sys-apps/dbus-1.2.14 )"
+ >=sys-apps/dbus-1.2.14 )
+ !<dev-util/gtk-doc-1.15-r2"
PDEPEND="introspection? ( dev-libs/gobject-introspection )
!<gnome-base/gvfs-1.6.4-r990" # Earlier versions do not work with glib