summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/noatun-plugins/ChangeLog6
-rw-r--r--kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild20
2 files changed, 13 insertions, 13 deletions
diff --git a/kde-base/noatun-plugins/ChangeLog b/kde-base/noatun-plugins/ChangeLog
index d63a3efd0bf0..9333eac75696 100644
--- a/kde-base/noatun-plugins/ChangeLog
+++ b/kde-base/noatun-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/noatun-plugins
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.45 2006/06/01 21:07:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.46 2006/06/12 22:20:32 carlo Exp $
+
+ 12 Jun 2006; Carsten Lohrke <carlo@gentoo.org>
+ noatun-plugins-3.5.3.ebuild:
+ Fix bug #136299.
*noatun-plugins-3.5.3 (01 Jun 2006)
diff --git a/kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild b/kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild
index 7a8704ae5007..e878148b12f6 100644
--- a/kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild
+++ b/kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild
@@ -1,31 +1,27 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild,v 1.1 2006/06/01 21:07:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.3.ebuild,v 1.2 2006/06/12 22:20:32 carlo Exp $
KMNAME=kdeaddons
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta
+inherit db-use kde-meta
-DESCRIPTION="Various plugins for noatun"
+DESCRIPTION="Various plugins for Noatun."
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="arts sdl berkdb"
+
DEPEND="$(deprange-dual $PV $MAXKDEVER kde-base/noatun)
arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
sdl? ( >=media-libs/libsdl-1.2 )
- berkdb? ( || ( =sys-libs/db-4.3*
- =sys-libs/db-4.2* ) )"
+ berkdb? ( =sys-libs/db-4* )"
+RDEPEND="${DEPEND}"
src_compile() {
local myconf="$(use_with sdl)"
if use berkdb; then
- if has_version "=sys-libs/db-4.3*"; then
- myconf="${myconf} --with-berkeley-db --with-db-lib=db_cxx-4.3
- --with-extra-includes=/usr/include/db4.3"
- elif has_version "=sys-libs/db-4.2*"; then
- myconf="${myconf} --with-berkeley-db --with-db-lib=db_cxx-4.2
- --with-extra-includes=/usr/include/db4.2"
- fi
+ myconf="${myconf} --with-berkeley-db --with-db-lib=$(db_libname)
+ --with-extra-includes=${ROOT}$(db_includedir)"
else
myconf="${myconf} --without-berkeley-db"
fi