summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.2.7.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index cd26fae278ad..106bd7a06bbb 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.192 2012/06/23 06:08:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.193 2012/07/27 06:14:51 graaff Exp $
+
+*actionmailer-3.2.7 (27 Jul 2012)
+
+ 27 Jul 2012; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.2.7.ebuild:
+ Version bump for Rails 3.2.7, bug 428254.
23 Jun 2012; Hans de Graaff <graaff@gentoo.org> -actionmailer-3.0.12.ebuild,
-actionmailer-3.1.4-r1.ebuild, -actionmailer-3.2.3.ebuild,
diff --git a/dev-ruby/actionmailer/actionmailer-3.2.7.ebuild b/dev-ruby/actionmailer/actionmailer-3.2.7.ebuild
new file mode 100644
index 000000000000..3eec358d9d90
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.2.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.2.7.ebuild,v 1.1 2012/07/27 06:14:51 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.4.4"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.12.1
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}