summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/pydf/pydf-0.9.6.ebuild27
-rw-r--r--app-cdr/cdrtools/cdrtools-1.11.33-r1.ebuild20
-rw-r--r--app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild22
-rw-r--r--app-crypt/mcrypt/mcrypt-2.6.2.ebuild17
-rw-r--r--app-crypt/mcrypt/mcrypt-2.6.4.ebuild13
-rw-r--r--app-crypt/pgpdump/pgpdump-0.19.ebuild8
-rw-r--r--app-dicts/aspell-pt/aspell-pt-0.50.2.ebuild4
-rw-r--r--app-dicts/ispell-cs/ispell-cs-20020628.ebuild4
8 files changed, 46 insertions, 69 deletions
diff --git a/app-admin/pydf/pydf-0.9.6.ebuild b/app-admin/pydf/pydf-0.9.6.ebuild
index 1345c9110d90..97aa17ccfabe 100644
--- a/app-admin/pydf/pydf-0.9.6.ebuild
+++ b/app-admin/pydf/pydf-0.9.6.ebuild
@@ -1,36 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pydf/pydf-0.9.6.ebuild,v 1.2 2003/06/29 15:24:07 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pydf/pydf-0.9.6.ebuild,v 1.3 2003/08/05 18:07:16 vapier Exp $
-S="${WORKDIR}/${P}"
-
-DESCRIPTION="Enhanced df with colors."
-
-SRC_URI="http://melkor.dnp.fmph.uniba.sk/~garabik/pydf/pydf_${PV}.tar.gz"
+DESCRIPTION="Enhanced df with colors"
HOMEPAGE="http://melkor.dnp.fmph.uniba.sk/~garabik/pydf"
+SRC_URI="http://melkor.dnp.fmph.uniba.sk/~garabik/pydf/pydf_${PV}.tar.gz"
+
LICENSE="as-is"
-DEPEND="dev-lang/python"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
-IUSE=""
+RDEPEND="dev-lang/python"
-src_compile() {
- echo "Nothing to compile for ${P}."
-}
-
-src_install () {
+src_compile() { return 0; }
+src_install() {
dobin pydf
-
dodoc COPYING INSTALL README
-
doman pydf.1
-
insinto /etc
doins pydfrc
}
pkg_postinst() {
- ewarn "Please edit /etc/pydfrc to suit your needs."
+ ewarn "Please edit /etc/pydfrc to suit your needs"
}
diff --git a/app-cdr/cdrtools/cdrtools-1.11.33-r1.ebuild b/app-cdr/cdrtools/cdrtools-1.11.33-r1.ebuild
index 7e32c62424ba..6efd04e5535a 100644
--- a/app-cdr/cdrtools/cdrtools-1.11.33-r1.ebuild
+++ b/app-cdr/cdrtools/cdrtools-1.11.33-r1.ebuild
@@ -1,22 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-1.11.33-r1.ebuild,v 1.1 2003/05/17 12:26:57 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-1.11.33-r1.ebuild,v 1.2 2003/08/05 18:08:15 vapier Exp $
inherit eutils
-DESCRIPTION="A set of tools for CDR drives, including cdrecord."
+MY_P=${PN}-${PV%.*}a${PV##*.}
+S=${WORKDIR}/${PN}-1.11
+
+DESCRIPTION="A set of tools for CDR drives, including cdrecord"
HOMEPAGE="http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/cdrecord.html"
-LICENSE="GPL-2"
-DEPEND="virtual/glibc"
-RDEPEND="${DEPEND}"
-PROVIDE="virtual/cdrtools"
+SRC_URI="ftp://ftp.fokus.gmd.de:21/pub/unix/cdrecord/alpha/${MY_P}.tar.gz"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc"
-MY_P=${PN}-${PV%.*}a${PV##*.}
-S=${WORKDIR}/${PN}-1.11
-SRC_URI="ftp://ftp.fokus.gmd.de:21/pub/unix/cdrecord/alpha/${MY_P}.tar.gz"
+DEPEND="virtual/glibc"
+PROVIDE="virtual/cdrtools"
src_unpack() {
unpack ${A}
diff --git a/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild b/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
index b0616b39631e..69c938d57046 100644
--- a/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
+++ b/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild
@@ -1,31 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild,v 1.2 2003/06/29 22:18:39 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpg-ringmgr/gpg-ringmgr-1.12.ebuild,v 1.3 2003/08/05 18:10:37 vapier Exp $
DESCRIPTION="GPG Keyring Manager to handle large GPG keyrings more easily"
-
HOMEPAGE="http://www.ualberta.ca/~rbpark/gpg-ringmgr.html"
-
SRC_URI="http://www.ualberta.ca/~rbpark/projects/${PN}"
LICENSE="GPL-2"
-
SLOT="0"
-
-#This should work everywhere
KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa"
DEPEND="dev-lang/perl
- >=app-crypt/gnupg-1.2.1"
-
-RDEPEND="${DEPEND}"
-
-IUSE=""
-
-S=${WORKDIR}/${P}
+ >=app-crypt/gnupg-1.2.1"
src_unpack() {
- cd ${WORKDIR} && mkdir ${P}
+ mkdir ${P}
cp ${DISTDIR}/${PN} ${S}
}
@@ -35,11 +24,8 @@ src_compile() {
}
src_install() {
- # base install
dobin ${PN}
- # now we all all the docs
doman ${PN}.1
dohtml ${PN}.html
- # prepalldocs rocks! I saw it in net-fs/samba/samba-2.2.8
prepalldocs
}
diff --git a/app-crypt/mcrypt/mcrypt-2.6.2.ebuild b/app-crypt/mcrypt/mcrypt-2.6.2.ebuild
index fdcc58bc9529..d1cc34ceac52 100644
--- a/app-crypt/mcrypt/mcrypt-2.6.2.ebuild
+++ b/app-crypt/mcrypt/mcrypt-2.6.2.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/mcrypt-2.6.2.ebuild,v 1.6 2003/06/29 22:18:39 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/mcrypt-2.6.2.ebuild,v 1.7 2003/08/05 18:09:37 vapier Exp $
-DESCRIPTION="mcrypt is intended to be a replacement of the old unix crypt(1)"
-SRC_URI="ftp://mcrypt.hellug.gr/pub/crypto/mcrypt/${P}.tar.gz"
+DESCRIPTION="replacement of the old unix crypt(1)"
HOMEPAGE="http://mcrypt.hellug.gr/"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/crypto/mcrypt/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc ~sparc "
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc"
+IUSE="nls"
DEPEND=">=dev-libs/libmcrypt-2.5.1
>=app-crypt/mhash-0.8.15"
@@ -16,11 +17,11 @@ DEPEND=">=dev-libs/libmcrypt-2.5.1
src_compile() {
local myconf
use nls || myconf="--disable-nls"
- econf ${myconf}
+ econf ${myconf} || die
emake || die
}
src_install() {
- einstall
+ einstall || die
dodoc README NEWS AUTHORS COPYING THANKS TODO
}
diff --git a/app-crypt/mcrypt/mcrypt-2.6.4.ebuild b/app-crypt/mcrypt/mcrypt-2.6.4.ebuild
index 1bb4d5509d61..de964b8bf79b 100644
--- a/app-crypt/mcrypt/mcrypt-2.6.4.ebuild
+++ b/app-crypt/mcrypt/mcrypt-2.6.4.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/mcrypt-2.6.4.ebuild,v 1.1 2003/04/24 17:40:07 robbat2 Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/mcrypt-2.6.4.ebuild,v 1.2 2003/08/05 18:09:37 vapier Exp $
-DESCRIPTION="mcrypt is intended to be a replacement of the old unix crypt(1)"
-SRC_URI="ftp://mcrypt.hellug.gr/pub/crypto/mcrypt/${P}.tar.gz"
+DESCRIPTION="replacement of the old unix crypt(1)"
HOMEPAGE="http://mcrypt.hellug.gr/"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/crypto/mcrypt/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc "
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="nls"
DEPEND=">=dev-libs/libmcrypt-2.5.7
>=app-crypt/mhash-0.8.15"
diff --git a/app-crypt/pgpdump/pgpdump-0.19.ebuild b/app-crypt/pgpdump/pgpdump-0.19.ebuild
index f946beebdd5d..d2426bec3779 100644
--- a/app-crypt/pgpdump/pgpdump-0.19.ebuild
+++ b/app-crypt/pgpdump/pgpdump-0.19.ebuild
@@ -1,18 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pgpdump/pgpdump-0.19.ebuild,v 1.1 2003/07/19 13:42:35 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pgpdump/pgpdump-0.19.ebuild,v 1.2 2003/08/05 18:10:56 vapier Exp $
DESCRIPTION="A PGP packet visualizer"
HOMEPAGE="http://pgp.iijlab.net/pgpdump.html"
SRC_URI="ftp://pgp.iijlab.net/pub/pgp/tools/${P}.tar.gz"
LICENSE="as-is"
-KEYWORDS="~x86"
SLOT="0"
-IUSE=""
+KEYWORDS="~x86"
DEPEND="virtual/glibc"
-S=${WORKDIR}/${P}
src_compile() {
econf || die
diff --git a/app-dicts/aspell-pt/aspell-pt-0.50.2.ebuild b/app-dicts/aspell-pt/aspell-pt-0.50.2.ebuild
index b927f6613199..be1b43219850 100644
--- a/app-dicts/aspell-pt/aspell-pt-0.50.2.ebuild
+++ b/app-dicts/aspell-pt/aspell-pt-0.50.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/aspell-pt/aspell-pt-0.50.2.ebuild,v 1.2 2003/02/13 06:25:26 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/aspell-pt/aspell-pt-0.50.2.ebuild,v 1.3 2003/08/05 18:11:17 vapier Exp $
ASPELL_LANG="Portuguese"
diff --git a/app-dicts/ispell-cs/ispell-cs-20020628.ebuild b/app-dicts/ispell-cs/ispell-cs-20020628.ebuild
index 410e15ee5b82..8a88560dbba5 100644
--- a/app-dicts/ispell-cs/ispell-cs-20020628.ebuild
+++ b/app-dicts/ispell-cs/ispell-cs-20020628.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/ispell-cs/ispell-cs-20020628.ebuild,v 1.6 2003/03/11 21:11:44 seemant Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/ispell-cs/ispell-cs-20020628.ebuild,v 1.7 2003/08/05 18:11:29 vapier Exp $
MY_P=${PN/cs/czech}
S=${WORKDIR}/${MY_P}