summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-power/acpid/ChangeLog6
-rw-r--r--sys-power/acpid/acpid-1.0.4-r1.ebuild16
-rw-r--r--sys-power/acpid/files/acpid-1.0.4-gcc4.patch20
3 files changed, 38 insertions, 4 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index 97b855f4637d..fb395d6d21f1 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/acpid
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.3 2005/04/24 16:21:45 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.4 2005/04/26 10:32:12 azarah Exp $
+
+ 26 Apr 2005; Martin Schlemmer <azarah@gentoo.org>
+ +files/acpid-1.0.4-gcc4.patch, acpid-1.0.4-r1.ebuild:
+ Fix building with gcc4. Use proper compiler.
*acpid-1.0.4-r1 (24 Apr 2005)
diff --git a/sys-power/acpid/acpid-1.0.4-r1.ebuild b/sys-power/acpid/acpid-1.0.4-r1.ebuild
index b6c213063377..05514b0c0bfc 100644
--- a/sys-power/acpid/acpid-1.0.4-r1.ebuild
+++ b/sys-power/acpid/acpid-1.0.4-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-1.0.4-r1.ebuild,v 1.1 2005/04/24 16:21:45 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-1.0.4-r1.ebuild,v 1.2 2005/04/26 10:32:12 azarah Exp $
+
+inherit eutils toolchain-funcs
DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
HOMEPAGE="http://acpid.sourceforge.net"
@@ -15,18 +17,26 @@ DEPEND="virtual/libc
virtual/linux-sources"
RDEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix building with gcc4
+ epatch ${FILESDIR}/${P}-gcc4.patch
+}
+
src_compile() {
# DO NOT COMPILE WITH OPTIMISATIONS (bug #22365)
# That is a note to the devs. IF you are a user, go ahead and optimise
# if you want, but we won't support bugs associated with that.
- make INSTPREFIX=${D} || die
+ make CC="$(tc-getCC)" INSTPREFIX="${D}" || die
}
src_install() {
# needed since the Makefile doesn't do 'mkdir -p $(BINDIR)'
dodir /usr/bin
- make INSTPREFIX=${D} install || die
+ make INSTPREFIX="${D}" install || die
exeinto /etc/acpi
newexe ${FILESDIR}/${P}-default.sh default.sh || die
diff --git a/sys-power/acpid/files/acpid-1.0.4-gcc4.patch b/sys-power/acpid/files/acpid-1.0.4-gcc4.patch
new file mode 100644
index 000000000000..b56901d21b11
--- /dev/null
+++ b/sys-power/acpid/files/acpid-1.0.4-gcc4.patch
@@ -0,0 +1,20 @@
+--- acpid-1.0.4/ud_socket.c 2005-04-26 10:26:29.000000000 +0000
++++ acpid-1.0.4.az/ud_socket.c 2005-04-26 10:27:09.000000000 +0000
+@@ -60,7 +60,7 @@
+ struct sockaddr_un cliaddr;
+ int len = sizeof(struct sockaddr_un);
+
+- newsock = accept(listenfd, (struct sockaddr *)&cliaddr, &len);
++ newsock = accept(listenfd, (struct sockaddr *)&cliaddr, (socklen_t *)&len);
+ if (newsock < 0) {
+ if (errno == EINTR) {
+ continue; /* signal */
+@@ -71,7 +71,7 @@
+
+ if (cred) {
+ len = sizeof(struct ucred);
+- getsockopt(newsock, SOL_SOCKET, SO_PEERCRED,cred,&len);
++ getsockopt(newsock, SOL_SOCKET, SO_PEERCRED,cred,(socklen_t *)&len);
+ }
+
+ return newsock;