summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/aggregate/ChangeLog9
-rw-r--r--net-misc/aggregate/aggregate-1.6.ebuild16
-rw-r--r--net-misc/aggregate/files/aggregate-1.6-build-fixup.patch14
3 files changed, 32 insertions, 7 deletions
diff --git a/net-misc/aggregate/ChangeLog b/net-misc/aggregate/ChangeLog
index 2a1b8a868401..6bca1ba848c4 100644
--- a/net-misc/aggregate/ChangeLog
+++ b/net-misc/aggregate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/aggregate
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aggregate/ChangeLog,v 1.13 2007/04/22 08:48:42 kloeri Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aggregate/ChangeLog,v 1.14 2008/10/10 08:35:14 robbat2 Exp $
+
+ 10 Oct 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/aggregate-1.6-build-fixup.patch, aggregate-1.6.ebuild:
+ Fix pre-stripping for bug #240930, also now builds with the user CFLAGS
+ and LDFLAGS.
22 Apr 2007; Bryan Østergaard <kloeri@gentoo.org> aggregate-1.6.ebuild:
Stable on Mips, bug 173860.
diff --git a/net-misc/aggregate/aggregate-1.6.ebuild b/net-misc/aggregate/aggregate-1.6.ebuild
index f6cd0b4ee362..830b3cacb2ff 100644
--- a/net-misc/aggregate/aggregate-1.6.ebuild
+++ b/net-misc/aggregate/aggregate-1.6.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/aggregate/aggregate-1.6.ebuild,v 1.13 2007/04/22 08:48:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aggregate/aggregate-1.6.ebuild,v 1.14 2008/10/10 08:35:14 robbat2 Exp $
+
+inherit eutils
DESCRIPTION="aggregate takes a list of prefixes in conventional format on stdin, and performs two optimisations to reduce the length of the prefix list."
-BASE_URI="http://dist.automagic.org/"
-HOMEPAGE="${BASE_URI}"
-SRC_URI="${BASE_URI}/${P}.tar.gz"
+HOMEPAGE="http://dist.automagic.org/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 mips ppc sparc x86"
@@ -13,6 +14,11 @@ IUSE=""
DEPEND=""
RDEPEND="dev-lang/perl"
+src_unpack() {
+ unpack "${A}"
+ epatch "${FILESDIR}"/${P}-build-fixup.patch
+}
+
src_install() {
dobin aggregate aggregate-ios
doman aggregate.1 aggregate-ios.1
diff --git a/net-misc/aggregate/files/aggregate-1.6-build-fixup.patch b/net-misc/aggregate/files/aggregate-1.6-build-fixup.patch
new file mode 100644
index 000000000000..51c9f9f96128
--- /dev/null
+++ b/net-misc/aggregate/files/aggregate-1.6-build-fixup.patch
@@ -0,0 +1,14 @@
+diff -Nuar aggregate-1.6.orig/Makefile.in aggregate-1.6/Makefile.in
+--- aggregate-1.6.orig/Makefile.in 2002-03-06 08:59:37.000000000 -0800
++++ aggregate-1.6/Makefile.in 2008-10-10 01:31:42.613937925 -0700
+@@ -25,8 +25,8 @@
+ INSTALL = @INSTALL@
+ DEFS = @DEFS@
+ LIBS = @LIBS@
+-CFLAGS = -O
+-LDFLAGS = -s
++CFLAGS +=
++LDFLAGS +=
+ prefix = @prefix@
+
+ SHELL = /bin/sh