summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/mekanix/mekanix-065.ebuild6
-rw-r--r--games-emulation/pcsx2/files/0.5-time-renames.patch16
-rw-r--r--games-emulation/pcsx2/files/digest-pcsx2-0.51
-rw-r--r--games-emulation/pcsx2/pcsx2-0.5.ebuild52
-rw-r--r--games-emulation/pcsx2/pcsx2-0.6.ebuild3
-rw-r--r--games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild8
-rw-r--r--games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild8
-rw-r--r--games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild6
-rw-r--r--games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.5.ebuild8
-rw-r--r--games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.21.ebuild8
-rw-r--r--games-emulation/psemu-gpupetexgl2/files/digest-psemu-gpupetexgl2-2.0.5-r13
-rw-r--r--games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r1.ebuild33
-rw-r--r--games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild6
-rw-r--r--games-fps/aaquake2/aaquake2-0.1.ebuild6
-rw-r--r--games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild8
-rw-r--r--games-fps/cube/cube-20031223.ebuild90
-rw-r--r--games-fps/cube/cube-20040522.ebuild5
-rw-r--r--games-fps/cube/files/20031223-gentoo-paths.patch43
-rw-r--r--games-fps/cube/files/cube-20021020-add-custom-paths.patch43
-rw-r--r--games-fps/cube/files/digest-cube-200312231
-rw-r--r--games-fps/freedoom/freedoom-0.2.ebuild7
21 files changed, 50 insertions, 311 deletions
diff --git a/games-emulation/mekanix/mekanix-065.ebuild b/games-emulation/mekanix/mekanix-065.ebuild
index 216afe54a79c..c3c93e88e9a9 100644
--- a/games-emulation/mekanix/mekanix-065.ebuild
+++ b/games-emulation/mekanix/mekanix-065.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mekanix/mekanix-065.ebuild,v 1.4 2004/06/24 22:30:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mekanix/mekanix-065.ebuild,v 1.5 2004/11/03 00:16:06 vapier Exp $
inherit games
@@ -13,7 +13,9 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/x11"
+RDEPEND="virtual/x11"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S="${WORKDIR}"
diff --git a/games-emulation/pcsx2/files/0.5-time-renames.patch b/games-emulation/pcsx2/files/0.5-time-renames.patch
deleted file mode 100644
index 96b924beffd7..000000000000
--- a/games-emulation/pcsx2/files/0.5-time-renames.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- Pcsx2Src/RPC/80000001fileio.h.orig 2003-08-14 11:39:42.319499152 -0400
-+++ Pcsx2Src/RPC/80000001fileio.h 2003-08-14 11:40:09.145420992 -0400
-@@ -73,10 +73,10 @@
- 4 Symbolic link */
- unsigned int st_attr;// Flag compatible with memory card mode
- unsigned int st_size;
-- unsigned char st_ctime[8];// Creation time
-- unsigned char st_atime[8];/* This field is updated at the same time as last access time
-+ unsigned char sr_ctime[8];// Creation time
-+ unsigned char sr_atime[8];/* This field is updated at the same time as last access time
- and last update time. */
-- unsigned char st_mtime[8];/* Last update time
-+ unsigned char sr_mtime[8];/* Last update time
- byte0 Reserved
- byte1 Seconds
- byte2 Minutes
diff --git a/games-emulation/pcsx2/files/digest-pcsx2-0.5 b/games-emulation/pcsx2/files/digest-pcsx2-0.5
deleted file mode 100644
index b31be86cf526..000000000000
--- a/games-emulation/pcsx2/files/digest-pcsx2-0.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5f149055af85f2e728f808e75b497250 Pcsx2Src-0.5.tgz 936311
diff --git a/games-emulation/pcsx2/pcsx2-0.5.ebuild b/games-emulation/pcsx2/pcsx2-0.5.ebuild
deleted file mode 100644
index 2453e718d43e..000000000000
--- a/games-emulation/pcsx2/pcsx2-0.5.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.5.ebuild,v 1.6 2004/06/24 22:32:22 agriffis Exp $
-
-inherit eutils games
-
-DESCRIPTION="Playstation2 emulator"
-HOMEPAGE="http://www.pcsx2.net/"
-SRC_URI="http://www.pcsx2.net/download/${PV:0:3}release/Pcsx2Src-${PV}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-
-RDEPEND="virtual/x11
- =x11-libs/gtk+-1*
- || (
- >=games-emulation/ps2emu-cddvdlinuz-0.3-r1
- >=games-emulation/ps2emu-cdvdiso-0.3
- )
- >=games-emulation/ps2emu-gssoft-0.61
- >=games-emulation/ps2emu-padxwin-0.5
- >=games-emulation/ps2emu-spu2null-0.21
- >=games-emulation/ps2emu-dev9null-0.1"
-DEPEND="${RDEPEND}
- dev-lang/nasm"
-
-S=${WORKDIR}/Pcsx2Src-${PV}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-time-renames.patch
-}
-
-src_compile() {
- cd ${S}/ix86-32/GoldRec
- emake OPTIMIZE="${CFLAGS}" || die "goldrec building failed"
- cd ${S}/Linux
- emake OPTIMIZE="${CFLAGS}" || die "linux building failed"
-}
-
-src_install() {
- newgamesbin Linux/pcsx2 pcsx2.bin
- dogamesbin ${FILESDIR}/pcsx2
- dodir ${GAMES_LIBDIR}/ps2emu/Langs
- rm -rf Intl/Langs/cvs
- cp -r Intl/Langs/* ${D}/${GAMES_LIBDIR}/ps2emu/Langs/
- dodoc Docs/*.txt
- prepgamesdirs
-}
diff --git a/games-emulation/pcsx2/pcsx2-0.6.ebuild b/games-emulation/pcsx2/pcsx2-0.6.ebuild
index 0f4280073a8b..e1e5695b0154 100644
--- a/games-emulation/pcsx2/pcsx2-0.6.ebuild
+++ b/games-emulation/pcsx2/pcsx2-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.6.ebuild,v 1.2 2004/06/24 22:32:22 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.6.ebuild,v 1.3 2004/11/03 00:16:33 vapier Exp $
inherit eutils games
@@ -24,6 +24,7 @@ RDEPEND="virtual/x11
>=games-emulation/ps2emu-spu2null-0.21
>=games-emulation/ps2emu-dev9null-0.1"
DEPEND="${RDEPEND}
+ app-arch/unzip
dev-lang/nasm"
S="${WORKDIR}/pcsx2_${PV}src"
diff --git a/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild b/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild
index c53592b802a5..131e056d8c04 100644
--- a/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild
+++ b/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild,v 1.5 2004/06/24 22:32:33 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild,v 1.6 2004/11/03 00:16:55 vapier Exp $
inherit games
@@ -10,10 +10,12 @@ SRC_URI="http://www.pcsx2.net/download/0.5release/CDVDlinuz${PV}.zip"
LICENSE="freedist"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="~ppc x86"
IUSE=""
-DEPEND="=x11-libs/gtk+-1*"
+RDEPEND="=x11-libs/gtk+-1*"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S="${WORKDIR}/CDVDlinuz"
diff --git a/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild b/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild
index a92b992eb3b5..5ffad7c64686 100644
--- a/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild
+++ b/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild,v 1.5 2004/06/24 22:32:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.3.ebuild,v 1.6 2004/11/03 00:17:13 vapier Exp $
inherit games
@@ -10,10 +10,12 @@ SRC_URI="http://www.pcsx2.net/download/0.5release/CDVDiso${PV}.zip"
LICENSE="freedist"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="ppc x86"
IUSE=""
-DEPEND="=x11-libs/gtk+-1*"
+RDEPEND="=x11-libs/gtk+-1*"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/CDVDiso
diff --git a/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild b/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild
index 3e0a4acb7eb2..c22d92047421 100644
--- a/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild
+++ b/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild,v 1.4 2004/06/24 22:32:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-dev9null/ps2emu-dev9null-0.1.ebuild,v 1.5 2004/11/03 00:17:33 vapier Exp $
inherit games
@@ -13,7 +13,9 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="=x11-libs/gtk+-1*"
+RDEPEND="=x11-libs/gtk+-1*"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/dev9null
diff --git a/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.5.ebuild b/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.5.ebuild
index c4d6be1023aa..567e31f4c7d2 100644
--- a/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.5.ebuild
+++ b/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.5.ebuild,v 1.5 2004/06/24 22:33:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-padxwin/ps2emu-padxwin-0.5.ebuild,v 1.6 2004/11/03 00:17:54 vapier Exp $
inherit games
@@ -10,10 +10,12 @@ SRC_URI="http://www.pcsx2.net/download/0.5release/PADwin${PV}.zip"
LICENSE="freedist"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="ppc x86"
IUSE=""
-DEPEND="=x11-libs/gtk+-1*"
+RDEPEND="=x11-libs/gtk+-1*"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/PADwin
diff --git a/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.21.ebuild b/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.21.ebuild
index d4854255f346..16d3409b4530 100644
--- a/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.21.ebuild
+++ b/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.21.ebuild,v 1.5 2004/06/24 22:33:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.21.ebuild,v 1.6 2004/11/03 00:18:15 vapier Exp $
inherit games
@@ -10,10 +10,12 @@ SRC_URI="http://www.pcsx2.net/download/0.5release/SPU2null${PV}.zip"
LICENSE="freedist"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="ppc x86"
IUSE=""
-DEPEND="=x11-libs/gtk+-1*"
+RDEPEND="=x11-libs/gtk+-1*"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/SPU2null
diff --git a/games-emulation/psemu-gpupetexgl2/files/digest-psemu-gpupetexgl2-2.0.5-r1 b/games-emulation/psemu-gpupetexgl2/files/digest-psemu-gpupetexgl2-2.0.5-r1
deleted file mode 100644
index cf2d26ab9059..000000000000
--- a/games-emulation/psemu-gpupetexgl2/files/digest-psemu-gpupetexgl2-2.0.5-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d9e524b871868ba0eaab863fe0efff27 gpupetexgl205.tar.gz 180777
-MD5 2bb81f8164039c97fb1dd92628c6cf8e pete_ogl2_shader_simpleblur.zip 1032
-MD5 2628e8e11fe638dc599fd5564169d756 pete_ogl2_shader_scale2x.zip 3072
diff --git a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r1.ebuild b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r1.ebuild
deleted file mode 100644
index d76a68f76f70..000000000000
--- a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r1.ebuild,v 1.4 2004/07/14 14:37:22 agriffis Exp $
-
-inherit games
-
-DESCRIPTION="PSEmu MesaGL GPU"
-HOMEPAGE="http://home.t-online.de/home/PeteBernert/"
-# we want all the shaders as well!
-SRC_URI="http://home.t-online.de/home/PeteBernert/gpupetexgl${PV//.}.tar.gz http://home.t-online.de/home/PeteBernert/pete_ogl2_shader_simpleblur.zip http://home.t-online.de/home/PeteBernert/pete_ogl2_shader_scale2x.zip"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-
-DEPEND="virtual/opengl"
-
-S=${WORKDIR}
-
-src_install() {
- exeinto ${GAMES_LIBDIR}/psemu/plugins
- doexe lib*
- exeinto ${GAMES_LIBDIR}/psemu/cfg
- doexe cfgPeteXGL2
- insinto ${GAMES_LIBDIR}/psemu/cfg
- doins gpuPeteXGL2.cfg
- # now do our shader files!
- insinto ${GAMES_LIBDIR}/psemu/shaders
- doins *.fp *.vp *.slf *.slv
- dodoc *.txt
- prepgamesdirs
-}
diff --git a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild
index 5addcfed088e..df0bbb605088 100644
--- a/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild
+++ b/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild,v 1.4 2004/06/24 22:34:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-gpupetexgl2/psemu-gpupetexgl2-2.0.5-r2.ebuild,v 1.5 2004/11/03 00:18:40 vapier Exp $
inherit games
@@ -15,7 +15,9 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/opengl"
+RDEPEND="virtual/opengl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S="${WORKDIR}"
diff --git a/games-fps/aaquake2/aaquake2-0.1.ebuild b/games-fps/aaquake2/aaquake2-0.1.ebuild
index ea784a0fb99a..a4299cd84da5 100644
--- a/games-fps/aaquake2/aaquake2-0.1.ebuild
+++ b/games-fps/aaquake2/aaquake2-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.4 2004/06/24 22:39:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/aaquake2/aaquake2-0.1.ebuild,v 1.5 2004/11/03 00:18:59 vapier Exp $
inherit games eutils
@@ -16,7 +16,9 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="media-libs/aalib"
+RDEPEND="media-libs/aalib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S="${WORKDIR}/quake2-3.21/linux"
diff --git a/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
index f3a9377f8d9d..1b6f534f4244 100644
--- a/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
+++ b/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild,v 1.7 2004/08/28 09:43:03 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/anaglyph-stereo-quake/anaglyph-stereo-quake-130100-r1.ebuild,v 1.8 2004/11/03 00:19:16 vapier Exp $
inherit games gcc eutils
@@ -11,12 +11,14 @@ SRC_URI="http://home.iprimus.com.au/crbean/zip/3dGLQuake_SRC_${PV}.zip
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64"
+KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="virtual/x11
+RDEPEND="virtual/x11
virtual/opengl
media-libs/libsdl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S="${WORKDIR}/WinQuake"
diff --git a/games-fps/cube/cube-20031223.ebuild b/games-fps/cube/cube-20031223.ebuild
deleted file mode 100644
index bbc3068c3fda..000000000000
--- a/games-fps/cube/cube-20031223.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20031223.ebuild,v 1.8 2004/08/15 09:18:26 vapier Exp $
-
-inherit eutils games
-
-MY_P="cube_2003_12_23"
-
-DESCRIPTION="open source multiplayer and singleplayer first person shooter game"
-HOMEPAGE="http://www.cubeengine.com/"
-SRC_URI="mirror://sourceforge/cube/${MY_P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="x86 ppc hppa"
-IUSE=""
-
-RDEPEND="virtual/opengl
- virtual/glu
- media-libs/libsdl
- media-libs/sdl-mixer
- media-libs/sdl-image
- sys-libs/zlib
- media-libs/libpng"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-S="${WORKDIR}/cube"
-CUBE_DATADIR="${GAMES_DATADIR}/${PN}/"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}/source
- unzip -qn ${MY_P}_src.zip || die
-
- cd ${MY_P}_src/src
- epatch ${FILESDIR}/${PV}-gentoo-paths.patch
- echo "#define GAMES_DATADIR \"${CUBE_DATADIR}\"" >> tools.h
- echo "#define GAMES_DATADIR_LEN ${#CUBE_DATADIR}" >> tools.h
- sed -i \
- -e "s:packages/:${CUBE_DATADIR}packages/:" \
- renderextras.cpp rendermd2.cpp sound.cpp worldio.cpp \
- || die "fixing data path failed"
- # enable parallel make
- sed -i \
- -e 's/make -C/$(MAKE) -C/' Makefile \
- || die "sed Makefile failed"
- edos2unix *.cpp
-}
-
-src_compile() {
- cd source/${MY_P}_src/src
- emake CXXOPTFLAGS="${CXXFLAGS}" || die "emake failed"
-}
-
-src_install() {
- dogamesbin source/${MY_P}_src/src/cube_{client,server} \
- || die "dogamesbin failed"
- exeinto "${GAMES_LIBDIR}/${PN}"
- if [ "${ARCH}" == "x86" ] ; then
- newexe bin_unix/linux_client cube_client
- newexe bin_unix/linux_server cube_server
- elif [ "${ARCH}" == "ppc" ] ; then
- newexe bin_unix/ppc_linux_client cube_client
- newexe bin_unix/ppc_linux_server cube_server
- fi
- dogamesbin ${FILESDIR}/cube_{client,server}-bin \
- || die "dogamesbin failed (bin)"
- sed -i \
- -e "s:GENTOO_DATADIR:${CUBE_DATADIR}:" \
- -e "s:GENTOO_LIBDIR:${GAMES_LIBDIR}/${PN}:" \
- ${D}/${GAMES_BINDIR}/cube_{client,server}-bin
-
- dodir ${CUBE_DATADIR}
- cp -r *.cfg data packages ${D}/${CUBE_DATADIR} \
- || die "cp failed"
-
- dodoc source/${MY_P}_src/src/CUBE_TODO.txt
- dohtml -r docs/
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- einfo "You now have 2 clients and 2 servers:"
- einfo "cube_client-bin prebuilt version (needed to play on public multiplayer servers)"
- einfo "cube_client custom client built from source"
- einfo "Parallel versions of the server have been installed"
-}
diff --git a/games-fps/cube/cube-20040522.ebuild b/games-fps/cube/cube-20040522.ebuild
index 581e6989d6ee..23ac4f22776c 100644
--- a/games-fps/cube/cube-20040522.ebuild
+++ b/games-fps/cube/cube-20040522.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20040522.ebuild,v 1.4 2004/08/17 06:20:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/cube/cube-20040522.ebuild,v 1.5 2004/11/03 00:20:41 vapier Exp $
inherit eutils games
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/cube/${MY_P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="x86 ppc hppa"
+KEYWORDS="hppa ppc x86"
IUSE=""
RDEPEND="virtual/opengl
@@ -23,6 +23,7 @@ RDEPEND="virtual/opengl
sys-libs/zlib
media-libs/libpng"
DEPEND="${RDEPEND}
+ app-arch/unzip
>=sys-apps/sed-4"
S="${WORKDIR}/cube"
diff --git a/games-fps/cube/files/20031223-gentoo-paths.patch b/games-fps/cube/files/20031223-gentoo-paths.patch
deleted file mode 100644
index 594a0714e5fb..000000000000
--- a/games-fps/cube/files/20031223-gentoo-paths.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- tools.cpp.orig 2002-12-17 09:35:55.000000000 -0500
-+++ tools.cpp 2002-12-17 09:39:28.000000000 -0500
-@@ -100,8 +100,19 @@
-
- ///////////////////////// misc tools ///////////////////////
-
-+char *addfullpath(char *s) {
-+ static char ret[256]; // choose a reasonable max buffer size
-+ if (s[0] == '/') { return s; }
-+ int slen = strlen(s);
-+ memset(ret, 0x00, 256);
-+ memcpy(ret, GAMES_DATADIR, GAMES_DATADIR_LEN);
-+ memcpy(ret+GAMES_DATADIR_LEN, s, slen);
-+ return ret;
-+}
-+
- char *path(char *s)
- {
-+ s = addfullpath(s);
- for(char *t = s; t = strpbrk(t, "/\\"); *t++ = PATHDIV);
- return s;
- };
---- rendergl.cpp.orig 2002-12-17 09:48:00.000000000 -0500
-+++ rendergl.cpp 2002-12-17 09:50:19.000000000 -0500
-@@ -59,6 +59,7 @@
-
- bool installtex(int tnum, char *texname, int &xs, int &ys, bool clamp)
- {
-+ texname = addfullpath(texname);
- SDL_Surface *s = IMG_Load(texname);
- if(!s) { conoutf("couldn't load texture %s", (int)texname); return false; };
- if(s->format->BitsPerPixel!=24) { conoutf("texture must be 24bpp: %s", (int)texname); return false; };
---- tools.h.orig 2002-12-17 09:51:06.000000000 -0500
-+++ tools.h 2002-12-17 09:50:59.000000000 -0500
-@@ -96,7 +96,7 @@
- #endif
-
-
--
-+extern char *addfullpath(char *s);
- extern char *path(char *s);
- extern char *loadfile(char *fn, int *size);
- extern void endianswap(void *, int, int);
diff --git a/games-fps/cube/files/cube-20021020-add-custom-paths.patch b/games-fps/cube/files/cube-20021020-add-custom-paths.patch
deleted file mode 100644
index 594a0714e5fb..000000000000
--- a/games-fps/cube/files/cube-20021020-add-custom-paths.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- tools.cpp.orig 2002-12-17 09:35:55.000000000 -0500
-+++ tools.cpp 2002-12-17 09:39:28.000000000 -0500
-@@ -100,8 +100,19 @@
-
- ///////////////////////// misc tools ///////////////////////
-
-+char *addfullpath(char *s) {
-+ static char ret[256]; // choose a reasonable max buffer size
-+ if (s[0] == '/') { return s; }
-+ int slen = strlen(s);
-+ memset(ret, 0x00, 256);
-+ memcpy(ret, GAMES_DATADIR, GAMES_DATADIR_LEN);
-+ memcpy(ret+GAMES_DATADIR_LEN, s, slen);
-+ return ret;
-+}
-+
- char *path(char *s)
- {
-+ s = addfullpath(s);
- for(char *t = s; t = strpbrk(t, "/\\"); *t++ = PATHDIV);
- return s;
- };
---- rendergl.cpp.orig 2002-12-17 09:48:00.000000000 -0500
-+++ rendergl.cpp 2002-12-17 09:50:19.000000000 -0500
-@@ -59,6 +59,7 @@
-
- bool installtex(int tnum, char *texname, int &xs, int &ys, bool clamp)
- {
-+ texname = addfullpath(texname);
- SDL_Surface *s = IMG_Load(texname);
- if(!s) { conoutf("couldn't load texture %s", (int)texname); return false; };
- if(s->format->BitsPerPixel!=24) { conoutf("texture must be 24bpp: %s", (int)texname); return false; };
---- tools.h.orig 2002-12-17 09:51:06.000000000 -0500
-+++ tools.h 2002-12-17 09:50:59.000000000 -0500
-@@ -96,7 +96,7 @@
- #endif
-
-
--
-+extern char *addfullpath(char *s);
- extern char *path(char *s);
- extern char *loadfile(char *fn, int *size);
- extern void endianswap(void *, int, int);
diff --git a/games-fps/cube/files/digest-cube-20031223 b/games-fps/cube/files/digest-cube-20031223
deleted file mode 100644
index fd37e49321a0..000000000000
--- a/games-fps/cube/files/digest-cube-20031223
+++ /dev/null
@@ -1 +0,0 @@
-MD5 22555b87ef16c403198a6f378c048c6f cube_2003_12_23.zip 18587017
diff --git a/games-fps/freedoom/freedoom-0.2.ebuild b/games-fps/freedoom/freedoom-0.2.ebuild
index ae6b1a8f9733..1619863e3c05 100644
--- a/games-fps/freedoom/freedoom-0.2.ebuild
+++ b/games-fps/freedoom/freedoom-0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/freedoom/freedoom-0.2.ebuild,v 1.2 2004/07/21 18:45:10 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/freedoom/freedoom-0.2.ebuild,v 1.3 2004/11/03 00:20:22 vapier Exp $
inherit games
@@ -17,10 +17,11 @@ SRC_URI="mirror://sourceforge/freedoom/doom1.zip
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="ppc x86"
IUSE=""
-DEPEND="!games-fps/doom-data"
+RDEPEND="!games-fps/doom-data"
+DEPEND="app-arch/unzip"
src_install() {
insinto ${GAMES_DATADIR}/doom-data