summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/e3/ChangeLog6
-rw-r--r--app-editors/e3/e3-2.7.0.ebuild27
-rw-r--r--app-editors/e3/files/digest-e3-2.7.03
-rw-r--r--app-editors/e3/files/emacs21
-rw-r--r--app-editors/e3/files/pico21
-rw-r--r--app-editors/e3/files/vi21
6 files changed, 5 insertions, 94 deletions
diff --git a/app-editors/e3/ChangeLog b/app-editors/e3/ChangeLog
index f70314872c00..fb3cee0c025d 100644
--- a/app-editors/e3/ChangeLog
+++ b/app-editors/e3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/e3
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/ChangeLog,v 1.28 2008/01/20 19:03:12 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/ChangeLog,v 1.29 2008/01/20 19:40:12 ulm Exp $
+
+ 20 Jan 2008; Ulrich Mueller <ulm@gentoo.org> -files/emacs, -files/pico,
+ -files/vi, -e3-2.7.0.ebuild:
+ Clean up.
20 Jan 2008; Christoph Mende <angelos@gentoo.org> e3-2.7.1.ebuild:
Stable on amd64 wrt bug #205896
diff --git a/app-editors/e3/e3-2.7.0.ebuild b/app-editors/e3/e3-2.7.0.ebuild
deleted file mode 100644
index 8cba87c520a5..000000000000
--- a/app-editors/e3/e3-2.7.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-2.7.0.ebuild,v 1.9 2007/10/10 06:08:55 opfer Exp $
-
-DESCRIPTION="Very tiny editor in ASM with emacs, pico, wordstar, and vi keybindings"
-HOMEPAGE="http://www.sax.de/~adlibit/"
-SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 x86"
-IUSE=""
-RESTRICT="strip"
-
-DEPEND="dev-lang/nasm"
-RDEPEND=""
-
-src_install() {
- use amd64 && newbin "${S}/bin/Linux_x86-64/e3-64" e3
- use x86 && newbin "${S}/bin/Linux/e3" e3
- dosym e3 /usr/bin/e3vi
- dosym e3 /usr/bin/e3em
- dosym e3 /usr/bin/e3ws
- dosym e3 /usr/bin/e3pi
- dosym e3 /usr/bin/e3ne
- newman e3.man e3.1
-}
diff --git a/app-editors/e3/files/digest-e3-2.7.0 b/app-editors/e3/files/digest-e3-2.7.0
deleted file mode 100644
index faeff2d3cb07..000000000000
--- a/app-editors/e3/files/digest-e3-2.7.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a76dd61c52a80a1f4d3938a4ce54c62e e3-2.7.0.tar.gz 239477
-RMD160 4faf15dff1b44ed15faad1946c56aed13f12373c e3-2.7.0.tar.gz 239477
-SHA256 ab45362282b3b3e987ef40a0c6b300aa7267fcc0bb1f9879d09bbb6445eec18d e3-2.7.0.tar.gz 239477
diff --git a/app-editors/e3/files/emacs b/app-editors/e3/files/emacs
deleted file mode 100644
index 511e19c490cf..000000000000
--- a/app-editors/e3/files/emacs
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-E3=/usr/bin/e3
-whichE3=${E3}em
-
-if [ -f ${E3} ]; then
- if [ -f ${whichE3} ]; then
- if [ $# -eq 0 ]; then
- ${whichE3}
- else
- for i in $@
- do
- ${whichE3} $i
- done
- fi
- else
- echo ${whichE3}: file does not exist
- fi
-else
- echo "${E3}: file does not exist"
-fi
diff --git a/app-editors/e3/files/pico b/app-editors/e3/files/pico
deleted file mode 100644
index 5bde480ca17c..000000000000
--- a/app-editors/e3/files/pico
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-E3=/usr/bin/e3
-whichE3=${E3}pi
-
-if [ -f ${E3} ]; then
- if [ -f ${whichE3} ]; then
- if [ $# -eq 0 ]; then
- ${whichE3}
- else
- for i in $@
- do
- ${whichE3} $i
- done
- fi
- else
- echo ${whichE3}: file does not exist
- fi
-else
- echo "${E3}: file does not exist"
-fi
diff --git a/app-editors/e3/files/vi b/app-editors/e3/files/vi
deleted file mode 100644
index eed53d954452..000000000000
--- a/app-editors/e3/files/vi
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-E3=/usr/bin/e3
-whichE3=${E3}vi
-
-if [ -f ${E3} ]; then
- if [ -f ${whichE3} ]; then
- if [ $# -eq 0 ]; then
- ${whichE3}
- else
- for i in $@
- do
- ${whichE3} $i
- done
- fi
- else
- echo ${whichE3}: file does not exist
- fi
-else
- echo "${E3}: file does not exist"
-fi