summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/treeviewx/ChangeLog11
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch75
-rw-r--r--sci-biology/treeviewx/treeviewx-0.5.1-r1.ebuild49
-rw-r--r--sci-biology/treeviewx/treeviewx-0.5.1.ebuild4
4 files changed, 135 insertions, 4 deletions
diff --git a/sci-biology/treeviewx/ChangeLog b/sci-biology/treeviewx/ChangeLog
index cf011aaccb25..52c917009e2c 100644
--- a/sci-biology/treeviewx/ChangeLog
+++ b/sci-biology/treeviewx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/treeviewx
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/ChangeLog,v 1.16 2007/04/30 03:51:41 dirtyepic Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/ChangeLog,v 1.17 2008/06/16 10:45:59 markusle Exp $
+
+*treeviewx-0.5.1-r1 (16 Jun 2008)
+
+ 16 Jun 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/treeviewx-0.5.1-gcc4.3.patch, +treeviewx-0.5.1-r1.ebuild:
+ Added new revision with fix for gcc-4.3 compile issues (bug #227245).
+ Thanks much to Marek Miller <mlm@shells.pl> for his patch.
30 Apr 2007; Ryan Hill <dirtyepic@gentoo.org> treeviewx-0.5.1.ebuild:
Use wxwidgets.eclass
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch
new file mode 100644
index 000000000000..7d42d962eaff
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch
@@ -0,0 +1,75 @@
+diff -Naur tv-0.5.1/TreeLib/Parse.cpp tv-0.5.1.new/TreeLib/Parse.cpp
+--- tv-0.5.1/TreeLib/Parse.cpp 2002-02-23 07:22:32.000000000 -0500
++++ tv-0.5.1.new/TreeLib/Parse.cpp 2008-06-16 06:32:30.000000000 -0400
+@@ -20,7 +20,9 @@
+ */
+
+ // $Id: treeviewx-0.5.1-gcc4.3.patch,v 1.1 2008/06/16 10:46:00 markusle Exp $
+-
++
++
++#include <cstring>
+ #include <ctype.h>
+ #include "Parse.h"
+
+diff -Naur tv-0.5.1/TreeLib/TreeLib.cpp tv-0.5.1.new/TreeLib/TreeLib.cpp
+--- tv-0.5.1/TreeLib/TreeLib.cpp 2004-05-13 08:22:11.000000000 -0400
++++ tv-0.5.1.new/TreeLib/TreeLib.cpp 2008-06-16 06:32:30.000000000 -0400
+@@ -24,6 +24,8 @@
+ #include "TreeLib.h"
+ #include "Parse.h"
+
++
++#include <cstdlib>
+ #include <vector>
+
+
+diff -Naur tv-0.5.1/TreeLib/treereader.cpp tv-0.5.1.new/TreeLib/treereader.cpp
+--- tv-0.5.1/TreeLib/treereader.cpp 2003-09-10 08:58:16.000000000 -0400
++++ tv-0.5.1.new/TreeLib/treereader.cpp 2008-06-16 06:32:30.000000000 -0400
+@@ -21,6 +21,8 @@
+
+ // $Id: treeviewx-0.5.1-gcc4.3.patch,v 1.1 2008/06/16 10:46:00 markusle Exp $
+
++#include <cstring>
++#include <cstdlib>
+ #include "treereader.h"
+
+ #if __MWERKS__
+diff -Naur tv-0.5.1/ncl-2.0/src/charactersblock.cpp tv-0.5.1.new/ncl-2.0/src/charactersblock.cpp
+--- tv-0.5.1/ncl-2.0/src/charactersblock.cpp 2002-12-10 06:35:49.000000000 -0500
++++ tv-0.5.1.new/ncl-2.0/src/charactersblock.cpp 2008-06-16 06:32:30.000000000 -0400
+@@ -1,3 +1,5 @@
++
++#include <cstring>
+ #include "nexusdefs.h"
+ #include "xnexus.h"
+ #include "nexustoken.h"
+diff -Naur tv-0.5.1/ncl-2.0/src/nexus.cpp tv-0.5.1.new/ncl-2.0/src/nexus.cpp
+--- tv-0.5.1/ncl-2.0/src/nexus.cpp 2002-12-10 06:35:50.000000000 -0500
++++ tv-0.5.1.new/ncl-2.0/src/nexus.cpp 2008-06-16 06:32:30.000000000 -0400
+@@ -1,3 +1,5 @@
++
++#include <cstring>
+ #include "nexusdefs.h"
+ #include "xnexus.h"
+ #include "nexustoken.h"
+diff -Naur tv-0.5.1/ncl-2.0/src/nexustoken.cpp tv-0.5.1.new/ncl-2.0/src/nexustoken.cpp
+--- tv-0.5.1/ncl-2.0/src/nexustoken.cpp 2005-04-29 10:28:17.000000000 -0400
++++ tv-0.5.1.new/ncl-2.0/src/nexustoken.cpp 2008-06-16 06:32:30.000000000 -0400
+@@ -1,3 +1,5 @@
++
++#include <cstring>
+ #include "nexusdefs.h"
+ #include "xnexus.h"
+ #include "nexustoken.h"
+diff -Naur tv-0.5.1/ncl-2.0/src/nxsstring.cpp tv-0.5.1.new/ncl-2.0/src/nxsstring.cpp
+--- tv-0.5.1/ncl-2.0/src/nxsstring.cpp 2001-02-02 07:55:40.000000000 -0500
++++ tv-0.5.1.new/ncl-2.0/src/nxsstring.cpp 2008-06-16 06:32:30.000000000 -0400
+@@ -1,3 +1,6 @@
++
++#include <cstring>
++
+ #ifdef __BORLANDC__
+ // Undefine __MINMAX_DEFINED so that min and max are correctly defined
+ #ifdef __MINMAX_DEFINED
diff --git a/sci-biology/treeviewx/treeviewx-0.5.1-r1.ebuild b/sci-biology/treeviewx/treeviewx-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..b8408d8098b4
--- /dev/null
+++ b/sci-biology/treeviewx/treeviewx-0.5.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/treeviewx-0.5.1-r1.ebuild,v 1.1 2008/06/16 10:45:59 markusle Exp $
+
+inherit eutils wxwidgets
+
+DESCRIPTION="A phylogenetic tree viewer"
+HOMEPAGE="http://darwin.zoology.gla.ac.uk/~rpage/treeviewx/"
+SRC_URI="http://darwin.zoology.gla.ac.uk/~rpage/${PN}/download/0.5/tv-${PV}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="=x11-libs/wxGTK-2.6*"
+
+S="${WORKDIR}/tv-${PV}"
+
+pkg_setup() {
+ if ! built_with_use x11-libs/wxGTK X; then
+ echo
+ eerror "TreeViewX requires an SVG library which is part of the"
+ eerror "optional X support in the \"x11-libs/wxGTK\" package. To"
+ eerror "install TreeViewX on your system, first recompile"
+ eerror "\"x11-libs/wxGTK\" with the \"X\" USE flag enabled, then try"
+ eerror "to install TreeViewX again."
+ die "X support not enabled in \"x11-libs/wxGTK\""
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-wxt.patch
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
+}
+
+src_compile() {
+ WX_GTK_VER="2.6"
+ need-wxwidgets gtk2
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+}
diff --git a/sci-biology/treeviewx/treeviewx-0.5.1.ebuild b/sci-biology/treeviewx/treeviewx-0.5.1.ebuild
index 5141d4569de0..b599bb54e658 100644
--- a/sci-biology/treeviewx/treeviewx-0.5.1.ebuild
+++ b/sci-biology/treeviewx/treeviewx-0.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/treeviewx-0.5.1.ebuild,v 1.6 2007/04/30 03:51:41 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/treeviewx/treeviewx-0.5.1.ebuild,v 1.7 2008/06/16 10:45:59 markusle Exp $
inherit eutils wxwidgets