summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/gobby/ChangeLog7
-rw-r--r--app-editors/gobby/gobby-0.4.11.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-editors/gobby/ChangeLog b/app-editors/gobby/ChangeLog
index 75430924883b..6d427cf646cb 100644
--- a/app-editors/gobby/ChangeLog
+++ b/app-editors/gobby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gobby
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.33 2009/10/28 09:10:16 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/ChangeLog,v 1.34 2009/11/07 21:52:46 patrick Exp $
+
+*gobby-0.4.11 (07 Nov 2009)
+
+ 07 Nov 2009; Patrick Lauer <patrick@gentoo.org> +gobby-0.4.11.ebuild:
+ Bump for #292293
28 Oct 2009; Torsten Veller <tove@gentoo.org> metadata.xml:
humpback is AWOL (#34793). Adding maintainer-needed
diff --git a/app-editors/gobby/gobby-0.4.11.ebuild b/app-editors/gobby/gobby-0.4.11.ebuild
new file mode 100644
index 000000000000..a79d9caad929
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.11.ebuild,v 1.1 2009/11/07 21:52:46 patrick Exp $
+
+EAPI="2"
+
+inherit base eutils
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="avahi gnome"
+
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/libsigc++:2
+ >=net-libs/obby-0.4.6[avahi?]
+ dev-cpp/libxmlpp:2.6
+ x11-libs/gtksourceview:2.0
+ gnome? ( gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# There's only one test and it needs X
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ --with-gtksourceview2 \
+ $(use_with gnome)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ domenu contrib/gobby.desktop
+}