summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/commons-jexl/ChangeLog12
-rw-r--r--dev-java/commons-jexl/commons-jexl-2.1.1.ebuild57
-rw-r--r--dev-java/commons-jexl/files/2.1.1-build.xml127
3 files changed, 193 insertions, 3 deletions
diff --git a/dev-java/commons-jexl/ChangeLog b/dev-java/commons-jexl/ChangeLog
index 91d9b7c43426..74f29847e821 100644
--- a/dev-java/commons-jexl/ChangeLog
+++ b/dev-java/commons-jexl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/commons-jexl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jexl/ChangeLog,v 1.10 2011/12/19 12:22:54 sera Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jexl/ChangeLog,v 1.11 2013/11/24 14:46:46 ercpe Exp $
+
+*commons-jexl-2.1.1 (24 Nov 2013)
+
+ 24 Nov 2013; Johann Schmitz <ercpe@gentoo.org> +commons-jexl-2.1.1.ebuild,
+ +files/2.1.1-build.xml:
+ Version bump of commons-jexl to 2.1.1 (wrt #480432). Dependency of picard
+ (#491816) et al.
19 Dec 2011; Ralph Sennhauser <sera@gentoo.org> commons-jexl-1.1.ebuild:
Fix homepage wrt #202445. Fix unquoted variables to please repoman.
@@ -45,4 +52,3 @@
+commons-jexl-1.0.ebuild:
Initial import. Ebuild based on the contribution by Vibhav Garg
<vibhavgarg@gmail.com>. Fixes #70671
-
diff --git a/dev-java/commons-jexl/commons-jexl-2.1.1.ebuild b/dev-java/commons-jexl/commons-jexl-2.1.1.ebuild
new file mode 100644
index 000000000000..96019e8f77bc
--- /dev/null
+++ b/dev-java/commons-jexl/commons-jexl-2.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jexl/commons-jexl-2.1.1.ebuild,v 1.1 2013/11/24 14:46:46 ercpe Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Expression language engine, can be embedded in applications and frameworks."
+HOMEPAGE="http://commons.apache.org/jexl/"
+SRC_URI="mirror://apache/commons/jexl/source/${P}-src.tar.gz"
+
+CDEPEND="dev-java/commons-logging:0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.5
+ >=dev-java/javacc-5
+ test? ( dev-java/ant-junit:0 )
+ ${CDEPEND}"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="commons-logging"
+
+java_prepare() {
+ cp "${FILESDIR}"/${PV}-build.xml build.xml || die
+
+ # these two calls is what the "jjtree-javacc" goal in the pom.xml does
+ jjtree -OUTPUT_DIRECTORY="${S}/src/main/java/org/apache/commons/jexl2/parser/" \
+ src/main/java/org/apache/commons/jexl2/parser/Parser.jjt \
+ || die "Code generation via jjtree failed"
+ javacc -OUTPUT_DIRECTORY="${S}/src/main/java/org/apache/commons/jexl2/parser/" \
+ src/main/java/org/apache/commons/jexl2/parser/Parser.jj \
+ || die "Parser.java code generation via javacc failed"
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt
+
+ use doc && java-pkg_dojavadoc "${S}"/target/site/apidocs
+ use source && java-pkg_dosrc "${S}"/src/main/java/*
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
diff --git a/dev-java/commons-jexl/files/2.1.1-build.xml b/dev-java/commons-jexl/files/2.1.1-build.xml
new file mode 100644
index 000000000000..d0bf54ef3571
--- /dev/null
+++ b/dev-java/commons-jexl/files/2.1.1-build.xml
@@ -0,0 +1,127 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<project name="commons-jexl-from-maven" default="package" basedir=".">
+ <property file="${user.home}/.m2/maven.properties" />
+ <property file="maven-build.properties" />
+
+ <property name="maven.build.finalName" value="commons-jexl" />
+ <property name="maven.build.dir" value="target" />
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes" />
+ <property name="maven.build.srcDir.0" value="src/main/java" />
+ <property name="maven.build.resourceDir.0" value="src/main/resources" />
+ <property name="maven.build.resourceDir.1" value="." />
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes" />
+ <property name="maven.build.testDir.0" value="src/test/java" />
+ <property name="maven.build.testResourceDir.0" value="src/test/resources" />
+ <property name="maven.build.testResourceDir.1" value="." />
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports" />
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site" />
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository" />
+ <property name="maven.settings.offline" value="false" />
+ <property name="maven.settings.interactiveMode" value="true" />
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath" />
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}" />
+ </target>
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}" />
+ <javac destdir="${maven.build.outputDir}" encoding="iso-8859-1" nowarn="false" debug="true" optimize="false" deprecation="true" target="1.5" verbose="false" fork="false" source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}" />
+ </src>
+ <classpath refid="build.classpath" />
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}" />
+ </copy>
+ <mkdir dir="${maven.build.outputDir}/META-INF" />
+ </target>
+
+ <target name="compile-tests" depends="compile" description="Compile the test code" unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}" />
+ <javac destdir="${maven.build.testOutputDir}" encoding="iso-8859-1" nowarn="false" debug="true" optimize="false" deprecation="true" target="1.5" verbose="false" fork="false" source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}" />
+ </src>
+ <classpath>
+ <path refid="build.test.classpath" />
+ <pathelement location="${maven.build.outputDir}" />
+ </classpath>
+ </javac>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF" />
+ </target>
+
+ <target name="test" depends="compile-tests, junit-missing" unless="junit.skipped" description="Run the test cases">
+ <mkdir dir="${maven.test.reports}" />
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="." />
+ <formatter type="xml" />
+ <formatter type="plain" usefile="false" />
+ <classpath>
+ <path refid="build.test.classpath" />
+ <pathelement location="${maven.build.outputDir}" />
+ <pathelement location="${maven.build.testOutputDir}" />
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test.java" />
+ <exclude name="**/*Abstract*Test.java" />
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java" />
+ <exclude name="**/*Abstract*Test.java" />
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" />
+ </target>
+
+ <target name="test-junit-status" depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}" />
+ <isfalse value="${maven.test.skip}" />
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}" />
+ <istrue value="${maven.test.skip}" />
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing" depends="test-junit-status" if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}" packagenames="*" destdir="${maven.reporting.outputDirectory}/apidocs" access="protected" old="false" verbose="false" encoding="iso-8859-1" version="true" use="true" author="true" splitindex="false" nodeprecated="false" nodeprecatedlist="false" notree="false" noindex="false" nohelp="false" nonavbar="false" serialwarn="false" charset="ISO-8859-1" source="1.5" linksource="true" breakiterator="false">
+ </javadoc>
+ </target>
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar" compress="true" index="false" basedir="${maven.build.outputDir}" excludes="**/package.html">
+ </jar>
+ </target>
+
+ <target name="jar" depends="package" description="Builds the jar for the application" />
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true" />
+ </condition>
+ </target>
+</project>