summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/windowlab/ChangeLog11
-rw-r--r--x11-wm/windowlab/files/windowlab-1.40-gentoo.diff53
-rw-r--r--x11-wm/windowlab/windowlab-1.40.ebuild53
3 files changed, 115 insertions, 2 deletions
diff --git a/x11-wm/windowlab/ChangeLog b/x11-wm/windowlab/ChangeLog
index 71ece8222e4f..73e443911e13 100644
--- a/x11-wm/windowlab/ChangeLog
+++ b/x11-wm/windowlab/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/windowlab
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowlab/ChangeLog,v 1.28 2009/01/09 15:42:49 remi Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowlab/ChangeLog,v 1.29 2010/05/30 15:40:25 xarthisius Exp $
+
+*windowlab-1.40 (30 May 2010)
+
+ 30 May 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +windowlab-1.40.ebuild, +files/windowlab-1.40-gentoo.diff:
+ Version bump. Thanks to Tomáš Hlušička <tomas.hlusicka@seznam.cz> for
+ report
09 Jan 2009; Rémi Cardona <remi@gentoo.org> windowlab-1.34.ebuild:
Change virtual/xft dependency to x11-libs/libXft, bug 253771.
diff --git a/x11-wm/windowlab/files/windowlab-1.40-gentoo.diff b/x11-wm/windowlab/files/windowlab-1.40-gentoo.diff
new file mode 100644
index 000000000000..121526ceac8b
--- /dev/null
+++ b/x11-wm/windowlab/files/windowlab-1.40-gentoo.diff
@@ -0,0 +1,53 @@
+--- Makefile.orig 2009-11-05 21:04:45.000000000 +0000
++++ Makefile 2010-05-30 15:31:04.047559352 +0000
+@@ -5,18 +5,18 @@
+ EXTRA_LIBS += -lXext
+
+ # Set this to the hardcoded location of all files if it's not /
+-PREFIX = /usr/local
++PREFIX = /usr
+
+ # Set this to the directory, below PREFIX, where man pages
+ # are expected. Below this directory, the target "install"
+ # will put "windowlab.1x" in section "man1".
+-MANBASE = /man
++MANBASE = /share/man
+
+ # Set this to the location of the X installation you want to compile against
+-XROOT = /usr/X11R6
++XROOT = /usr
+
+ # Some flexibility for configuration location
+-CONFPREFIX = $(PREFIX)
++CONFPREFIX =
+ CONFDIR = /etc/X11/windowlab
+
+ # Set this to the location of the global configuration files
+@@ -43,7 +43,6 @@
+
+ # --------------------------------------------------------------------
+
+-CC = gcc
+ ifndef CFLAGS
+ CFLAGS = -g -O2 -Wall -W
+ endif
+@@ -63,15 +62,15 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(LDPATH) $(LIBS) -o $@
+
+ $(OBJS): %.o: %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
+
+ install: all
+- mkdir -p $(BINDIR) && install -m 755 -s $(PROG) $(BINDIR)
+- mkdir -p $(MANDIR) && install -m 644 $(MANPAGE) $(MANDIR) && gzip -9vfn $(MANDIR)/$(MANPAGE)
+- mkdir -p $(CFGDIR) && cp -i windowlab.menurc $(CFGDIR)/windowlab.menurc && chmod 644 $(CFGDIR)/windowlab.menurc
++ install -D -m 755 $(PROG) $(BINDIR)/$(PROG)
++ install -D -m 644 $(MANPAGE) $(MANDIR)/windowlab.1
++ install -D -m 644 windowlab.menurc $(CFGDIR)/windowlab.menurc
+
+ clean:
+ rm -f $(PROG) $(OBJS)
diff --git a/x11-wm/windowlab/windowlab-1.40.ebuild b/x11-wm/windowlab/windowlab-1.40.ebuild
new file mode 100644
index 000000000000..5157aacd28f8
--- /dev/null
+++ b/x11-wm/windowlab/windowlab-1.40.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowlab/windowlab-1.40.ebuild,v 1.1 2010/05/30 15:40:25 xarthisius Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="small and simple window manager of novel design."
+HOMEPAGE="http://www.nickgravgaard.com/windowlab/"
+SRC_URI="http://www.nickgravgaard.com/${PN}/${P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="truetype"
+
+RDEPEND="truetype? ( x11-libs/libXft )
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use truetype ; then
+ export DEFINES=-DXFT
+ export EXTRA_INC=$(pkg-config --cflags xft)
+ export EXTRA_LIBS=$(pkg-config --libs xft)
+ fi
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.34-fixed-font.patch" \
+ "${FILESDIR}"/${P}-gentoo.diff
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGELOG README TODO || die
+
+ exeinto /etc/X11/Sessions
+ cat <<- EOF > "${T}"/${PN}
+ #!/bin/sh
+ exec /usr/bin/${PN}
+ EOF
+ doexe "${T}"/${PN}
+}
+
+pkg_postinst() {
+ elog "${PN}'s menu config file has been changed from"
+ elog "/etc/X11/${PN}/menurc to /etc/X11/${PN}/${PN}.menurc"
+}