summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/audtty/ChangeLog11
-rw-r--r--media-sound/audtty/audtty-0.1.12.ebuild46
-rw-r--r--media-sound/audtty/files/audtty-0.1.12-cc-and-destdir.patch29
3 files changed, 84 insertions, 2 deletions
diff --git a/media-sound/audtty/ChangeLog b/media-sound/audtty/ChangeLog
index b46829c79edc..5f926157e9aa 100644
--- a/media-sound/audtty/ChangeLog
+++ b/media-sound/audtty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/audtty
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audtty/ChangeLog,v 1.22 2009/08/09 11:37:24 nixnut Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audtty/ChangeLog,v 1.23 2011/11/04 11:00:58 chainsaw Exp $
+
+*audtty-0.1.12 (04 Nov 2011)
+
+ 04 Nov 2011; Tony Vroon <chainsaw@gentoo.org> +audtty-0.1.12.ebuild,
+ +files/audtty-0.1.12-cc-and-destdir.patch:
+ Version bump. Address underlinking as pointed out by Diego Elio Pettenò in
+ bug #369707.
09 Aug 2009; nixnut <nixnut@gentoo.org> audtty-0.1.9a-r1.ebuild:
ppc stable #272326
diff --git a/media-sound/audtty/audtty-0.1.12.ebuild b/media-sound/audtty/audtty-0.1.12.ebuild
new file mode 100644
index 000000000000..f9fd47e04461
--- /dev/null
+++ b/media-sound/audtty/audtty-0.1.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audtty/audtty-0.1.12.ebuild,v 1.1 2011/11/04 11:00:57 chainsaw Exp $
+
+EAPI=4
+inherit autotools base toolchain-funcs
+
+DESCRIPTION="Control Audacious from the command line with a friendly ncurses interface"
+HOMEPAGE="http://audtty.alioth.debian.org"
+SRC_URI="http://www.code-monkeys.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses
+ >=media-sound/audacious-2.4.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-cc-and-destdir.patch" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+ elog "In order to run audtty over ssh or on a seperate TTY locally you need"
+ elog "to download and run the following script in a terminal on your desktop:"
+ elog ""
+ elog "http://${PN}.alioth.debian.org/dbus.sh"
+ elog ""
+ elog "Once run you will need to add ~/.dbus-session to your ~/.bashrc file."
+}
diff --git a/media-sound/audtty/files/audtty-0.1.12-cc-and-destdir.patch b/media-sound/audtty/files/audtty-0.1.12-cc-and-destdir.patch
new file mode 100644
index 000000000000..61ba98e5f04a
--- /dev/null
+++ b/media-sound/audtty/files/audtty-0.1.12-cc-and-destdir.patch
@@ -0,0 +1,29 @@
+--- audtty-0.1.12.ORIG/Makefile.in 2011-11-04 10:48:58.715132072 +0000
++++ audtty-0.1.12/Makefile.in 2011-11-04 10:51:28.352134317 +0000
+@@ -20,18 +20,18 @@
+ all: audtty
+
+ audtty: ${BINS}
+- cc -g -O2 -g2 -Wall -Werror -lncursesw -laudclient ${LDFLAGS} -o audtty $(BINS)
++ $(CC) -Wall ${LDFLAGS} -o audtty $(BINS) -lncursesw -laudclient -lglib-2.0 -ldbus-glib-1 -lgobject-2.0
+
+ .c.o:
+- cc -g -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
++ $(CC) -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
+
+ install: audtty
+- mkdir -p ${bindir}
+- install -m 0755 audtty ${bindir}/audtty
+- mkdir -p ${mandir}
+- install -m 0644 audtty.1 ${mandir}/audtty.1
+- mkdir -p ${sysconfdir}
+- install -m 0644 audtty.conf ${sysconfdir}/audtty.conf
++ mkdir -p $(DESTDIR)${bindir}
++ install -m 0755 audtty $(DESTDIR)${bindir}/audtty
++ mkdir -p $(DESTDIR)${mandir}
++ install -m 0644 audtty.1 $(DESTDIR)${mandir}/audtty.1
++ mkdir -p $(DESTDIR)${sysconfdir}
++ install -m 0644 audtty.conf $(DESTDIR)${sysconfdir}/audtty.conf
+
+ uninstall:
+ rm ${bindir}/audtty || false