summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/util-linux/ChangeLog6
-rw-r--r--sys-apps/util-linux/Manifest12
-rw-r--r--sys-apps/util-linux/files/util-linux-2.11z-mips-fdisk-fix.patch54
-rw-r--r--sys-apps/util-linux/util-linux-2.11z-r1.ebuild12
4 files changed, 82 insertions, 2 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index a224d5e40033..5ed1acf4ab8d 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.29 2003/03/24 03:11:55 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.30 2003/04/22 22:16:26 kumba Exp $
*util-linux-2.11z (03 Feb 2003)
+ 22 Apr 2003; Joshua Kinard <kumba@gentoo.org> util-linux-2.11z-r1.ebuild:
+ added patch from util-linux maintainer that makes fdisk function correctly on mips
+ patch only gets added on "mips" archs, but will be standard in util-linux 2.12
+
23 Mar 2003; Joshua Brindle <method@gentoo.org> util-linux-2.11z-r1.ebuild:
added selinux support, thanks sindian
diff --git a/sys-apps/util-linux/Manifest b/sys-apps/util-linux/Manifest
new file mode 100644
index 000000000000..a6a745157612
--- /dev/null
+++ b/sys-apps/util-linux/Manifest
@@ -0,0 +1,12 @@
+MD5 897b3f3d414c7ed899c97b242eedc429 ChangeLog 4895
+MD5 f57fa14eb16fc800e4aa7a32802a3bd7 util-linux-2.11o-r3.ebuild 1718
+MD5 565d1b898a530f0b451df4f0c4555239 util-linux-2.11y.ebuild 2111
+MD5 59486f0e0487356259342c9f48af09a6 util-linux-2.11z-r1.ebuild 2334
+MD5 939305c630f0d2196de84e79f220dd8d files/digest-util-linux-2.11o-r3 138
+MD5 48e36b9b6ea3bed4ea25292f9ae5a958 files/digest-util-linux-2.11y 152
+MD5 02afa4d774f45ab0b9ef42ecc1748005 files/digest-util-linux-2.11z-r1 153
+MD5 6aa1c240dd789327ea92e36309052950 files/no-symlink-resolve.patch 316
+MD5 50b088dbe0471cb0a49ad1f9b967ee04 files/util-linux-2.11u-gentoo.patch 367
+MD5 e3697bc8fd6a344e8cba1c7d32e34790 files/util-linux-2.11y-parallel-make.patch 369
+MD5 e3697bc8fd6a344e8cba1c7d32e34790 files/util-linux-2.11z-parallel-make.patch 369
+MD5 6dc0134d8d5f325a86257698d2184718 files/util-linux-2.11z-mips-fdisk-fix.patch 1698
diff --git a/sys-apps/util-linux/files/util-linux-2.11z-mips-fdisk-fix.patch b/sys-apps/util-linux/files/util-linux-2.11z-mips-fdisk-fix.patch
new file mode 100644
index 000000000000..d0279dab5dcc
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.11z-mips-fdisk-fix.patch
@@ -0,0 +1,54 @@
+--- ../../util-linux-2.11z/fdisk/fdisk.c Sat Nov 23 17:05:24 2002
++++ ./fdisk.c Thu Apr 10 01:26:39 2003
+@@ -1335,7 +1337,15 @@
+ int i, sys, origsys;
+ struct partition *p;
+
+- i = get_existing_partition(0, partitions);
++ /* If sgi_label then don't use get_existing_partition,
++ let the user select a partition, since get_existing_partition()
++ only works for Linux like partition tables. */
++ if (!sgi_label) {
++ i = get_existing_partition(0, partitions);
++ } else {
++ i = get_partition(0, partitions);
++ }
++
+ if (i == -1)
+ return;
+ p = ptes[i].part_table;
+@@ -1866,7 +1876,7 @@
+ fill_bounds(first, last);
+ if (n < 4) {
+ start = sector_offset;
+- if (display_in_cyl_units)
++ if (display_in_cyl_units || !total_number_of_sectors)
+ limit = heads * sectors * cylinders - 1;
+ else
+ limit = total_number_of_sectors - 1;
+@@ -1946,7 +1956,7 @@
+ _("Last %s or +size or +sizeM or +sizeK"),
+ str_units(SINGULAR));
+ stop = read_int(cround(start), cround(limit), cround(limit),
+- cround(start), mesg);
++ cround(start)-1, mesg);
+ if (display_in_cyl_units) {
+ stop = stop * units_per_sector - 1;
+ if (stop >limit)
+@@ -2575,7 +2585,15 @@
+ unknown_command(c);
+ break;
+ case 'd':
+- j = get_existing_partition(1, partitions);
++ /* If sgi_label then don't use get_existing_partition,
++ let the user select a partition, since
++ get_existing_partition() only works for Linux-like
++ partition tables */
++ if (!sgi_label) {
++ j = get_existing_partition(1, partitions);
++ } else {
++ j = get_partition(1, partitions);
++ }
+ if (j >= 0)
+ delete_partition(j);
+ break;
diff --git a/sys-apps/util-linux/util-linux-2.11z-r1.ebuild b/sys-apps/util-linux/util-linux-2.11z-r1.ebuild
index 894cb486647e..c64bda13e064 100644
--- a/sys-apps/util-linux/util-linux-2.11z-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.11z-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11z-r1.ebuild,v 1.7 2003/03/24 03:11:55 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11z-r1.ebuild,v 1.8 2003/04/22 22:16:26 kumba Exp $
IUSE="crypt nls selinux"
@@ -45,6 +45,16 @@ src_unpack() {
# Fix unreadable df output
epatch ${FILESDIR}/no-symlink-resolve.patch
+ # <kumba@gentoo.org> (22 Apr 2003)
+ # Fix fdisk so it works on SGI Disk Labels and lets the user
+ # Actually select a partition, rather than automatically
+ # choosing "4".
+ if [ "${ARCH}" = "mips" ]
+ then
+ epatch ${FILESDIR}/${P}-mips-fdisk-fix.patch
+ fi
+
+
cp MCONFIG MCONFIG.orig
sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \