summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/cvs/ChangeLog7
-rw-r--r--dev-util/cvs/cvs-1.11.17.ebuild57
-rw-r--r--dev-util/cvs/files/digest-cvs-1.11.174
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-util/cvs/ChangeLog b/dev-util/cvs/ChangeLog
index 216138ce9e6a..eebc8ca42aee 100644
--- a/dev-util/cvs/ChangeLog
+++ b/dev-util/cvs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cvs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.52 2004/06/09 15:13:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.53 2004/06/09 17:56:49 scandium Exp $
+
+*cvs-1.11.17 (09 Jun 2004)
+
+ 09 Jun 2004; Rainer Groesslinger <scandium@gentoo.org> cvs-1.11.17.ebuild:
+ new version, security update (bug #53408)
09 Jun 2004; Aron Griffis <agriffis@gentoo.org> cvs-1.11.16-r1.ebuild,
cvs-1.11.16.ebuild:
diff --git a/dev-util/cvs/cvs-1.11.17.ebuild b/dev-util/cvs/cvs-1.11.17.ebuild
new file mode 100644
index 000000000000..37b2105ad475
--- /dev/null
+++ b/dev-util/cvs/cvs-1.11.17.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.11.17.ebuild,v 1.1 2004/06/09 17:56:52 scandium Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Concurrent Versions System - source code revision control tools"
+HOMEPAGE="http://www.cvshome.org/"
+
+# scandium@gentoo.org (9th June 2004)
+# Recently, upstream changed the directory structure for the files.
+# The directory numbers in the middle differ for every release/file, so
+# unfortunatly they have to be corrected with every new release.
+SRC_URI="http://ccvs.cvshome.org/files/documents/19/191/${P}.tar.bz2
+ doc? ( http://ccvs.cvshome.org/files/documents/19/199/cederqvist-${PV}.html.tar.bz2
+ http://ccvs.cvshome.org/files/documents/19/197/cederqvist-${PV}.pdf
+ http://ccvs.cvshome.org/files/documents/19/196/cederqvist-${PV}.ps )"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+
+IUSE="doc emacs"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.4"
+
+src_compile() {
+ use alpha && append-flags -fPIC
+
+ econf --with-tmpdir=/tmp || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/cvspserver.xinetd.d cvspserver || die "newins failed"
+
+ dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
+ MINOR* NEWS PROJECTS README* TESTS TODO
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp
+ doins cvs-format.el || die "doins failed"
+ fi
+
+ if use doc; then
+ dodoc ${DISTDIR}/cederqvist-${PV}.pdf
+ dodoc ${DISTDIR}/cederqvist-${PV}.ps
+ tar xjf ${DISTDIR}/cederqvist-${PV}.html.tar.bz2
+ dohtml -r cederqvist-${PV}.html/*
+ cd ${D}/usr/share/doc/${PF}/html/
+ ln -s cvs.html index.html
+ fi
+}
diff --git a/dev-util/cvs/files/digest-cvs-1.11.17 b/dev-util/cvs/files/digest-cvs-1.11.17
new file mode 100644
index 000000000000..e24faf8b4840
--- /dev/null
+++ b/dev-util/cvs/files/digest-cvs-1.11.17
@@ -0,0 +1,4 @@
+MD5 17cd48888d5571d215a44a7e8d46759c cvs-1.11.17.tar.bz2 2343366
+MD5 375e11766de80eb1fd1256abc132b3a8 cederqvist-1.11.17.html.tar.bz2 114159
+MD5 361faa49ebb62c8f22c12b0a2594454f cederqvist-1.11.17.pdf 1084788
+MD5 1b67e454af56a408f16a665ab36e6035 cederqvist-1.11.17.ps 1090356