summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/noteedit/ChangeLog7
-rw-r--r--media-sound/noteedit/files/noteedit-2.8.1+gcc-4.3.1.patch28
-rw-r--r--media-sound/noteedit/noteedit-2.8.1-r1.ebuild4
3 files changed, 36 insertions, 3 deletions
diff --git a/media-sound/noteedit/ChangeLog b/media-sound/noteedit/ChangeLog
index 164ee3d946d3..17ecae9bbdf3 100644
--- a/media-sound/noteedit/ChangeLog
+++ b/media-sound/noteedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/noteedit
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/ChangeLog,v 1.33 2008/05/02 16:08:16 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/ChangeLog,v 1.34 2008/06/25 17:24:22 aballier Exp $
+
+ 25 Jun 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/noteedit-2.8.1+gcc-4.3.1.patch, noteedit-2.8.1-r1.ebuild:
+ fix build with gcc 4.3 with tse3 useflag on, by Markus Rathgeb
+ <maggu2810@web.de>, bug #229291
02 May 2008; Samuli Suominen <drac@gentoo.org> noteedit-2.8.1-r1.ebuild:
Use berlios mirrors://
diff --git a/media-sound/noteedit/files/noteedit-2.8.1+gcc-4.3.1.patch b/media-sound/noteedit/files/noteedit-2.8.1+gcc-4.3.1.patch
new file mode 100644
index 000000000000..d5a2238b8834
--- /dev/null
+++ b/media-sound/noteedit/files/noteedit-2.8.1+gcc-4.3.1.patch
@@ -0,0 +1,28 @@
+diff -Naur noteedit-2.8.1.orig/configure.in.in noteedit-2.8.1/configure.in.in
+--- noteedit-2.8.1.orig/configure.in.in 2006-03-27 08:07:18.000000000 +0200
++++ noteedit-2.8.1/configure.in.in 2008-06-24 23:04:48.000000000 +0200
+@@ -275,10 +275,10 @@
+
+ fi
+ cat >tse3vtest.cc << EOF
+-#include <istream.h>
++#include <iostream>
+ #include <tse3/TSE3.h>
+ int main() {
+- cout << TSE3::TSE3_Version() << endl;
++ std::cout << TSE3::TSE3_Version() << std::endl;
+ return 0;
+ }
+ EOF
+diff -Naur noteedit-2.8.1.orig/kguitar_excerpt/fingerlist.cpp noteedit-2.8.1/kguitar_excerpt/fingerlist.cpp
+--- noteedit-2.8.1.orig/kguitar_excerpt/fingerlist.cpp 2006-03-26 22:54:31.000000000 +0200
++++ noteedit-2.8.1/kguitar_excerpt/fingerlist.cpp 2008-06-24 23:04:24.000000000 +0200
+@@ -21,7 +21,7 @@
+ #if GCC_MAJ_VERS > 2
+ #include <istream>
+ #else
+-#include <istream.h>
++#include <istream>
+ #endif
+ #include <qpainter.h>
+ #include <qcolor.h>
diff --git a/media-sound/noteedit/noteedit-2.8.1-r1.ebuild b/media-sound/noteedit/noteedit-2.8.1-r1.ebuild
index 7d918577bdbd..79bf76e38a7b 100644
--- a/media-sound/noteedit/noteedit-2.8.1-r1.ebuild
+++ b/media-sound/noteedit/noteedit-2.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/noteedit-2.8.1-r1.ebuild,v 1.6 2008/05/02 16:08:16 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/noteedit/noteedit-2.8.1-r1.ebuild,v 1.7 2008/06/25 17:24:22 aballier Exp $
IUSE="kmid tse3"
@@ -23,7 +23,7 @@ DEPEND="kmid? ( || ( kde-base/kmid kde-base/kdemultimedia ) )
need-kde 3
-PATCHES=( "${FILESDIR}/${P}-desktop-file.patch" "${FILESDIR}/${P}+gcc-4.3.patch" )
+PATCHES=( "${FILESDIR}/${P}-desktop-file.patch" "${FILESDIR}/${P}+gcc-4.3.patch" "${FILESDIR}/${P}+gcc-4.3.1.patch" )
src_compile() {
use tse3 || use kmid || myconf="--without-libs"