summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/logbook/ChangeLog10
-rw-r--r--dev-python/logbook/files/logbook-0.4.2-objectsinv.patch11
-rw-r--r--dev-python/logbook/logbook-0.4.2.ebuild50
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/logbook/ChangeLog b/dev-python/logbook/ChangeLog
index 6cfdc71ada71..3bf3fc0a478f 100644
--- a/dev-python/logbook/ChangeLog
+++ b/dev-python/logbook/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/logbook
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.8 2013/04/05 21:49:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.9 2013/06/30 14:50:46 idella4 Exp $
+
+*logbook-0.4.2 (30 Jun 2013)
+
+ 30 Jun 2013; Ian Delaney <idella4@gentoo.org>
+ +files/logbook-0.4.2-objectsinv.patch, +logbook-0.4.2.ebuild,
+ logbook-0.4.ebuild:
+ bump; Drop support py3.1 py3.2 add py3.3, patch for doc build, add IUSE doc,
+ upgrade all phases, closes Bug #440210
05 Apr 2013; Agostino Sarubbo <ago@gentoo.org> logbook-0.4.ebuild:
Stable for x86, wrt bug #457900
diff --git a/dev-python/logbook/files/logbook-0.4.2-objectsinv.patch b/dev-python/logbook/files/logbook-0.4.2-objectsinv.patch
new file mode 100644
index 000000000000..28b26f0bc9a3
--- /dev/null
+++ b/dev-python/logbook/files/logbook-0.4.2-objectsinv.patch
@@ -0,0 +1,11 @@
+Prevent unwanted d'loading of un-needed objects.inv files
+diff -ur logbook-0.4.2.orig/docs/conf.py logbook-0.4.2/docs/conf.py
+--- docs/conf.py 2013-06-02 19:31:32.000000000 +0800
++++ docs/conf.py 2013-06-30 10:50:38.604402792 +0800
+@@ -219,6 +219,3 @@
+ [u'Armin Ronacher, Georg Brandl'], 1)
+ ]
+
+-intersphinx_mapping = {
+- 'http://docs.python.org': None
+-}
diff --git a/dev-python/logbook/logbook-0.4.2.ebuild b/dev-python/logbook/logbook-0.4.2.ebuild
new file mode 100644
index 000000000000..f85f9c15c403
--- /dev/null
+++ b/dev-python/logbook/logbook-0.4.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.4.2.ebuild,v 1.1 2013/06/30 14:50:46 idella4 Exp $
+
+EAPI=5
+# py3.2 fails tests & is marked to be dropped next release which will be very soon
+# along with py2.5. See issue/86
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="http://packages.python.org/Logbook/ http://pypi.python.org/pypi/Logbook"
+SRC_URI="https://github.com/mitsuhiko/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( virtual/python-json[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${P}-objectsinv.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ # https://github.com/mitsuhiko/logbook/issues/86
+ distutils-r1_python_compile
+ pushd "${BUILD_DIR}"/lib/ > /dev/null
+ if [[ "${EPYTHON}" != 'python2.5' ]]; then
+ rm $(find . -name _stringfmt.py) || die
+ fi
+}
+
+python_test() {
+ # https://github.com/mitsuhiko/logbook/issues/86
+ nosetests tests || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}