summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest/ChangeLog5
-rw-r--r--dev-python/pytest/pytest-2.3.4.ebuild16
2 files changed, 16 insertions, 5 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index cc31c5b23dfb..e3aee9fb3a92 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.57 2013/04/02 23:14:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.58 2013/04/04 09:14:30 idella4 Exp $
+
+ 04 Apr 2013; Ian Delaney <idella4@gentoo.org> pytest-2.3.4.ebuild:
+ Test suite fixed for py3, fixes Bug #462552, by patrick
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> pytest-2.3.4.ebuild:
Stable for hppa, wrt bug #462180
diff --git a/dev-python/pytest/pytest-2.3.4.ebuild b/dev-python/pytest/pytest-2.3.4.ebuild
index b9b6bc6ff359..41e0365148d5 100644
--- a/dev-python/pytest/pytest-2.3.4.ebuild
+++ b/dev-python/pytest/pytest-2.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4.ebuild,v 1.14 2013/04/02 23:14:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4.ebuild,v 1.15 2013/04/04 09:14:30 idella4 Exp $
EAPI="5"
@@ -13,12 +13,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+KEYWORDS="alpha ~amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc test"
# When bumping, please check setup.py for the proper py version
PY_VER="1.4.12"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/py-${PY_VER}"
DEPEND="${RDEPEND}
app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]"
@@ -43,7 +43,15 @@ python_compile_all() {
}
python_test() {
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py || die "tests failed with ${EPYTHON}"
+ cd "${BUILD_DIR}"/lib/ || die
+ # pytest.py draws from "${S}" if / when absent of a local testing folder; Bug 462552
+ if [[ "${EPYTHON:6:1}" == 3 ]]; then
+ cp -a "${S}"/testing/ . || die
+ "${PYTHON}" pytest.py || die "tests failed with ${EPYTHON}"
+ rm -rf testing/
+ else
+ "${PYTHON}" pytest.py || die "tests failed with ${EPYTHON}"
+ fi
}
python_install_all() {