summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-visualization/xd3d/ChangeLog10
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff12
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch61
-rw-r--r--sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch10
-rw-r--r--sci-visualization/xd3d/xd3d-8.3.1.ebuild24
5 files changed, 95 insertions, 22 deletions
diff --git a/sci-visualization/xd3d/ChangeLog b/sci-visualization/xd3d/ChangeLog
index ac0bb789fdcf..fd7195554dca 100644
--- a/sci-visualization/xd3d/ChangeLog
+++ b/sci-visualization/xd3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/xd3d
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xd3d/ChangeLog,v 1.8 2008/04/04 10:10:12 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xd3d/ChangeLog,v 1.9 2009/12/04 19:05:23 bicatali Exp $
+
+ 04 Dec 2009; Sébastien Fabbro <bicatali@gentoo.org> xd3d-8.3.1.ebuild,
+ files/xd3d-8.3.1-gentoo.diff, +files/xd3d-8.3.1-parallel.patch,
+ +files/xd3d-8.3.1-rotated.patch:
+ Fixed parallel building, no more forced stripping, added a missing header
+ for QA, removed fortran eclass, switched to EAPI=2
04 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
-files/gentoo-xd3d-8.2.1.diff, -xd3d-8.2.1.ebuild, xd3d-8.3.1.ebuild:
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff b/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff
index 4baf7b3f795b..4e7c52b7724a 100644
--- a/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-gentoo.diff
@@ -45,24 +45,24 @@ diff -Naur RULES.gentoo RULES.gentoo
+#
+# Fortran compiler
+#
-+COMPILF = ##FC##
++COMPILF = $(FC)
+
+#
+# C compiler
+#
-+COMPILC = ##CC##
++COMPILC = $(CC)
+RANLIB = ranlib
+AR = ar r
-+STRIP = strip $@
++STRIP = echo $@
+
+#
+# Options for the Fortran compiler
+#
-+OPTF = ##FFLAGS##
++OPTF = $(FFLAGS)
+#
+# Options for the C compiler
+#
-+OPTC = ##CFLAGS##
++OPTC = $(CFLAGS)
+
+#-----------------------------------------------
+# You should not need to change anything below !
@@ -75,7 +75,7 @@ diff -Naur RULES.gentoo RULES.gentoo
+INCF = -I$(XD3D_DIR)/src/include
+INCC = -I$(LIBX11)/../include
+
-+LINK = $(COMPILF) $(OPTF) -o
++LINK = $(COMPILF) $(LDFLAGS) -o
+LINKOPT = -lc -lm
+LINKOPTX = -L$(LIBX11) -lX11 -lXpm -lc -lm
+LIBRAIRIE = $(LIBDIR)/question_lib.a
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch b/sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch
new file mode 100644
index 000000000000..8161fda3d9a7
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-parallel.patch
@@ -0,0 +1,61 @@
+--- ./src/various/Makefile.orig 2009-12-04 18:16:57.000000000 +0000
++++ ./src/various/Makefile 2009-12-04 18:17:13.000000000 +0000
+@@ -1,6 +1,6 @@
+ include ../../RULES
+
+-all :; make clair clairc3d create_c3d obscur obscurc3d tradavoir translation txt2avoir
++all : clair clairc3d create_c3d obscur obscurc3d tradavoir translation txt2avoir
+
+ clair : clair.f $(LIBRAIRIE) ;\
+ $(LINK) $(BINDIR)/clair $(INCF) clair.f $(LIBRAIRIE) $(LINKOPTX)
+--- ./src/X/Makefile.orig 2009-12-04 18:16:06.000000000 +0000
++++ ./src/X/Makefile 2009-12-04 18:16:36.000000000 +0000
+@@ -118,7 +118,7 @@
+ lib : $(LIBMARC)
+ $(LIBMARC) : $(OBJETS) $(OBJETSMARC) ; $(AR) $@ $(OBJETS) $(OBJETSMARC) ; $(RANLIB) $@
+
+-all :; make ; make lib
++all : lib
+
+ clean : ; /bin/rm -f $(OBJETS) $(LIB) $(LIBMARC)
+
+--- ./Makefile.orig 2009-12-04 18:12:08.000000000 +0000
++++ ./Makefile 2009-12-04 19:06:37.000000000 +0000
+@@ -13,22 +13,24 @@
+ $(BINDIR)/xd3d$(SUFF) \
+ $(BINDIR)/xgraphic$(SUFF)
+
+-all :; make libs ; make utils ; make xgraphic ; make xd3d
++all : libs utils xgraphic xd3d
+
+ install :; /bin/cp -pidvu $(EXE) ./infps $(INSTALL_DIR)
+
+ libs :; \
+-cd $(SRCDIR)/qlib ; echo "---- Building utility lib ----" ; make ;\
+-cd $(SRCDIR)/interp ; echo "---- Building parsing lib ----" ; make ;\
+-cd $(SRCDIR)/X ; echo "---- Building X interface lib ----" ; make
+-
+-xd3d :; cd $(SRCDIR)/d3d ; echo "---- Building xd3d ----" ; make
+-
+-xgraphic :; cd $(SRCDIR)/graphic ; echo "---- Building xgraphic ----" ; make
+-
+-utils :; \
+-echo " ---- Building various utils ----" ;\
+-cd $(SRCDIR)/trad_nopo ; make ;\
+-cd $(SRCDIR)/various ; make
++cd $(SRCDIR)/qlib ; echo "---- Building utility lib ----" ; $(MAKE) ;\
++cd $(SRCDIR)/interp ; echo "---- Building parsing lib ----" ;$(MAKE) ;\
++cd $(SRCDIR)/X ; echo "---- Building X interface lib ----" ; $(MAKE)
++
++xd3d : libs
++ cd $(SRCDIR)/d3d ; echo "---- Building xd3d ----" ; $(MAKE)
++
++xgraphic : libs
++ cd $(SRCDIR)/graphic ; echo "---- Building xgraphic ----" ; $(MAKE)
++
++utils : libs
++ echo " ---- Building various utils ----" ;\
++ cd $(SRCDIR)/trad_nopo ; $(MAKE) ;\
++ cd $(SRCDIR)/various ; $(MAKE)
+
+ clean :; /bin/rm -f $(SRCDIR)/*/*.o $(LIBRAIRIE) $(MYXLIB) $(INTERP) $(EXE)
diff --git a/sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch b/sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch
new file mode 100644
index 000000000000..9e66dcab586c
--- /dev/null
+++ b/sci-visualization/xd3d/files/xd3d-8.3.1-rotated.patch
@@ -0,0 +1,10 @@
+--- src/X/rotated.c.orig 2009-12-04 18:09:55.000000000 +0000
++++ src/X/rotated.c 2009-12-04 18:10:37.000000000 +0000
+@@ -29,6 +29,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <string.h>
++#include <stdlib.h>
+ #include "rotated.h"
+
+
diff --git a/sci-visualization/xd3d/xd3d-8.3.1.ebuild b/sci-visualization/xd3d/xd3d-8.3.1.ebuild
index ae832b91862b..3974d26a083f 100644
--- a/sci-visualization/xd3d/xd3d-8.3.1.ebuild
+++ b/sci-visualization/xd3d/xd3d-8.3.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xd3d/xd3d-8.3.1.ebuild,v 1.2 2008/04/04 10:10:12 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xd3d/xd3d-8.3.1.ebuild,v 1.3 2009/12/04 19:05:23 bicatali Exp $
-inherit fortran toolchain-funcs multilib
+EAPI=2
+inherit eutils toolchain-funcs
DESCRIPTION="scientific visualization tool"
HOMEPAGE="http://www.cmap.polytechnique.fr/~jouve/xd3d/"
@@ -13,34 +14,29 @@ KEYWORDS="~ppc ~ppc64 ~x86 ~amd64"
IUSE=""
RDEPEND="x11-libs/libXpm"
-
DEPEND="${RDEPEND}
app-shells/tcsh"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-parallel.patch
+ epatch "${FILESDIR}"/${P}-rotated.patch
}
-src_compile() {
+src_configure() {
+ export FC=$(tc-getFC)
sed -e "s:##D##:${D}:" \
-e "s:##lib##:$(get_libdir):" \
- -e "s:##FC##:${FORTRANC}:" \
- -e "s:##CC##:$(tc-getCC):" \
- -e "s:##FFLAGS##:${FFLAGS}:" \
- -e "s:##CFLAGS##:${CFLAGS}:" \
-i RULES.gentoo \
|| die "failed to set up RULES.gentoo"
./configure -arch=gentoo || die "configure failed."
- emake || die "emake failed."
}
src_install() {
dodir /usr/bin
emake install || die "emake install failed"
- dodoc BUGS CHANGELOG FAQ FORMATS INSTALL README || die
+ dodoc BUGS CHANGELOG FAQ FORMATS README
insinto /usr/share/doc/${PF}
doins Manuals/* || die