summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/gd/gd-2.0.28.ebuild10
-rw-r--r--net-analyzer/ntop/ntop-3.0.ebuild22
-rw-r--r--net-irc/dircproxy/dircproxy-1.1.0.ebuild14
3 files changed, 35 insertions, 11 deletions
diff --git a/media-libs/gd/gd-2.0.28.ebuild b/media-libs/gd/gd-2.0.28.ebuild
index e063158f056c..daac03c3ddbf 100644
--- a/media-libs/gd/gd-2.0.28.ebuild
+++ b/media-libs/gd/gd-2.0.28.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.28.ebuild,v 1.1 2004/07/22 19:52:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.28.ebuild,v 1.2 2004/07/30 20:28:20 vapier Exp $
+
+inherit gnuconfig
DESCRIPTION="A graphics library for fast image creation"
HOMEPAGE="http://www.boutell.com/gd/"
@@ -16,6 +18,12 @@ DEPEND="jpeg? ( >=media-libs/jpeg-6b )
truetype? ( >=media-libs/freetype-2.1.5 )
X? ( virtual/x11 )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+}
+
src_compile() {
econf \
`use_with png` \
diff --git a/net-analyzer/ntop/ntop-3.0.ebuild b/net-analyzer/ntop/ntop-3.0.ebuild
index eaa9e77f9f34..6893b07fb583 100644
--- a/net-analyzer/ntop/ntop-3.0.ebuild
+++ b/net-analyzer/ntop/ntop-3.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.0.ebuild,v 1.8 2004/07/25 13:35:01 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.0.ebuild,v 1.9 2004/07/30 20:30:20 vapier Exp $
+
+inherit gnuconfig
DESCRIPTION="tool that shows network usage like top"
HOMEPAGE="http://www.ntop.org/ntop.html"
@@ -20,19 +22,25 @@ DEPEND=">=sys-libs/gdbm-1.8.0
readline? ( >=sys-libs/readline-4.1 )
ncurses? ( sys-libs/ncurses )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+}
+
src_compile() {
local myconf
- use readline || myconf="${myconf} --without-readline"
- use tcpd || myconf="${myconf} --with-tcpwrap"
- use ssl || myconf="${myconf} --without-ssl"
- use ncurses || myconf="${myconf} --without-curses"
+ use readline || myconf="${myconf} --without-readline"
+ use tcpd || myconf="${myconf} --with-tcpwrap"
+ use ssl || myconf="${myconf} --without-ssl"
+ use ncurses || myconf="${myconf} --without-curses"
econf ${myconf} || die "configure problem"
make || die "compile problem"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "install problem"
# fixme: bad handling of plugins (in /usr/lib with unsuggestive names)
@@ -40,7 +48,7 @@ src_install () {
doman ntop.8
- dodoc AUTHORS CONTENTS COPYING ChangeLog MANIFESTO NEWS
+ dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
dodoc PORTING README SUPPORT_NTOP.txt THANKS docs/*
dohtml ntop.html
diff --git a/net-irc/dircproxy/dircproxy-1.1.0.ebuild b/net-irc/dircproxy/dircproxy-1.1.0.ebuild
index 7c5eec4132bd..a45096e38e53 100644
--- a/net-irc/dircproxy/dircproxy-1.1.0.ebuild
+++ b/net-irc/dircproxy/dircproxy-1.1.0.ebuild
@@ -1,18 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/dircproxy/dircproxy-1.1.0.ebuild,v 1.4 2004/07/01 22:21:03 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/dircproxy/dircproxy-1.1.0.ebuild,v 1.5 2004/07/30 20:31:51 vapier Exp $
+
+inherit gnuconfig
DESCRIPTION="an IRC proxy server"
-SRC_URI="http://www.securiweb.net/pub/oss/dircproxy/unstable/${P}.tar.gz"
HOMEPAGE="http://dircproxy.securiweb.net/"
+SRC_URI="http://www.securiweb.net/pub/oss/dircproxy/unstable/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha"
IUSE=""
DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+}
+
src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc AUTHORS ChangeLog FAQ NEWS PROTOCOL README* TODO INSTALL