summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/kon2/ChangeLog6
-rw-r--r--app-i18n/kon2/files/kon2-0.3.9b-gcc34.patch11
-rw-r--r--app-i18n/kon2/kon2-0.3.9b-r1.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/app-i18n/kon2/ChangeLog b/app-i18n/kon2/ChangeLog
index 946d95171ac3..77f6e1a0b053 100644
--- a/app-i18n/kon2/ChangeLog
+++ b/app-i18n/kon2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/kon2
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kon2/ChangeLog,v 1.7 2004/06/24 21:49:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kon2/ChangeLog,v 1.8 2004/11/19 23:26:08 sekretarz Exp $
+
+ 20 Nov 2004; Karol Wojtaszek <sekretarz@gentoo.org> +files/kon2-0.3.9b-gcc34.patch,
+ kon2-0.3.9b-r1.ebuild:
+ Fixed gcc-3.4 compile issues and ~amd64 keyworded, bug #68005
29 Dec 2003; Mamoru KOMACHI <usata@gentoo.org> kon2-0.3.9b-r1.ebuild,
files/kon2-0.3.9b-gentoo.patch:
diff --git a/app-i18n/kon2/files/kon2-0.3.9b-gcc34.patch b/app-i18n/kon2/files/kon2-0.3.9b-gcc34.patch
new file mode 100644
index 000000000000..ea42ff94a947
--- /dev/null
+++ b/app-i18n/kon2/files/kon2-0.3.9b-gcc34.patch
@@ -0,0 +1,11 @@
+diff -Naur kon2-0.3.9b.orig/src/term.c kon2-0.3.9b/src/term.c
+--- kon2-0.3.9b.orig/src/term.c 2004-11-20 00:15:35.000000000 +0100
++++ kon2-0.3.9b/src/term.c 2004-11-20 00:16:21.888163632 +0100
+@@ -89,6 +89,7 @@
+ };
+
+ static struct initInfo init;
++static void ChangeNewConsole();
+
+ static void CleanUp(void)
+ {
diff --git a/app-i18n/kon2/kon2-0.3.9b-r1.ebuild b/app-i18n/kon2/kon2-0.3.9b-r1.ebuild
index 719d2b8e9cc9..82c673c326d8 100644
--- a/app-i18n/kon2/kon2-0.3.9b-r1.ebuild
+++ b/app-i18n/kon2/kon2-0.3.9b-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kon2/kon2-0.3.9b-r1.ebuild,v 1.8 2004/06/28 01:50:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kon2/kon2-0.3.9b-r1.ebuild,v 1.9 2004/11/19 23:26:08 sekretarz Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.linet.gr.jp/pub/KON/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
IUSE=""
DEPEND="virtual/libc"
@@ -24,6 +24,7 @@ src_unpack() {
epatch ${FILESDIR}/${P}-exec.patch
epatch ${FILESDIR}/${P}-bufover-fix.patch
epatch ${FILESDIR}/${P}-racecondition-fix3.patch
+ epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {