summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/xchat/ChangeLog10
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.9-r11
-rw-r--r--net-irc/xchat/xchat-1.8.9-r1.ebuild98
3 files changed, 108 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 36a0c4788b9a..d7b59b4c4d38 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.8 2002/06/11 21:43:52 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.9 2002/06/27 12:20:27 seemant Exp $
+
+
+*xchat-1.8.9-r1 (27 Jun 2002)
+
+ 27 Jun 2002; Seemant Kulleen <seemant@gentoo.org> xchat-1.8.9-r1.ebuild
+ files/digest-xchat-1.8.9-r1 :
+
+ cleaned up, so things are not installed in /share
*xchat-1.9.1.ebuild (11 Jun 2002)
11 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> xchat-1.9.1.ebuild:
diff --git a/net-irc/xchat/files/digest-xchat-1.8.9-r1 b/net-irc/xchat/files/digest-xchat-1.8.9-r1
new file mode 100644
index 000000000000..2979470d8a7f
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.8.9-r1
@@ -0,0 +1 @@
+MD5 a7d3723053fbee23399647f88afd15fa xchat-1.8.9.tar.bz2 747762
diff --git a/net-irc/xchat/xchat-1.8.9-r1.ebuild b/net-irc/xchat/xchat-1.8.9-r1.ebuild
new file mode 100644
index 000000000000..bea8768b18c0
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.9-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyrigth 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.9-r1.ebuild,v 1.1 2002/06/27 12:20:27 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ python? ( >=dev-lang/python-2.2-r7 )
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+
+ use python && ( \
+ local mylibs=`/usr/bin/python-config`
+ sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' \
+ configure.orig > configure
+ )
+}
+
+src_compile() {
+
+ local myopts myflags
+
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt --disable-gdk-pixbuf"
+
+ use gnome \
+ && CFLAGS="${CFLAGS} -I/usr/include/orbit-1.0" \
+ || myopts="${myopts} --disable-gnome"
+
+ use gtk \
+ || myopts="${myopts} --disable-gtkfe"
+
+ use ssl \
+ && myopts="${myopts} --enable-openssl"
+
+ use perl \
+ || myopts="${myopts} --disable-perl"
+
+ use nls \
+ && myopts="${myopts} --enable-hebrew --enable-japanese-conv" \
+ || myopts="${myopts} --disable-nls"
+
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6"
+
+ use python \
+ && myflags="`python-config`" \
+ && myopts="${myopts} --enable-python"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ use kde && ( \
+ make \
+ prefix=${D}/usr \
+ utildir=${D}${KDEDIR}/share/applnk/Internet \
+ install || die
+ ) || ( \
+ make \
+ prefix=${D}/usr \
+ install || die
+ )
+
+ use gnome && ( \
+ insinto /usr/share/gnome/apps/Internet
+ doins xchat.desktop
+ )
+
+ dodoc AUTHORS COPYING ChangeLog README
+}