summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/qsynth/ChangeLog10
-rw-r--r--media-sound/qsynth/Manifest6
-rw-r--r--media-sound/qsynth/metadata.xml8
-rw-r--r--media-sound/qsynth/qsynth-0.1.0.ebuild17
4 files changed, 31 insertions, 10 deletions
diff --git a/media-sound/qsynth/ChangeLog b/media-sound/qsynth/ChangeLog
index 36160a3d7ea8..53b58178af1e 100644
--- a/media-sound/qsynth/ChangeLog
+++ b/media-sound/qsynth/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/qsynth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.2 2004/01/15 05:38:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.3 2004/06/20 14:38:19 fvdpol Exp $
+
+ 20 Jun 2004; Frank van de Pol <fvdpol@gentoo.org> metadata.xml,
+ qsynth-0.1.0.ebuild:
+ Fixed sandbox violations, closing bug #45289.
+
+ (note: Package was marked stable x86; left it that way since this is only a
+ correction in the ebuild. Flagging it ~x86 might break people's systems who
+ managed to install it.)
*qsynth-0.1.0 (15 Jan 2004)
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 936920bfcdb0..69b21e58aee1 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1,4 +1,4 @@
-MD5 e184ca55e21e855bf7efa66f8225a2f0 qsynth-0.1.0.ebuild 567
+MD5 ce70645f6816aecb0c5f6f8097801330 ChangeLog 740
+MD5 bed98f5cc72fd626b638bfcae4593ce6 metadata.xml 647
+MD5 e794b50e74261c3feaafc9ebd1f76ec0 qsynth-0.1.0.ebuild 576
MD5 fde45970ba4d6681ef829f9fde4b7e72 files/digest-qsynth-0.1.0 63
-MD5 8dd02f90c644e320153e7a9e74c46184 ChangeLog 418
-MD5 d0d7ea03e238a808414b4426394c100f metadata.xml 221
diff --git a/media-sound/qsynth/metadata.xml b/media-sound/qsynth/metadata.xml
index ea12fab7b274..e70dd2ba42f6 100644
--- a/media-sound/qsynth/metadata.xml
+++ b/media-sound/qsynth/metadata.xml
@@ -5,4 +5,12 @@
<maintainer>
<email>sound@gentoo.org</email>
</maintainer>
+<longdescription>
+QSynth is a fluidsynth GUI front-end application written in C++ around the
+Qt3 toolkit using Qt Designer. Eventually it may evolve into a softsynth
+management application allowing the user to control and manage a variety of
+command line softsynth but for the moment it wraps the excellent FluidSynth.
+FluidSynth is a command line software synthesiser based on the Soundfont
+specification.
+</longdescription>
</pkgmetadata>
diff --git a/media-sound/qsynth/qsynth-0.1.0.ebuild b/media-sound/qsynth/qsynth-0.1.0.ebuild
index 9e38c8a8ddb9..3a1ae7d047be 100644
--- a/media-sound/qsynth/qsynth-0.1.0.ebuild
+++ b/media-sound/qsynth/qsynth-0.1.0.ebuild
@@ -1,22 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.1.0.ebuild,v 1.1 2004/01/15 01:57:17 wmertens Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.1.0.ebuild,v 1.2 2004/06/20 14:38:19 fvdpol Exp $
DESCRIPTION="A Qt application to control FluidSynth"
HOMEPAGE="http://qsynth.sf.net/"
SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
-RESTRICT="nomirror"
-
LICENSE="GPL-2"
+
SLOT="0"
-KEYWORDS="x86"
+IUSE=""
+KEYWORDS="x86 ~amd64"
DEPEND="virtual/glibc
>=x11-libs/qt-3.1.1
media-sound/fluidsynth"
+src_compile() {
+ addwrite ${QTDIR}/etc/settings
+ econf || die
+ einstall || die
+}
+
src_install () {
einstall || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog README TODO
}