summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/agg/ChangeLog12
-rw-r--r--x11-libs/agg/agg-2.5-r1.ebuild58
-rw-r--r--x11-libs/agg/files/2.5/02_maintainer_mode.patch21
-rw-r--r--x11-libs/agg/files/2.5/03_pkg_config_pic.patch19
-rw-r--r--x11-libs/agg/files/2.5/04_no_rpath.patch19
-rw-r--r--x11-libs/agg/metadata.xml11
6 files changed, 134 insertions, 6 deletions
diff --git a/x11-libs/agg/ChangeLog b/x11-libs/agg/ChangeLog
index 210c6db70aac..c09239b3dd42 100644
--- a/x11-libs/agg/ChangeLog
+++ b/x11-libs/agg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/agg
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/agg/ChangeLog,v 1.15 2008/11/30 18:48:35 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/agg/ChangeLog,v 1.16 2009/03/26 14:00:32 scarabeus Exp $
+
+*agg-2.5-r1 (26 Mar 2009)
+
+ 26 Mar 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +files/2.5/02_maintainer_mode.patch, +files/2.5/03_pkg_config_pic.patch,
+ +files/2.5/04_no_rpath.patch, metadata.xml, +agg-2.5-r1.ebuild:
+ Apply patches from debian. Clean up deps. Move to eapi2. Remove sdl
+ useflag and introduce new gpc useflag.
30 Nov 2008; Raúl Porcel <armin76@gentoo.org> agg-2.5.ebuild:
sparc stable wrt #244336
diff --git a/x11-libs/agg/agg-2.5-r1.ebuild b/x11-libs/agg/agg-2.5-r1.ebuild
new file mode 100644
index 000000000000..d25cb69deb7b
--- /dev/null
+++ b/x11-libs/agg/agg-2.5-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/agg/agg-2.5-r1.ebuild,v 1.1 2009/03/26 14:00:32 scarabeus Exp $
+
+EAPI="2"
+
+inherit eutils autotools base
+
+DESCRIPTION="Anti-Grain Geometry - A High Quality Rendering Engine for C++"
+HOMEPAGE="http://antigrain.com/"
+SRC_URI="http://antigrain.com/${P}.tar.gz"
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="+gpc +truetype +X"
+
+# preffer X with enabled xcb, really
+RDEPEND="
+ media-libs/libsdl[X?]
+ X? ( x11-libs/libX11[xcb] )
+ truetype? ( media-libs/freetype:2 )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+"
+
+# taken from debian
+PATCHES=(
+ "${FILESDIR}/${PV}/02_maintainer_mode.patch"
+ "${FILESDIR}/${PV}/03_pkg_config_pic.patch"
+ "${FILESDIR}/${PV}/04_no_rpath.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+ sed -r -i \
+ -e 's:^(.*) -L@.*:\1:' \
+ src/platform/X11/Makefile.am || die "Failed to sed"
+ eautoreconf
+}
+
+src_configure() {
+ # examples are not (yet) installed, so do not compile them
+ # sdl is harddep only sdl-tests are optional so we enable them anyway
+ econf \
+ --enable-ctrl \
+ --enable-sdltest \
+ --disable-examples \
+ --disable-dependency-tracking \
+ $(use_enable gpc gpc) \
+ $(use_enable truetype freetype) \
+ $(use_with X x)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc readme authors ChangeLog news
+}
diff --git a/x11-libs/agg/files/2.5/02_maintainer_mode.patch b/x11-libs/agg/files/2.5/02_maintainer_mode.patch
new file mode 100644
index 000000000000..4c65c9723e34
--- /dev/null
+++ b/x11-libs/agg/files/2.5/02_maintainer_mode.patch
@@ -0,0 +1,21 @@
+
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 02_maintainer_mode.dpatch by <rodrigo@nul-unu.com>
+##
+## DP: Use AM_MAINTAINER_MODE, to avoid re-running autotools
+## DP: except when explicitely called in debian/rules
+
+@DPATCH@
+diff -urNad agg-2.5+dfsg~/configure.in agg-2.5+dfsg/configure.in
+--- agg-2.5+dfsg~/configure.in 2007-07-21 19:58:06.966030999 -0500
++++ agg-2.5+dfsg/configure.in 2007-07-21 19:58:33.595695250 -0500
+@@ -2,7 +2,7 @@
+ AC_CANONICAL_TARGET
+ AC_CONFIG_HEADERS(include/config.h)
+ AM_INIT_AUTOMAKE(agg, 2.5.0)
+-
++AM_MAINTAINER_MODE
+
+ dnl Checks for programs.
+ AC_PROG_CC
+
diff --git a/x11-libs/agg/files/2.5/03_pkg_config_pic.patch b/x11-libs/agg/files/2.5/03_pkg_config_pic.patch
new file mode 100644
index 000000000000..7a7b21bcd990
--- /dev/null
+++ b/x11-libs/agg/files/2.5/03_pkg_config_pic.patch
@@ -0,0 +1,19 @@
+
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 03_pkg_config_pic.dpatch by <rene@zero>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad agg-2.3~/libagg.pc.in agg-2.3/libagg.pc.in
+--- agg-2.3~/libagg.pc.in 2005-02-18 03:27:48.000000000 +0100
++++ agg-2.3/libagg.pc.in 2006-03-01 18:08:26.906950512 +0100
+@@ -6,5 +6,5 @@
+ Name: libagg
+ Description: Anti Grain Geometry - A High Quality Rendering Engine for C++
+ Version: @VERSION@
+-Libs: -L${libdir} -Wl,-rpath,${exec_prefix}/lib -lagg
++Libs: -L${libdir} -Wl,-rpath,${exec_prefix}/lib -lagg_pic
+ Cflags: -I${includedir}
+
diff --git a/x11-libs/agg/files/2.5/04_no_rpath.patch b/x11-libs/agg/files/2.5/04_no_rpath.patch
new file mode 100644
index 000000000000..75e1936286d5
--- /dev/null
+++ b/x11-libs/agg/files/2.5/04_no_rpath.patch
@@ -0,0 +1,19 @@
+
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 04_no_rpath.dpatch by <rene@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad agg-2.4~/libagg.pc.in agg-2.4/libagg.pc.in
+--- agg-2.4~/libagg.pc.in 2006-07-10 11:27:16.000000000 +0200
++++ agg-2.4/libagg.pc.in 2006-07-10 11:28:51.000000000 +0200
+@@ -6,5 +6,5 @@
+ Name: libagg
+ Description: Anti Grain Geometry - A High Quality Rendering Engine for C++
+ Version: @VERSION@
+-Libs: -L${libdir} -Wl,-rpath,${exec_prefix}/lib -lagg_pic
++Libs: -L${libdir} -lagg_pic
+ Cflags: -I${includedir}
+
diff --git a/x11-libs/agg/metadata.xml b/x11-libs/agg/metadata.xml
index 62e201f5e48b..6d444ab35207 100644
--- a/x11-libs/agg/metadata.xml
+++ b/x11-libs/agg/metadata.xml
@@ -2,8 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>no-herd</herd>
- <maintainer>
- <email>genstef@gentoo.org</email>
- <name>Stefan Schweizer</name>
- </maintainer>
+<maintainer>
+ <email>genstef@gentoo.org</email>
+ <name>Stefan Schweizer</name>
+</maintainer>
+<use>
+ <flag name="gpc">Enable gpc polygon clipper library</flag>
+</use>
</pkgmetadata>