summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/lesstif/ChangeLog11
-rw-r--r--x11-libs/lesstif/files/digest-lesstif-0.93.36-r11
-rw-r--r--x11-libs/lesstif/lesstif-0.93.36-r1.ebuild57
3 files changed, 67 insertions, 2 deletions
diff --git a/x11-libs/lesstif/ChangeLog b/x11-libs/lesstif/ChangeLog
index ffff47a8745c..1ec4d8d27c3a 100644
--- a/x11-libs/lesstif/ChangeLog
+++ b/x11-libs/lesstif/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for x11-lib/lesstif
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/lesstif/ChangeLog,v 1.1 2002/10/21 05:17:11 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/lesstif/ChangeLog,v 1.2 2002/11/12 12:36:49 cretin Exp $
+
+*lesstif-0.93.36-r1 (12 Nov 2002)
+
+ 12 Nov 2002; Stefan Jones <cretin@gentoo.org> lesstif-0.93.36-r1.ebuild :
+
+ Updated ebuild to build the static library which is needed by the java
+ source ebuild.
*lesstif-0.93.36 (21 Oct 2002)
21 Oct 2002; Arcady Genkin <agenkin@gentoo.org> lesstif-0.93.36.ebuild :
Initial version of the ebuild, based on submission by Jianghai Zhu
- <zhu5@purdue.edu>. \ No newline at end of file
+ <zhu5@purdue.edu>.
diff --git a/x11-libs/lesstif/files/digest-lesstif-0.93.36-r1 b/x11-libs/lesstif/files/digest-lesstif-0.93.36-r1
new file mode 100644
index 000000000000..572e657b1cbd
--- /dev/null
+++ b/x11-libs/lesstif/files/digest-lesstif-0.93.36-r1
@@ -0,0 +1 @@
+MD5 bdca805aa4738f45b8fd50f8d37c88b5 lesstif-0.93.36.tar.bz2 2483486
diff --git a/x11-libs/lesstif/lesstif-0.93.36-r1.ebuild b/x11-libs/lesstif/lesstif-0.93.36-r1.ebuild
new file mode 100644
index 000000000000..09eee2d65aff
--- /dev/null
+++ b/x11-libs/lesstif/lesstif-0.93.36-r1.ebuild
@@ -0,0 +1,57 @@
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/lesstif/lesstif-0.93.36-r1.ebuild,v 1.1 2002/11/12 12:36:49 cretin Exp $
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+DESCRIPTION="An OSF/Motif(R) clone."
+HOMEPAGE="http://www.lesstif.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="LGPL"
+
+DEPEND="virtual/x11"
+
+KEYWORDS="x86"
+SLOT="0"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}/scripts/autoconf
+ sed -e "/^aclocaldir =/ a DESTDIR = ${D}" \
+ Makefile.in > Makefile.in.hacked
+ mv Makefile.in.hacked Makefile.in || die
+
+}
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-static \
+ --with-x || die "./configure failed"
+ emake CFLAGS="${CFLAGS}" || die
+
+}
+
+src_install() {
+
+ emake prefix=${D}/usr \
+ exec_prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dosym /usr/lib/libXm.so.2.0.1 /usr/lib/libXm.so.1
+
+ dodir /usr/share
+ mv ${D}/usr/man ${D}/usr/share/
+ dodir /usr/share/doc/${P}
+ mv ${D}/usr/LessTif/* ${D}/usr/share/doc/${P}/
+ # The LessTif directory should be empty now.
+ rmdir ${D}/usr/LessTif || die
+
+}