summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-wireless/rfkill/ChangeLog7
-rw-r--r--net-wireless/rfkill/rfkill-0.5.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/net-wireless/rfkill/ChangeLog b/net-wireless/rfkill/ChangeLog
index 6b9b4d331b09..a03c0ab15b29 100644
--- a/net-wireless/rfkill/ChangeLog
+++ b/net-wireless/rfkill/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/rfkill
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/rfkill/ChangeLog,v 1.14 2013/02/02 04:36:16 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/rfkill/ChangeLog,v 1.15 2013/05/04 16:29:29 zerochaos Exp $
+
+*rfkill-0.5 (04 May 2013)
+
+ 04 May 2013; Rick Farina <zerochaos@gentoo.org> +rfkill-0.5.ebuild:
+ new NFC support
02 Feb 2013; Rick Farina <zerochaos@gentoo.org> rfkill-0.4.ebuild:
upstream moved locations, and I prefer XZ while we are at it
diff --git a/net-wireless/rfkill/rfkill-0.5.ebuild b/net-wireless/rfkill/rfkill-0.5.ebuild
new file mode 100644
index 000000000000..9fc72c33b040
--- /dev/null
+++ b/net-wireless/rfkill/rfkill-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/rfkill/rfkill-0.5.ebuild,v 1.1 2013/05/04 16:29:29 zerochaos Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to read and control rfkill status through /dev/rfkill"
+HOMEPAGE="http://wireless.kernel.org/en/users/Documentation/rfkill"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+CC=$(tc-getCC)
+LD=$(tc-getLD)
+
+src_compile() {
+ emake V=1 || die "Failed to compile"
+}
+
+src_install() {
+ emake install V=1 DESTDIR="${D}" || die "Failed to install"
+}