summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/oniguruma/ChangeLog12
-rw-r--r--dev-libs/oniguruma/files/oniguruma-5.9.2-makefile.patch42
-rw-r--r--dev-libs/oniguruma/metadata.xml8
-rw-r--r--dev-libs/oniguruma/oniguruma-5.9.2-r1.ebuild38
4 files changed, 98 insertions, 2 deletions
diff --git a/dev-libs/oniguruma/ChangeLog b/dev-libs/oniguruma/ChangeLog
index 448cf3600151..2336ac768b04 100644
--- a/dev-libs/oniguruma/ChangeLog
+++ b/dev-libs/oniguruma/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/oniguruma
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/oniguruma/ChangeLog,v 1.51 2012/05/04 14:35:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/oniguruma/ChangeLog,v 1.52 2012/08/17 14:41:06 naota Exp $
+
+*oniguruma-5.9.2-r1 (17 Aug 2012)
+
+ 17 Aug 2012; Naohiro Aota <naota@gentoo.org>
+ +files/oniguruma-5.9.2-makefile.patch, +oniguruma-5.9.2-r1.ebuild,
+ metadata.xml, oniguruma-5.9.2.ebuild:
+ Patch Makefile.am not to include $(includedir). Patch-By: John Keeping
+ #430476; Patch configure.in to fix invalid test statement; Add new USE flags
+ to configure some options.
04 May 2012; Alexis Ballier <aballier@gentoo.org> oniguruma-5.9.2.ebuild:
keyword ~amd64-fbsd
@@ -197,4 +206,3 @@
27 Nov 2003; Mamoru KOMACHI <usata@gentoo.org> oniguruma-1.9.5.ebuild:
Initial import
-
diff --git a/dev-libs/oniguruma/files/oniguruma-5.9.2-makefile.patch b/dev-libs/oniguruma/files/oniguruma-5.9.2-makefile.patch
new file mode 100644
index 000000000000..bd594e395631
--- /dev/null
+++ b/dev-libs/oniguruma/files/oniguruma-5.9.2-makefile.patch
@@ -0,0 +1,42 @@
+--- Makefile.am.orig 2012-08-08 10:29:20.313862377 +0100
++++ Makefile.am 2012-08-08 10:29:30.793762591 +0100
+@@ -5,7 +5,7 @@
+
+ #AM_CFLAGS = -DNOT_RUBY
+ AM_CFLAGS =
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ SUBDIRS = . sample
+
+--- sample/Makefile.am.orig 2012-08-08 11:37:49.813512228 +0100
++++ sample/Makefile.am 2012-08-08 11:38:00.289410756 +0100
+@@ -2,7 +2,7 @@
+
+ libname = $(top_builddir)/libonig.la
+ LDADD = $(libname)
+-INCLUDES = -I$(top_srcdir) -I$(includedir)
++INCLUDES = -I$(top_srcdir)
+
+ encode_SOURCES = encode.c
+ listcap_SOURCES = listcap.c
+--- configure.in.orig
++++ configure.in
+@@ -23,7 +23,7 @@
+ AC_ARG_ENABLE(combination-explosion-check,
+ [ --enable-combination-explosion-check enable combination explosion check],
+ [comb_expl_check=$enableval])
+-if test $comb_expl_check = yes; then
++if test "x$comb_expl_check" = xyes; then
+ AC_DEFINE(USE_COMBINATION_EXPLOSION_CHECK,1,[Define if combination explosion check])
+ fi
+
+@@ -31,7 +31,7 @@
+ AC_ARG_ENABLE(crnl-as-line-terminator,
+ [ --enable-crnl-as-line-terminator enable CR+NL as line terminator],
+ [crnl_as_line_terminator=$enableval])
+-if test $crnl_as_line_terminator = yes; then
++if test "x$crnl_as_line_terminator" = xyes; then
+ AC_DEFINE(USE_CRNL_AS_LINE_TERMINATOR,1,[Define if enable CR+NL as line terminator])
+ fi
+
diff --git a/dev-libs/oniguruma/metadata.xml b/dev-libs/oniguruma/metadata.xml
index 5cdf38dd263b..cbabf9d6775f 100644
--- a/dev-libs/oniguruma/metadata.xml
+++ b/dev-libs/oniguruma/metadata.xml
@@ -8,4 +8,12 @@ this library is that different character encoding for every regular
expression object can be specified. (Supported character encodings:
ASCII, UTF-8, EUC-JP, Shift_JIS)
</longdescription>
+<use>
+ <flag name="combination-explosion-check">
+ enable combination explosion check
+ </flag>
+ <flag name="crnl-as-line-terminator">
+ enable CR+NL as line terminator
+ </flag>
+</use>
</pkgmetadata>
diff --git a/dev-libs/oniguruma/oniguruma-5.9.2-r1.ebuild b/dev-libs/oniguruma/oniguruma-5.9.2-r1.ebuild
new file mode 100644
index 000000000000..a6cdfc1e2412
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-5.9.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/oniguruma/oniguruma-5.9.2-r1.ebuild,v 1.1 2012/08/17 14:41:06 naota Exp $
+
+EAPI=4
+
+inherit eutils autotools-utils
+
+MY_P=onig-${PV}
+
+DESCRIPTION="a regular expression library for different character encodings"
+HOMEPAGE="http://www.geocities.jp/kosako3/oniguruma"
+SRC_URI="http://www.geocities.jp/kosako3/oniguruma/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="combination-explosion-check crnl-as-line-terminator static-libs"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+DOCS=( AUTHORS HISTORY README{,.ja} doc/{API,FAQ,RE}{,.ja} )
+# Needed for a sane .so versionning on fbsd, please dont drop
+AUTOTOOLS_AUTORECONF=1
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable combination-explosion-check)
+ $(use_enable crnl-as-line-terminator)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use static-libs || prune_libtool_files
+}