summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/openmm/ChangeLog5
-rw-r--r--sci-libs/openmm/openmm-4.1.1.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/sci-libs/openmm/ChangeLog b/sci-libs/openmm/ChangeLog
index 12300238d97a..98b54be7601e 100644
--- a/sci-libs/openmm/ChangeLog
+++ b/sci-libs/openmm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/openmm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/openmm/ChangeLog,v 1.1 2012/11/30 20:45:20 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/openmm/ChangeLog,v 1.2 2012/12/26 18:48:19 ottxor Exp $
+
+ 26 Dec 2012; Christoph Junghans <ottxor@gentoo.org> openmm-4.1.1.ebuild:
+ fixed cmake options
*openmm-4.1.1 (30 Nov 2012)
diff --git a/sci-libs/openmm/openmm-4.1.1.ebuild b/sci-libs/openmm/openmm-4.1.1.ebuild
index a22e148f1938..9d664c2da021 100644
--- a/sci-libs/openmm/openmm-4.1.1.ebuild
+++ b/sci-libs/openmm/openmm-4.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/openmm/openmm-4.1.1.ebuild,v 1.1 2012/11/30 20:45:20 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/openmm/openmm-4.1.1.ebuild,v 1.2 2012/12/26 18:48:19 ottxor Exp $
EAPI="5"
@@ -33,9 +33,12 @@ pkg_nofetch(){
src_configure() {
mycmakeargs=(
+ $(cmake-utils_use cuda OPENMM_BUILD_CUDA_LIB)
+ $(cmake-utils_use opencl OPENMM_BUILD_OPENCL_LIB)
+ $(cmake-utils_use !cuda CUDA_BUILD_CUBIN)
$(cmake-utils_use opencl OPENMM_BUILD_RPMD_PLUGIN)
$(cmake-utils_use opencl OPENMM_BUILD_PYTHON_WRAPPERS)
- ) # workarounds for broken autodetection
+ ) # last 3 options are workarounds for broken build system
cmake-utils_src_configure
}